WineHQ
Internet Explorer 8.0 for NT 5.1 (32-bit)



Category: Main > Networking & Communication > Browsers > Internet Explorer > 8.0 for NT 5.1 (32-bit)


NameInternet Explorer
Version8.0 for NT 5.1 (32-bit)
License Free to use
URLhttp://www.microsoft.com/ie
Votes 2
RatingBronze
Wine Version1.7.15
Free Download English Download
Free Download French Download
Maintainers of this version:
Description
Internet Explorer 8 for Windows XP (32-bit)
Selected Test Results (selected in 'Test Results' table below)

What works
Successfully browses HTTP pages using default settings. Able to add Favorites to side bar menu.


What does not
Repeatedly claims search provider was corrupted. Unable to access HTTPS pages, even with crypt32.dll set to (native,builtin) and even after manually installing crypt32.dll. Favorites menu in menu bar is blank. Tools->About Internet Explorer reports a Cipher Strength of 0-bit.


What was not tested
Anything not listed above.


Additional Comments

Installed via:

winetricks ie8 crypt32
Test Results
DistributionTest dateWine versionInstalls?Runs?RatingSubmitter
CurrentPC-BSD 10.0 (64-Bit)May 19 20141.7.15 Yes Yes Bronze David Colborne 
ShowLinux Mint 15 "Olivia"Sep 19 20131.6 Yes Yes Bronze an anonymous user 
ShowFedora 17 x86_64Oct 31 20121.5.13 No Not installable Garbage Graben 
ShowFedora 17Dec 28 20121.2.3 Yes Yes Silver an anonymous user 
ShowUbuntu 10.04 "Lucid" amd64 (+ variants like Kubuntu)Nov 29 20101.3.8 Yes Yes Bronze A Wine user 


Known bugs
Bug # Description Status Resolution Other apps affected
9727 mshtml's ShowHTMLDialog too stubby; OPML and Intuit QuickBooks Free / Akamai Download Manager fail NEW View
23134 iexplore does not correctly detect proxy details NEW View
25648 ie8 does not navigate to web pages or obey home page setting NEW View
27388 IE8 UTF-7 doesn't work NEW View
29249 iexplore fails to load ftp.adobe.com NEW View
29319 Internet Explorer 8 fails to start an InPrivate Browsing session NEW View
29583 JScript is missing 'new XMLHttpRequest();' support NEW View
29590 Search results do not update on webpage (IE8) UNCONFIRMED View
30107 IE8 buttons bar doesn't have background under several buttons NEW View
30488 IE8 shows corrupted previews on the quick tabs screen NEW View
33787 IE8 crashes on new tab NEW View
34021 IE8 crashes badly when navigating to www.microsoft.com NEW View
34022 Unimplemented function urlmon.dll.414 NEW View
34025 IE8 help exits silently NEW View
34026 IE8 help pages are blank NEW View
34027 IE8 menus are not activated with ALT key NEW View

 
HOWTO

1. Copy and paste the following into a terminal:

cat > /tmp/IE8.reg <<EOF
[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
"TabProcGrowth"=dword:00000000
EOF
regedit /tmp/IE8.reg

2. Run winetricks -q urlmon mshtml

This may work, it may not. Try winetricks.


 

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

IE 8 install
by Tom on Friday November 6th 2009, 2:32
Hello,

I got IE 8 to install and run but as others have pointed out here there are still allot of errors. I installed flash to and it worked fine, and renamed the jscript.dll in /system32 and set it as native and IE 8 installed a native dll.. The native dll seems to work better then the builtin dll at this time.

www.wine-reviews.net/wine-reviews/microsoft/internet-explorer-8-on-linux-with-wine.html

Cheers,
Tom

[post new] [reply to this]

Working except for JavaScript
by Cillian de RĂ³iste on Tuesday May 5th 2009, 7:25
IE8 works pretty well for me except JavaScript doesn't work and it throws an error for some sites. I don't know why, others work fine. www.google.com gives the error "Internet Explorer couldn't download %ws" although www.jquery.com works fine.

I am using wine-1.1.20 (on Mandriva 2009.0) and went through the following steps:
Created a fresh ~/.wine
Ran winetricks and set the version to win2k and installed IE6.
Ran winetricks and set the version to winxp.
Installed IE7:
$ wine IE7-WindowsXP-x86-enu.exe
Installed IE8:
$ wine IE8-WindowsXP-x86-ENU.exe
I think it installed the first time, but when I tried to run it, it threw an error. For no good reason I ran the installer again. After that it works fine (except it doesn't seem to run any JavaScript). I think it is very usable for testing layout issues.

[post new] [reply to this]




   << Back

Page loaded in 0.15397 seconds.