WineHQ
San Andreas Multiplayer 0.3x



Category: Main > Games > Action Games > San Andreas Multiplayer > 0.3x


NameSan Andreas Multiplayer
Version0.3x
License Free to use
URLhttp://www.sa-mp.com/
Votes 3
Link SA-MP
RatingPlatinum
Wine Version1.4.1
Free Download SA-MP Downloads
Maintainers of this version:
Description
This is the 0.3 branch (including a, b, c, d, e and the new x version)
Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results (selected in 'Test Results' table below)

What works
* Launching game from samp.exe with ASI loader dlls
* Playing online for extended periods of time (in excess of 5 hours)
* Running and playing multiple complex gamemodes, registering accounts, all activities normally done under windows
* Everything else I can find


What does not
Nothing that I can see


What was not tested
Windows server (Linux server available)


Additional Comments


Test Results
DistributionTest dateWine versionInstalls?Runs?RatingSubmitter
ShowKorora 19 - 32bitAug 01 20131.6 Yes Yes Gold Pedro Mateus 
ShowUbuntu 12.10 "Quantal" amd64 (+ variants like Kubuntu)Mar 17 20131.4.1 Yes Yes Platinum Alexandru Tuca 
ShowUbuntu 10.04 "Lucid" i386 (+ variants like Kubuntu)Jun 08 20121.5.5 Yes Yes Platinum Mateusz Cichon 
ShowUbuntu 10.04 "Lucid" i386 (+ variants like Kubuntu)Mar 30 20121.4 Yes Yes Gold Mateusz Cichon 
ShowLinux Mint 10 "Julia" x86_64Mar 20 20111.3.16 Yes Yes Gold goodgod261 


Known bugs
Bug # Description Status Resolution Other apps affected

 
Please note
  • SA-MP requires GTA:SA (DVD game for PC) v1.00 US/EU.
  • Version 2.0 of the DVD version can be downgraded to 1.0 using a third-party patch.
  • The Steam and Direct2Drive versions of GTA:SA are not currently supported and cannot be downgraded.

 
HOWTO
To run the game you need to install DirectX 9 (d3dx9).
For easy install of DirectX 9 run "winetricks", select "d3dx9" and click OK.

 

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

Gta crashes on right click
by julianibus on Thursday November 3rd 2011, 8:08
The SAMP Program works fine and I also can login into servers. But I can't shoot because as soon as I perform a right click the program crashes.

[post new] [reply to this]

Intel card I, library fixed the no textures, but now crash.
by Richard on Sunday September 18th 2011, 12:50
So the game crashes after the loading screens and intro movie.

when running "wine gta_sa.exe" i get this output.

fixme:d3d_caps:select_card_intel_mesa Card selection not handled for Mesa Intel driver
fixme:d3d_caps:init_driver_info Unhandled vendor 8086.
err:d3d:check_fbo_compat >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from Framebuffer format check @ utils.c / 968
fixme:d3d:check_fbo_compat Format WINED3DFMT_R32_FLOAT with rendertarget flag is not supported as FBO color attachment, and no fallback specified.
err:d3d:check_fbo_compat >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from Framebuffer format check @ utils.c / 968
fixme:d3d:check_fbo_compat Format WINED3DFMT_R32G32_FLOAT with rendertarget flag is not supported as FBO color attachment, and no fallback specified.
err:d3d:check_fbo_compat >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from Framebuffer format check @ utils.c / 968
fixme:d3d:check_fbo_compat Format WINED3DFMT_R16_FLOAT with rendertarget flag is not supported as FBO color attachment, and no fallback specified.
err:d3d:check_fbo_compat >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from Framebuffer format check @ utils.c / 968
fixme:d3d:check_fbo_compat Format WINED3DFMT_R16G16_FLOAT with rendertarget flag is not supported as FBO color attachment, and no fallback specified.
fixme:d3d:check_filter Error during filtering test for format 822d, returning no filtering
fixme:d3d:check_filter Error during filtering test for format 822f, returning no filtering
fixme:win:EnumDisplayDevicesW ((null),0,0x177f494,0x00000000), stub!
fixme:d3d_caps:select_card_intel_mesa Card selection not handled for Mesa Intel driver
fixme:d3d_caps:init_driver_info Unhandled vendor 8086.
err:d3d:check_fbo_compat >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from Framebuffer format check @ utils.c / 968
fixme:d3d:check_fbo_compat Format WINED3DFMT_R32_FLOAT with rendertarget flag is not supported as FBO color attachment, and no fallback specified.
err:d3d:check_fbo_compat >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from Framebuffer format check @ utils.c / 968
fixme:d3d:check_fbo_compat Format WINED3DFMT_R32G32_FLOAT with rendertarget flag is not supported as FBO color attachment, and no fallback specified.
err:d3d:check_fbo_compat >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from Framebuffer format check @ utils.c / 968
fixme:d3d:check_fbo_compat Format WINED3DFMT_R16_FLOAT with rendertarget flag is not supported as FBO color attachment, and no fallback specified.
err:d3d:check_fbo_compat >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from Framebuffer format check @ utils.c / 968
fixme:d3d:check_fbo_compat Format WINED3DFMT_R16G16_FLOAT with rendertarget flag is not supported as FBO color attachment, and no fallback specified.
fixme:d3d:check_filter Error during filtering test for format 822d, returning no filtering
fixme:d3d:check_filter Error during filtering test for format 822f, returning no filtering
fixme:win:EnumDisplayDevicesW ((null),0,0x177f484,0x00000000), stub!
fixme:d3d_caps:select_card_intel_mesa Card selection not handled for Mesa Intel driver
fixme:d3d_caps:init_driver_info Unhandled vendor 8086.
err:d3d:check_fbo_compat >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from Framebuffer format check @ utils.c / 968
fixme:d3d:check_fbo_compat Format WINED3DFMT_R32_FLOAT with rendertarget flag is not supported as FBO color attachment, and no fallback specified.
err:d3d:check_fbo_compat >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from Framebuffer format check @ utils.c / 968
fixme:d3d:check_fbo_compat Format WINED3DFMT_R32G32_FLOAT with rendertarget flag is not supported as FBO color attachment, and no fallback specified.
err:d3d:check_fbo_compat >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from Framebuffer format check @ utils.c / 968
fixme:d3d:check_fbo_compat Format WINED3DFMT_R16_FLOAT with rendertarget flag is not supported as FBO color attachment, and no fallback specified.
err:d3d:check_fbo_compat >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from Framebuffer format check @ utils.c / 968
fixme:d3d:check_fbo_compat Format WINED3DFMT_R16G16_FLOAT with rendertarget flag is not supported as FBO color attachment, and no fallback specified.
fixme:d3d:check_filter Error during filtering test for format 822d, returning no filtering
fixme:d3d:check_filter Error during filtering test for format 822f, returning no filtering
fixme:win:EnumDisplayDevicesW ((null),0,0x177f10c,0x00000000), stub!
fixme:d3d_caps:select_card_intel_mesa Card selection not handled for Mesa Intel driver
fixme:d3d_caps:init_driver_info Unhandled vendor 8086.
err:d3d:check_fbo_compat >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from Framebuffer format check @ utils.c / 968
fixme:d3d:check_fbo_compat Format WINED3DFMT_R32_FLOAT with rendertarget flag is not supported as FBO color attachment, and no fallback specified.
err:d3d:check_fbo_compat >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from Framebuffer format check @ utils.c / 968
fixme:d3d:check_fbo_compat Format WINED3DFMT_R32G32_FLOAT with rendertarget flag is not supported as FBO color attachment, and no fallback specified.
err:d3d:check_fbo_compat >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from Framebuffer format check @ utils.c / 968
fixme:d3d:check_fbo_compat Format WINED3DFMT_R16_FLOAT with rendertarget flag is not supported as FBO color attachment, and no fallback specified.
err:d3d:check_fbo_compat >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from Framebuffer format check @ utils.c / 968
fixme:d3d:check_fbo_compat Format WINED3DFMT_R16G16_FLOAT with rendertarget flag is not supported as FBO color attachment, and no fallback specified.
fixme:d3d:check_filter Error during filtering test for format 822d, returning no filtering
fixme:d3d:check_filter Error during filtering test for format 822f, returning no filtering
fixme:win:EnumDisplayDevicesW ((null),0,0x177f5a4,0x00000000), stub!
fixme:system:SystemParametersInfoW Unimplemented action: 59 (SPI_SETSTICKYKEYS)
err:avicap:query_video_device Video 4 Linux support not enabled
err:avicap:query_video_device Video 4 Linux support not enabled
err:avicap:query_video_device Video 4 Linux support not enabled
err:avicap:query_video_device Video 4 Linux support not enabled
err:avicap:query_video_device Video 4 Linux support not enabled
err:avicap:query_video_device Video 4 Linux support not enabled
err:avicap:query_video_device Video 4 Linux support not enabled
err:avicap:query_video_device Video 4 Linux support not enabled
err:avicap:query_video_device Video 4 Linux support not enabled
err:avicap:query_video_device Video 4 Linux support not enabled
fixme:quartz:MPEGSplitter_query_accept MPEG-1 system streams not yet supported.
fixme:quartz:MPEGSplitter_query_accept MPEG-1 system streams not yet supported.
wine: Unhandled page fault on read access to 0x00000000 at address 0x4dd5a3 (thread 0009), starting debugger...

[post new] [reply to this]

Version
by goodgod261 on Sunday March 20th 2011, 11:08
IMHO version should be changed from 0.3b to 0.3x, due to the similarity of them. By the way, 0.3b is not the lastest version of SA:MP and version comment isn't up-to-date.

[post new] [reply to this]

  • RE: Version by Sigurdur Johannsson on Sunday March 20th 2011, 20:02
Logging into servers
by jkb0515 on Thursday December 16th 2010, 20:41
I have a problem when attempting to log into servers that have there own GUI's. an example of this would be a majority of the RPG servers such as Red County Roleplay. when attempting to login, it ask for a password. i cant seem to select the textbox in order to input a password to login. is anyone else having this problem and if so do you have a solution? thanks and kudos to all help.

[post new] [reply to this]

Found out how to avoid some of the main issues
by Blaine on Monday July 12th 2010, 12:32
Well, I got it to install successfully, but I was having a problem in that at times some controller functions were not working, which made normal game play impossible. What was happening when... I to pressed move forward and nothing would happen. I discovered a way around this. While the game is still running, select alt then F1 to launch the menu. Then scroll to Configure Wine and open it. It will open over the running game. Just select ok, and then you'll notice that all the controls will start working correctly. This can be done while selecting a character to use. It works for me all the time.

[post new] [reply to this]

NO NEED FOR ANY ASI
by Dr4x on Saturday June 26th 2010, 2:49
I have tested with Wine 1.2-rc5 and i didn't need any ASI loader or anything else than sa-mp installer and gta installed of course.

It works fine

[post new] [reply to this]

The file is
by Cesar_Biker on Thursday May 6th 2010, 11:57
the file that I seek is the Loader or So .dll, can not find it anywhere.

[post new] [reply to this]

The file dosn't exsist
by Cesar_Biker on Wednesday May 5th 2010, 15:49
Please, could you upload the file to Megaupload or Rapidshare, I need it, can not find it anywhere.

[post new] [reply to this]

Can't Install
by Joshua Elmendorf on Saturday January 30th 2010, 21:03
Can't install SAMP v0.3a, I keep getting this error "Access denied". Any ideas?

[post new] [reply to this]

INSTALLING ON UBUNTU: i cant browse the gta folder with sa-mp/wine (->hidden)
by hacksector on Sunday January 17th 2010, 5:52
i,
i installed gta san andreas and the sa-mp. both work well, but i cant play sa-mp, because i have to browse the game-folder and unfortunately it is hidden! i know how to browse hidden folders on ubuntu, but here its different.

the path is: /home/hacksector/.wine/dosdevices/c:/Programme/Rockstar Games/GTA San Andreas
and here a screenshot where i can go with sa-mp/wine:
img210.imageshack.us/img210/8792/unbenanntsj.jpg

if the gta-folder werent hidden, i could see the ".wine" folder there and everything would be fine!

so my question:
how can i "tell" sa-mp where the gta-folder is?

i really need help,
thanks in advance! smiley

hacksector

ps: i also opened a thread in the sa-mp forum:
forum.sa-mp.com/index.php?topic=146545.0

[post new] [reply to this]

slow gameplay intel onboard vid
by [MOB]Trip on Saturday November 7th 2009, 15:55
chea, so i finally got gta sa and sa-mp to run with the asi procedure and the intel algorythm fix. BUT the game runs like balls...super slow. Now, i am running it off an assus eeepc mini laptop (ROFL) but hey it works right? now, ive turned all the ingame graphix settings down as low as they can go, but ofc it still runs like shit. I havent had any other issues then just super low fps. any tips like a diff vid driver?? i am on the best one tmk for ubuntu 9.04 and i am running the newest wine. But hey it works and this game pwns just need someway to make it run better. I've tried searching for a low poly graphics mod, in hopes that it would solve my issue, but there unfortunately isnt one. I know there is a manual way to instal the windows direct x...but i dont wanna rape my wine install again lol. I've also set the wine cfg to disable the pixel function. I dont need the game to run super fast, but a little more playable would be great. but again, if ur tryin to run this game, it is 100% functional imo.

[post new] [reply to this]

GUI = Crash
by Maxim on Monday November 2nd 2009, 12:39
Hi. GTA:SA-MP runs good, but I can play on not every server. If server use additional GUI (new feature of samp 0.3a), gta_sa.exe is crashing.
P.S. Personage constantly running too.
P.P.S. Sorry for my bad English.

[post new] [reply to this]

Problem with controls
by Ya8 on Saturday October 31st 2009, 8:32
Hey, i haved to run SA:MP 0.3a using ASI loader, everything works perfect, but character constantly runs forward when on foot. It makes game not playable. I tried to connect other keyboard and mouse, but there are no changes. My distro is Kubuntu 9.10.

[post new] [reply to this]




   << Back

Page loaded in 0.09721 seconds.