WineHQ
Call Of Duty: Modern Warfare 2 Retail



Category: Main > Games > 1st Person Shooter > Call Of Duty: Modern Warfare 2 > Retail


NameCall Of Duty: Modern Warfare 2
VersionRetail
License Retail
URLhttp://modernwarfare2.infinity...
Votes 6
RatingPlatinum
Wine Version1.5.26
Maintainers of this version:
Description
Retail Release Version
Old test results
The test results for this version are very old, and as such they may not represent the current state of Wine. Please consider submitting a new test report.
Selected Test Results (selected in 'Test Results' table below)

What works

Installation

Launching


What does not
Nothing


What was not tested

Extended gameplay

Multiplayer


Additional Comments

Game runs out of the box.
Test Results
DistributionTest dateWine versionInstalls?Runs?RatingSubmitter
CurrentUbuntu 12.10 "Quantal" i386 (+ variants like Kubuntu)Mar 22 20131.5.26 Yes Yes Platinum Andrey Gusev 
ShowGentoo Linux AMD64Oct 25 20111.3.30 Yes Yes Silver an anonymous user 
ShowGentoo Linux AMD64Oct 29 20111.2.3 Yes Yes Gold an anonymous user 
ShowFedora 14Dec 11 20101.3.9 Yes Yes Gold NSLW 
ShowDebian GNU/Linux 6.0 "Squeeze" x86_64Nov 27 20101.3.8 Yes Yes Gold Nekroman 


Known bugs
Bug # Description Status Resolution Other apps affected
19748 Bad performance and/or lags with wrong thread problems in Metro 2033 (Unreal Tournament 3, Counter Strike: Source, Metro 2033, Call of Duty 4, Left 4 Dead, Left 4 Dead 2, Final Fantasy XIV, Half-Life 2) NEW View
22776 Call of Duty: Modern Warfare 2 flickery textures in midrange background NEW View

 
Co-OP Mode Works
HI, I yesterday tested Singleplayer and Multiplayer CO-OP Mode in Ubuntu 10.04 Beta2 x64 and this game mode works correctly. NOTE: There are some lag

 
How To run the game correctly
1. Turn off Compiz Fusion if it's enabled 2. Download winetricks and exec them with command sh into console and install Directx, corefonts,visual basic,codecs and all the requisites what appear in the box. 3. Start Steam and install game 4. Set resolution to: 800*600 or 1024*768 for a correctly work 5. Enjoy

 

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

Unhandled page fault on read access to 0x06000238 at address 0x6000238 (thread 0009)
by Michael Zimmer on Thursday November 3rd 2011, 11:07
using wine 1.3.26 I set up a new wineprefix, and installed COD6:MW2 to it. but when I run "wine iw4sp2.exe", it shows the splash screen, and then crashes, showing the debugger window and the following message:

fixme:mscoree:_CorDllMain (0x783f0000, 1, 0x1): stub
fixme:mscoree:_CorDllMain (0x10000000, 1, 0x1): stub
fixme:win:EnumDisplayDevicesW ((null),0,0x32f4e8,0x00000000), stub!
fixme:system:SystemParametersInfoW Unimplemented action: 59 (SPI_SETSTICKYKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 53 (SPI_SETTOGGLEKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 51 (SPI_SETFILTERKEYS)
wine: Unhandled page fault on read access to 0x06000238 at address 0x6000238 (thread 0009), starting debugger...


could anyone please tell me what to do?
thanks in advance.

[post new] [reply to this]

Input-Error (stub) Slows down Performance
by Gerrit Addiks on Wednesday December 1st 2010, 10:57
hi,

when playing CoD MW2, the game itself runs, it is playable,
but extremely slower then it should be.
By that i mean the the FPS drops down to 2-5 when being in a battle.
That is REALY annoying!

After i have turned on debug, i am getting the following when pressing or holding a key and sometimes when moving the mouse.

...
fixme:d3d_surface:IWineD3DVolumeImpl_LockBox (0xef595c0) : pBox=(nil) stub
fixme:d3d_surface:IWineD3DVolumeImpl_LockBox (0xef595c0) : pBox=(nil) stub
fixme:d3d_surface:IWineD3DVolumeImpl_LockBox (0xef595c0) : pBox=(nil) stub
fixme:d3d_surface:IWineD3DVolumeImpl_LockBox (0xaf096c8) : pBox=(nil) stub
...

And by "getting" them, i mean the console pumpes them out as if there where no tomorrow, thousands of lines in just seconds.
I am sure this is why the game is so damn slow.

Is there a way to fix it?
Otherwise there are no errors or glitches,
but that is going to make me mad.

Thanks for any Help,
Gerrit Addiks

[post new] [reply to this]

MW2 closes on completion of loading.
by Ethan on Tuesday October 26th 2010, 18:11
Here's what I did. Installed d3dx9/d3dx10 dlls and vcrun2005sp1 via winetricks > Launched steam from my Windows installation > Turned off the steam in-game overlay > Launched MW2 Multiplayer (WinXP config in wine) > (At this point everything runs sooooo smooth ^^) Selected Hardcore TDM to play > It finds a game and begins to load > as soon as loading completes it just closes?

I have 4gb RAM DDR3, i5 quad core, NVidia GTX 275(nvidia-current driver on Ubuntu), and I'm running wine1.3-dev on Ubuntu 10.10.

Game settings all at high and running in windowed mode at 1920x1080 Resolution.

Anyway to open a debug console for this?

Thanks ^^

[post new] [reply to this]

Error in last version
by Yore on Tuesday August 24th 2010, 18:58
Hi

When I try to execute the game, I got this error and I can play.

fixme:win:EnumDisplayDevicesW ((null),0,0x33f7ac,0x00000000), stub!
fixme:d3d:debug_d3dformat Unrecognized 1280070990 (as fourcc: NULL) WINED3DFORMAT!
fixme:d3d:getFormatDescEntry Can't find format unrecognized(1280070990) in the format lookup table
fixme:d3d:swapchain_init Add OpenGL context recreation support to context_validate_onscreen_formats
fixme:d3d_surface:IWineD3DVolumeImpl_LockBox (0xa9e4d28) : pBox=(nil) stub
fixme:win:EnumDisplayDevicesW ((null),0,0x33f62c,0x00000000), stub!
wine: Unhandled stack overflow at address 0x10017a13 (thread 001b), starting debugger...
err:seh:setup_exception_record stack overflow 828 bytes in thread 001b eip f7e53d90 esp 00240ff4 stack 0x240000-0x241000-0x340000
err:ntdll:RtlpWaitForCriticalSection section 0x7bca4fa0 "rtl.c: peb_lock" wait timed out in thread 0017, blocked by 001b, retrying (60 sec)


I use wine 1.3.1. Can anybody help me? Thanks.

[post new] [reply to this]

installer video walkthrough
by Dan Kegel on Saturday August 21st 2010, 1:16
In cinema verite' style :-)

www.nixnews.tk/how-to-install-call-of-duty-modern-warfare-2-under-ubuntu-9-10-pt1
www.nixnews.tk/how-to-install-call-of-duty-modern-warfare-2-under-ubuntu-9-10-pt2

[post new] [reply to this]

Bad FPS
by Benjamin Xiao on Wednesday July 28th 2010, 20:18
The game runs with little graphical glitches with the latest Wine, but performance is very bad, especially when turning around. Is there any workaround for this?

[post new] [reply to this]

  • RE: Bad FPS by Marcos Tenrero on Thursday July 29th 2010, 6:14
    • RE: Bad FPS by Benjamin Xiao on Thursday July 29th 2010, 12:22
      • RE: Bad FPS by Marcos Tenrero on Thursday July 29th 2010, 13:18
        • RE: Bad FPS by Oli on Wednesday September 15th 2010, 22:50
  • RE: Bad FPS by Oli on Wednesday September 15th 2010, 22:55
Graphic Slow Down
by Monkness on Tuesday May 25th 2010, 23:29
Quick overview:

Just updated Wine to 1.2-rc1
Running Ubuntu 10.04
Intel i7-860
4 gig ram
nVidia GTS 250 195.36.15
Compiz Fusion Full Quality

Now, the previous version on Wine was giving me a lot of graphical errors/bugs. But, this 1.2 rc1 isn't. The game runs beautifully! High frame rates with no problems from Steam or the online matching service. But I do run into a problem when I play through a whole round online. After the round is over, things slow down. I was wondering if this was due to something I might be doing. Let me know if there is something I should do differently or how I can help out.

[post new] [reply to this]

A lot of "Steam connect failed"
by LBM on Sunday May 16th 2010, 19:22
Hey, just wanted to check if anyone else is experiencing my problem while playing MW2 online using Wine.

The thing is that I'm usually able to play a match, or at lest half a match without problems, but then I'm always "kicked" (?) with the message "Steam connect failed".

I've been searching the web for answers and the recommendations are, 1) not to use a pirated copy of the game and 2) to check network/router settings. The thing is though, that my copy of the game is legit and my router seems to be as "open" as it can possibly be, so I'm starting to think the problem might be Wine.

Anyways, I'm not that happy about filing a bug for this problem since I'm not entirely sure the problem is Wine (tested with everything from v. 1.1.37 - 1.1.44), and since the "kick" doesn't seem to provide much output in logs, etc.

So, as for now I'm just curious, am I the only one here experiencing this?

[post new] [reply to this]

Unhandled Exception
by nicholas on Tuesday May 11th 2010, 19:27
Hey everyone, thanks for all of your work so far.

Anyway, I've got Steam installed fine (Steam actually seems to work MUCH MUCH better than the last time I tried with wine -- about 2 years ago.)

So, I thought I'd give MW2 a whirl.

No dice. When I try to launch the game, I get this output in the console:

wine: Unhandled page fault on read access to 0x7f0e5a4c at address 0x7ec84570 (thread 0016), starting debugger...
err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr 0x7b85b7c7
err:ole:RevokeDragDrop invalid hwnd (nil)
err:ole:RevokeDragDrop invalid hwnd 0x3012a

I've tried all the steps listed above.

About Wine/Computer: lib32 wine (Suse build) running under Arch 86_64. Kernel info: 2.6.33-ARCH #1 SMP PREEMPT Sun May 2 10:40:03 CEST 2010 x86_64 Intel(R) Core(TM)2 Quad CPU Q6700 @ 2.66GHz GenuineIntel GNU/Linux

[post new] [reply to this]

Black Screen
by Christian on Saturday May 8th 2010, 5:12
Installation seemed fine.
Then I got the dxdllreg.exe crash, so I altered the file path in the registry to prevent execution.
But with and without dxdllreg.exe I only get a black desktop in the game resolution (1024x768 I guess) and the MW2 icon showing, but nothing else. Did anyone encounter this problem or has a solution / tips for me?

[post new] [reply to this]

Bug Graphics in wine > 1.1.36
by Yore on Friday April 9th 2010, 3:04
When I execute the game with a version of wine higger than 1.1.36 I get a lot of bad render in game. With 1.1.36 the game work perfect. I use nvidia divers 190.53 and I tested 195 series too.

[post new] [reply to this]

no sound
by sean on Friday February 26th 2010, 21:04
theres no sound?

[post new] [reply to this]

Regarding last 3 wine versions
by Lukas Kropatschek on Wednesday February 24th 2010, 11:56
I found out, that there are some regressions/problems/bugs in the last 3 wine versions (1.1.39, 1.1.38, 1.1.37)

1.1.39 - Performance Issues ~-40% FPS
1.1.38 - Steam Windows dont get (re)rendered if moved (fixed in 1.1.39)
1.1.37 - Friends can't join my Lobby, everything else works as expected (steam, performance)

[post new] [reply to this]

No Keyboard
by Berillions on Sunday February 7th 2010, 10:34
Hello,

I installed the game with wine 1.1.37 but my keyboard doesn't work in game. When i'm in Steam application, it's work but when i'm ine the game, i can't move my character or change my command in the option.

How to resolve this problem?

Thanks

[post new] [reply to this]

ncomplete installation of Call of Duty: Modern Warfare 2 (2)
by mr bugg on Monday January 25th 2010, 6:06
ncomplete installation of Call of Duty: Modern Warfare 2 (2)

would any 1 help me with this please

[post new] [reply to this]

The end of Paradise :(
by AJSB on Wednesday January 20th 2010, 21:28
Well, after a lot of days playing it w/o problems, i took somedays w/o playing it and today i tryed again....Steam updated itself and also MW2...and since then i have no sound at all in MW2SP, MW2MP, TF2 and HL2 series :(

I'm starting to get p****d with Steam...

FWIW, other games not using Steam like COD2 and MXvsATV Unleashed (w/NoCD crack) play just fine...

Using now also Wine 1.1.36....possibly gonna try to put back 1.1.34 to see if it solves anything...

[post new] [reply to this]


by Milos_SD on Saturday January 16th 2010, 14:27
I just tried Modern Warfare 2 with wine 1.1.36 and there is a lot of graphic gliches. It isn't rendered good.

Here is the console output:
pastebin.com/m60d0a29b

[post new] [reply to this]

ERROR
by adam sjötröm on Friday January 15th 2010, 10:40
I got a problem starting COD4 modern warfare 2. It say:
Video card or driver doesn't support vertex shader 3.0 or better.
What can I do ?

[post new] [reply to this]

Resolutions problems
by Nicholas Cuthbertson on Thursday January 14th 2010, 11:29
Ok, I have gotten past the freezing problems (just uninstalled and reinstalled the game with AJSB's instructions) but now there is another problem. At 1280x1024 (aspect ratio 5:4) resolution (I change the resolution in the config.cfg config_mp.cfg) and minimum graphics the game works fine but the fps is low, as mentioned by many people. To remedy this I decreased the res to 640x480 (4:3) but when i got into a game I could only see the background and my sights, everything else, including enemy players was invisible. I think this was mentioned earlier but he didn't mention the resolution. The same graphical problem occurs with 1024x768 (4:3) and 640x512 (5:4) and i thinks all the other ones but these are the ones I have tried.
One thing I don't get though, is that when I am using a 4:3 resolution I can see the bars at the top and bottom of the desktop (Ubuntu 8.10) and when I am using 1280x1024 I can't see either of the bars but when I use 640x512 (the same aspect ratio as 1280x1024, so it should also work) I can see the bar at the top but not the one at the bottom.

If anyone else has had this problem or has found a way to fix it please say something.

In the meantime I will be trying other

[post new] [reply to this]


by kostas on Wednesday January 13th 2010, 10:26
OK, so today i upgraded to the new version of wine, 1.1.36.
Once again, like the previous version, it solves nothing when it comes to this game but instead of that, causes more problems. After the mouse bug that was introduced in 1.1.35 version of wine, now is the keyboard's turn to stop working when launching the game with wine 1.1.36. Pressing any keys in game will do nothing, however they will do whatever they were supposed to do, outside of the game, for example: I was pressing F1 to get the game summary and it did not work, but when i exited the game i saw that i had loaded several times the help contents of Ubuntu (which use F1 as the shortcut key).
The Mouse bug is fixed but every other problem persists: Low fps, sound stattering periodically or at times there's no sound at all, and garbage graphics. If anyone of you is saying that they haven't got low fps or good graphics, apparently haven't played this game in windows yet, to see how it is really supposed to be.

I've had it with wine and i'll downgrade to 1.1.34 if i won't find any workaround for the keyboard to work tonight even. I will post it here if i find it and see that more people have this problem or else back to 1.1.34 and no more upgrades. It's getting worse as it goes.

[post new] [reply to this]

  • RE: by kostas on Wednesday January 13th 2010, 10:48
    • RE: by hash on Thursday January 14th 2010, 0:31
    • RE: by Fabian Thoma on Saturday February 13th 2010, 16:40
mac os x
by ManiaC on Tuesday January 12th 2010, 18:20
It seems from a little test tonight that it works flawlessly on a macbook pro mid '09 with snow leopard. Had low fps but only tried with 9400.
Tomorrow i ll do some more tests and apply the data ofc i didn't check for high graphics :)
Only problem was installing the game... Had to download from steam to install it :P :)

[post new] [reply to this]

People , People !!!
by AJSB on Tuesday January 5th 2010, 19:41
There is nothing wrong with the game !!!

Follow my instructions in my review EXACTLY , except , use wine 1.1.34 (no need for patch) or use wine 1.1.35 with the patch for the mouse and it weill work fine AS LONG AS YOU DON-T FORGET TO DO IN THE END OF EVERYTHING INSTALLED:

sudo apt-get purge alsa-oss
sudo apt-get install alsa-oss

It sounds ridiculous BUT YOU NEED TO DO THAT.

and don't forget to edit the launcher to put "aoss" in the proper place.

I also now OC my PC with a e2610 at 1.8Ghz to 3.0Ghz and no longer have low fps :D

[post new] [reply to this]

Hmmm
by Adam Obenhofer on Monday January 4th 2010, 1:55
Seems like we need alot of patches to get this game fully working..I wish i had time to help.

[post new] [reply to this]

Freezes and other problems.
by Nicholas Cuthbertson on Sunday January 3rd 2010, 8:11
I have successfully installed Modern Warfare 2 with wine 1.1.35 but it seems to alternate between a few problems. Sometimes the game doesn't start at all and sometimes it freezes while it starts and I can move the mouse but can't click or right click on anything on the desktop. Singleplayer quits immediately after the game starts when it does start and multiplayer does start on occasion but freezes when I get into a game with enough people and it is about to start.

Any advice would be much appreciated.

[post new] [reply to this]


by Daniel on Sunday January 3rd 2010, 7:09
Hi!

I'm getting the following error after trying to run the game, I'm trying to run it through the steam I've got installed on PlayOnLinux.

Please turn off 'compatibility mode'
-right click steam.exe
-select Properties
-go to the 'Compatibility' tab
-un-check 'Run this application in compatibility mode...'

Of course I can't do this, anyone know what to do?

Thanks,
Daniel

[post new] [reply to this]

  • RE: by Daniel on Sunday January 3rd 2010, 7:10
Sound Initialisation Problems
by Dan on Wednesday December 30th 2009, 4:31
Hi All,

I believe I have followed these instruction which seemed very clear thank you! The installation went fine however when I launch the game I get the following error.

----- Client Initialization Complete -----
Attempting 44 kHz 16 bit [Windows default] sound
ERROR: Couldn't initialize digital driver: DirectSoundCreate() failed in get_system_speaker_configuration()


Error during initialization:
Miles sound system initialization failed.
Make sure you have your sound card's latest drivers and DirectX installed.

Any help would be greatly appreciated.

Wine: 1.1.35
MB: Gigabyte EX58-UD3R
Sound: Onboard HDA Intel 7.1
CPU: Core i7
GPU: Ati (soon to be replaced with a good Nvidia)

[post new] [reply to this]

unhanded exception
by SSK on Tuesday December 22nd 2009, 8:24
After some time playing MP or SP I have wine errors with unhanded exceptions and the game just stalls. Killing the process can only help, so when the game fails while playing a match the progress isn't saved. I'm running Debian Squeeze 64 bit. Wine 1.1.34.
Any ideas how to solve it?

[post new] [reply to this]

No Depth Perception Everything is invisible except background and letters
by mike huebner on Tuesday December 22nd 2009, 2:56
I just installed everything and it is working perfectly until i quite it gives out an error message and then along with that in game you cannot see people, weapons, or objects all i saw on the first level was a mountain view and a bunch of holes in the ground.... anyone else having this problem?
Can someone help me fix it

Please and thanks!

My Specs!
iMac 2008' Snow Leopard
2.8 GHz Intel Core 2 Duo
2 GB 800 Mhz DDR2 SDRAM
ATI Radeon HD 2600 Pro Graphics Card

[post new] [reply to this]


by antonio on Saturday December 19th 2009, 8:11
Hi, i installed the game without problems, it start but is very slow, I can't play.

[post new] [reply to this]

  • RE: by AJSB on Sunday December 20th 2009, 10:33

by kostas on Saturday December 19th 2009, 4:32
Probably it's ever since Wine upgraded to 1.1.35. Whenever i launch MW2 i still get my desktop's cursor instead of the game's cursor. I can only scroll the cursor but can't click on anything so i can't play the game because of it.

Any clues why is this happening and how can i fix it?

[post new] [reply to this]

  • RE: by Chris on Saturday December 19th 2009, 14:44
    • RE: by AJSB on Sunday December 20th 2009, 10:30
  • RE: by AJSB on Sunday December 20th 2009, 10:29
  • RE: by Kreso Kunjas on Sunday January 3rd 2010, 11:24

by Mark Douma on Monday December 7th 2009, 13:20
"as mentioned the game works, i.e. i hear sounds and see the display text (ammo, compass, in game map etc.) - however the screen stays black and the on-screen text "smears" into the black screen as you move."


I had the same thing until I went to Advanced Video settings (in the game itself) and disabled shadows, spec/glow, depth of field, and wall marks, and possibly more. Then the game appeared properly (I didn't narrow down if it was one setting in particular that "fixed" the issue, but I remember hearing somewhere that it might be shadows that's causing it).

That said, I had an issue with the input from my mouse (Logitech G5) just causing all kinds of random spastic movements (if you've ever seen aimbotters whip around back and forth in seemingly random directions to get kill after kill, that's what it felt like). I basically kept spinning around in a circle, so I didn't get very far. This was in X11's fullscreen mode at 1600 x 1200 (well, 1200 - 22, which is the height of the Mac menu bar). I will keep experimenting.

Oh, I almost forgot to add that I'm running Mac OS X 10.6.2.

[post new] [reply to this]

  • RE: by weegee on Monday December 7th 2009, 19:04
    • RE: by Mark Douma on Wednesday December 9th 2009, 20:58
low fps & garbage text issues
by Mahmoud Abdul Jawad on Saturday December 5th 2009, 7:18
hi all,,

i installed the game nicely & easily on my Fedora 11 box, what i did is that i copied the two DVD's contents to a folder i ran Setup.exe & everything went clearly..
after the finish of installing, i ran the game, it worked without issues, except the low fps & garbage text issues.

i don't know, what is the reason, but there's a lot of GPU idle while running the game, no errors, but some fixme warnings.

is this a bug or it's the wine limit??

the text isn't a big issue, but the low fps is the ULTIMATE DISASTER --another Mr. Bean..

any such issues or solutions??

[post new] [reply to this]

MW2 performance
by kostas on Thursday December 3rd 2009, 7:50
Hey guys, i have managed to ran Call of Duty Modern Warfare 2, on Ubuntu 9.10 with Wine 1.1.33 and the patch given by Max here.

All's good but the game's suffering from low fps, sound lagging and bad graphics due to having disabled depth of field and soften smoke edges.

I am getting owned at MP because of it and i really hate it.. Any ways to improve the game's general performance?

Before I got Ubuntu, i was playing this game with a slow poking 2 years old Windows Vista, and it ran sweet and perfectly, no problems at all, so i know my hardware is just fine.

I'm still a Linux illeterate so I'm looking for any tips that could help me improve the game's performance.

[post new] [reply to this]

Main Menu Fonts/text issue
by Rob McCann on Tuesday December 1st 2009, 12:31
I've (finally) installed and got the program to load (i'll write a howto later)

The text on the main menu is garbled, possibly a font issue?

It isn't possible to read it but the game is navigable.

The game also has a random black flicker, that I would normally equate to a driver issue.

I'm running a self-compiled version of 1.1.33 with the Left4Dead 2 'Incomplete installation (#)' patch installed. I've also done the registry tweaks provided and set my video memory to 1000000000

Ubuntu x64, ATI 4870 1 GB, Core i7 2.66, 6GB ram, 11gb swap

[post new] [reply to this]

Can't play to Multiplayer
by Berillions on Friday November 27th 2009, 14:15
Hello, when i want to play to CoD6 multiplayer, i can't because the game doesn't launch after the splash screen.

The only message that i have is this :
wine: Unhandled page fault on read access to 0x00000000 at address 0x7bc436b9 (thread 0028), starting debugger...

I don't how do to play correctly.

[post new] [reply to this]

Singleplayer FULLY working....MULTIPLAYER almost...NEED YOUR help !
by AJSB on Friday November 27th 2009, 11:06
OK, i mannged to put the SP fully working (details later), mainly thanks to 48khz, ALSA, 16bit and the patch....all this in XUBUNTU 9.10.

As for MP , i played online (AFAIK, in a VAC server !) today but i gived up for now, because a "small" problem....NO SOUND at all.

If i use same settings than for SP, MP crashes at start up....i have to change from ALSA to OSS to not crash but then i have no sound !!! :(

Notice that also in COD2 and COD4, i used under Slackware 12.2, ALSA for SP and OSS for MP to avoid also the start up crashes, but in both caserd i had sound !


Any ideas ?!?....Slackware 13 ?!? :P

TIA,
AJSB

[post new] [reply to this]

Almost there....
by AJSB on Thursday November 26th 2009, 19:20
OK, i dumped Slackware and installed XUBUNTU 9.10....installed everything including the pre-compiled patch and installed everything correctly....there is a final problem.

When MW2 SINGLEPLAYER starts, it gives an error about Miles sound not working:

Error During Initialization
Miles sound system initialization failed.

...and then, it will not continue to launch.

As for MW2 MULTIPLAYER, it fully launches w/o errors but there is no sound at all !!!

I remember that there was also another game with these same problems and that someone found a solution....don't recall however what game it was and , more important, what was solution....anyone knows ?

TIA,
AJSB

[post new] [reply to this]


by Stiebrs on Wednesday November 25th 2009, 6:58
Thanks, it seems to work.
For lazy people: solution that worked for me is waiting for about 5-10minutes, then game unfreezes and works fine. Still some bugs with specific lightning (e.g. night vision), but it's acceptable

[post new] [reply to this]

Find Solution
by Berillions on Tuesday November 24th 2009, 13:49
Thanks for the creator of this patch.
Left 4 Dead 2 has the same problem that CoD6, the error message :
(53) Incomplete Installation.
appdb.winehq.org/objectManager.php?sClass=version&iId=18408

So, i compiled wine 1.1.33 and i moved the file patched and it's works.
Solo + Multiplayer.

So, download this file :
hotfile.com/dl/18516885/0d1e877/PatchCod6.zip.html

And move the file in /usr/lib/wine in root.

[post new] [reply to this]

Incomplete installation of CoD MW2 (53) Bug
by AJSB on Monday November 23rd 2009, 23:09
I'm also having this issue :(
I installed the game today and no way it starts :((

However, it seems that might be related to Steam client itself because reading one of the bug reports here it says that Steam under Windows is being affect also !!!! There seems that Steam is trying to solve the problem ?!?

[post new] [reply to this]

video freezes
by Stiebrs on Sunday November 22nd 2009, 10:21
Video freezes after 1-2 seconds of working (it shows first animated logo and then hungs up) mp version without animations gets me to the menu and then freezes, but music keeps on playing.

console stops at this:
err:d3d:getColorBits Unsupported format: WINED3DFMT_UNKNOWN
err:d3d:IWineD3DImpl_IsPixelFormatCompatibleWithRenderFmt Unable to check compatibility for Format=WINED3DFMT_UNKNOWN
fixme:d3d:WineD3D_ChoosePixelFormat Add OpenGL context recreation support to SetDepthStencilSurface
fixme:d3d_surface:IWineD3DVolumeImpl_LockBox (0x16e521a8) : pBox=(nil) stub
fixme:win:EnumDisplayDevicesW ((null),0,0x33f714,0x00000000), stub!
fixme:d3d:WineD3D_ChoosePixelFormat Add OpenGL context recreation support to SetDepthStencilSurface
fixme:d3d:WineD3D_ChoosePixelFormat Add OpenGL context recreation support to SetDepthStencilSurface

Using Debian Lenny, wine 1.1.33

P.S. i'm still able to play COD4MW1 with the same settings without freezing

[post new] [reply to this]

Incomplete installation of CoD MW2 (53)
by Gold on Wednesday November 18th 2009, 11:43
I got the same error here

My CODMW2 was working has intended, even with all at extra and shadow on
But since Today (didnt play yesterday) I can`t play anymore just can`t start the game via steam always get

Incomplete installation of CoD MW2 (53)

like before i got my 1.1.33 wine

at least It`s not back to error (2) XD

Running with Winetricks and Under Karmic

[post new] [reply to this]

steam update
by hype on Wednesday November 18th 2009, 3:36
ok... after today's COD modern warfare 2 's updates: cant start the game anymore; same "incomplete installation" error.

[post new] [reply to this]

Incomplete installation of CoD MW2 (53)
by phantom_ch on Tuesday November 17th 2009, 4:53
hi all

i just installed wine 1.1.33 and CoD MW2 from this instructions:
appdb.winehq.org/objectManager.php?sClass=version&iId=18348&iTestingId=46479

My System:
Ubuntu Karmic 9.10, 64bit

Steam installation works fine and i can start Steam and login to my Steam Account. But if i want start CoD MW2 i get:

Incomplete installation of Call of Duty: Modern Warfare 2 (53)

Seam Problem on SinglePlayer and MultiPlayer Mode.

I searched on support.steampowered.com but there is no entry about Error (53)..

Any idea/hint?

Thanks a lot

greetings
phantom

[post new] [reply to this]

easy
by Manne Dyrver on Monday November 16th 2009, 16:34
open up a terminal and type "wine eject" without quotes and it should be able to keep on going.

[post new] [reply to this]

runtime error
by Panpan on Saturday November 14th 2009, 12:44
Hi when i tried to install mwf2, i have an error message that says isskin.dll cannot be imported. (runtime error -1:0)

Someone have an idea ?

Thanks.

[post new] [reply to this]

How to ;)
by ParkerRichard on Saturday November 14th 2009, 7:03
How To Install Modern Warfare 2 Under Ubuntu

First you will need a few programs listed below.

First get: winetricks to download open up terminial and type wget www.kegel.com/wine/winetricks


and then after done to open up type"sh winetricks" without the quotation marks.

Next you need a program called wine hq go to link below to download easy to follow isntructions on site.

www.winehq.org/download/

Then u need to open up winetricks in terminial
and check the following files to install.

d3dx9
corefonts
dotnet20
ie6

then click ok and proccess will take 30 minutes top to download and install the needed files.. ONce that is done u need a program called steam

download that at link below:
storefront.steampowered.com/download/SteamInstall.msi

once that is done downloading right click the .msi file and select open with windows program loader suggesting u have wine hq installed should open up and install and then log in with your steam account and if yu dont have an account make one then after that login then to the game installation part what you gonna wanna do is pop disc 1 in and browse the disc and open up the file well right click the file named "Setup.exe" Then install and when it ask for disc 2 dont do nothing cause u will need to open up terminial and type in the following "wine eject" without quotations if not doen so wont be able to finish installing so then once after typing that in disc one will eject from the bay then pop in disc 2 and click ok on the steam installer then once that is all done have fun :)

[post new] [reply to this]

Install
by Berillions on Thursday November 12th 2009, 11:39
How install this game with the DVD-ROM.

If i install the game with the dvd-rom, i have an error message told me that "The setup script has failed".

Need help please.

Thanks

[post new] [reply to this]

  • RE: Install by Berillions on Thursday November 12th 2009, 15:28
    • RE: Install by Hooty on Thursday November 26th 2009, 3:33
    • RE: Install by Hooty on Thursday November 26th 2009, 6:47
Works Correctly
by Berillions on Wednesday November 11th 2009, 10:40
The game works correctly?
There isn't graphic bug when you play at game?
You can play with the Hight graphic Option?

Thanks

[post new] [reply to this]




   << Back

Page loaded in 0.17232 seconds.