WineHQ
Portal 2 dvd



Category: Main > Games > Portal 2 > dvd


NamePortal 2
Versiondvd
License Retail
URL 
Votes  
RatingBronze
Wine Version1.7.10
Maintainers of this version:
Description
Installed from the dvd.
Selected Test Results (selected in 'Test Results' table below)

What works

Installation

Start of any level

 


What does not
When creating two portals, it crashes


What was not tested
Could not finish any level.


Additional Comments

Processor: Core 2 Quad Q9550 2.83Ghz
Video Card: GeForce 9600GT
RAM: 4GB
Test Results
DistributionTest dateWine versionInstalls?Runs?RatingSubmitter
CurrentLinux Mint 15 "Olivia" x86_64Feb 02 20141.7.10 Yes Yes Bronze Philipglo Joshua Opulencia 
ShowUbuntu 13.04 "Raring" amd64 (+ variants like Kubuntu)Jul 27 20131.6-rc5 Yes Yes Platinum Sveen 
ShowUbuntu 12.10 "Quantal" i386 (+ variants like Kubuntu)Apr 08 20131.4.1 Yes Yes Platinum ZachTM 
ShowUbuntu 11.10 "Oneiric" amd64 (+ variants like Kubuntu)Dec 29 20111.3.35 Yes Yes Silver Nonoo 
ShowUbuntu 11.04 "Natty" amd64 (+ variants like Kubuntu)Oct 12 20111.3.30 Yes No Garbage an anonymous user 


Known bugs
Bug # Description Status Resolution Other apps affected
24684 SMP problems with Source games NEW View

 
How-to install the game

You need:

  • A recent version of wine, 1.3.28 or newest, it's recommended the lastest release.
  • A video card with 3D Acceleration suport on your unix.
  • The official 3D driver installed and working for that card.
  • It's not necessary a clean prefix, but it's recommended.

First download steam from here, install following the steps on Steam page and install the game trought steam.

Be sure that 3D support is working, you can check this by typing the follow command:

glxinfo | grep "direct rendering:"

It's also recomended to install the following fonts: tahoma.ttf, arial.ttf and verdana.ttf.

I recommend that you install the Visual C Runtime, download-it from here and here and install on your prefix.

To override the wine vcrun with the native one you need to create a file called vcrun.reg with the follow content:

[HKEY_CURRENT_USER\Software\Wine\DllOverrides]
"msvcr80"="native,builtin"
"msvcr90"="native,builtin"

Then run the follow command:

env WINEPREFIX="(your-prefix)" WINEDEBUG="fixme-all" wine regedit ./vcrun.reg

The game shoud work fine. Any problem, you can see the Troubleshoot notes, post a comment or submit a bug at Bugzilla.


 
Workarounds

 For problems related with Steam itself, please visit the Steam Official Release page.


Can't change the resolution or go to fullscreen.

Right click on the game at steam and go to: Proprieties > Set Launch Options and type:

-full -w (your width resolution) -h (your height resolution).


Portal 2 is crashing before you enter the menu.

You need to check your game cache, on Steam right-click on portal 2 and go to Proprieties > Local Files (Tab) > Verify integrity of game cache.

Some people with  Portal 2 is still suffering with the problem "crashing before the menu" and verifying the integrity of the game don't work. Solutions that worked for some people:

  • Uninstall portal 2, and download again through steam (don't reinstall from DVD, download-it again).
  • Install steam through winetricks.
  • Disable the Steam Overlay by setting the gameoverlayrenderer library to disabled on winecfg.
  • Set winecfg to emulate Windows 7.

My suggestion is, if you tried everything and still have this problem, submit a new bug, or, ask to reopen the bug #26835.


Portal 2 has some ugly textures, or everything is yellow/green, the light is showing trought the wall.

Set the Multicore Rendering to Disabled/Off on graphics options into the game.

View more details about this bug here (Bug #24684).


When launch Portal 2 i got the "In order to run Steam properly on this version of Windows, the Steam service component must be installed." error.

The solution for this bug is to set the version of windows to XP, to do that, open your winecfg and set Windows Version to Windows XP.


The game is ramdomly crash after some minutes playing.

Try to check the integrity of the game, to do that, on your steam, right click on your Portal 2 Proprieties > Local Files (Tab) > Verify integrity of game cache.

Also, try to install these fonts on your wine prefix (drive_c/windows/Fonts)lucida.ttf, tahoma.ttf, arial.ttf and times.ttf.


The game wont start or crash at start.

Try to install vcrun2005 and vcrun2008, follow the How-To install tutorial.


The game is laggy on some maps, the FPS is very low.

Try to lower the AntiAliasing (AA), or even turn off AA.


General Troubleshoot.
  • Verify if your video driver is installed properly.
  • Install steam and Portal 2 to a separated prefix.
  • Set prefix version to Windows XP.
  • Close Portal 2 and steam, and reboot wine by typing wineserver -k.
  • Check integrity of the game trought steam, you can do that by right click on the game and going on Proprieties.
  • You can reinstall Portal 2 and Steam again in a fresh prefix, just copy the folder (your-prefix)/drive_c/Program Files/Steam/steamapps that contain all the Portal 2 files.

 
Old Problems.

Note: These problems don't affect the newest versions of wine, it's only here for precaution, if you have any of these bug's maybe you should upgrade your wine version.


Mouse randomly jumps around menu or in game.
This is caused by the new implementation of mouse input in wine, to solve-it, you need to run the game in Windowed mode or into a Virtual Desktop.


On wine older than 1.3.28 Portal Exists at Menu Screen.

If you're using a version older than 1.3.28 you're soffer Portal Exists at Menu Screen Problem (More info at bug #26835).

To solve the Portal Exists at Menu Screen, Download and apply this patch to your wine compilation. 


On wine older than 1.3.28 Portal ramdomly crash after 5 or more minutes of gameplay.

If you're using a version older than 1.3.28 you're soffer of the 5-Minutes crash (More info at bug #27877) and you have to apply one patch to solve.

To solve the 5-Minutes Crash, download and apply this patch to your wine compilation.


 

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

This game work's amazingly!
by ZachTM on Monday April 8th 2013, 13:37
I am using wine 1.4.1 on Ubuntu 12.10, and installing Portal 2 from DVD works on my computer flawlessly. I couldn't thank the Wine Developers enough, I didnt have to make any extra configuration. I got scared at the beginning because when Chel wake's up the screen is completely white and then it slowly fades away XD. Im running this game on the highest settings, Thank you Wine!!!

[post new] [reply to this]

No sound while playing
by SPGM1903 on Tuesday December 4th 2012, 4:57
Hello, gamers.
I have installed game from DVD. It went good until the end where CrossOver said that installation failed. But everything went good - game runs but with no sound. Portal plays sounds only at the beginning (fat head with red circle faucet) and... nothing later. Sound turns off in the menu, game does NOT crash. Tried to check audio setting in game and in Wine but with no result.
Everything is OK except the sound. Shall I reinstall the game or just change some setiings?

[post new] [reply to this]

Black screen
by Gwilym on Wednesday January 25th 2012, 14:36
Everything seems to work fine (sound, menu etc.) but when I start playing the starting voice begins to speak and the screen is white. Then the screen goes black and stays like that. I have even opened the door for wheatly but still the screen stays black.

I installed from the DVD (through steam) and that all seems to work fine.

Please Help

Gwilym

[post new] [reply to this]


by Laur A on Wednesday August 31st 2011, 17:38
How come i have no Direct3D under HKEY_CURRENT_USER > Software > Wine ?

[post new] [reply to this]

  • RE: by Jannik H. on Thursday September 1st 2011, 17:10
    • RE: by Laur A on Monday September 5th 2011, 7:27
      • RE: by Jannik H. on Monday September 5th 2011, 7:30
        • RE: by Laur A on Monday September 5th 2011, 7:58
Game only starts when UseGLSL is enabled
by Gabriel Moraes on Sunday June 12th 2011, 17:18
My game, unfortunately, only starts when UseGLSL is set as Enabled.
Otherwise, it'll just shut down to the desktop when a new game/level is loaded.

Game starts OK, I see the valve guy, then the SOURCE logo. Menu starts up and the menu effects work alright. Fonts are rendered correctly and on the proper size. Everything is fast and smooth @ 1920x1080. Starting a new game, I see a damaged robot on the ground, and the camera goes farther as it loads. When there's one dot remaining, game shuts down without much bureaucracy.

With UseGLSL, my framerate drops dramatically, and my computer freezes after a while.

Config:
AMD Athlon 64 X2 5000 @ 2.8GHz
2GB DDR2 800
AMD Radeon HD3200 256mb shared @ 910MHz
ATi Catalyst 11.5 8.850
Linux Kernel 2.6.35-28
Ubuntu Maverick
Game running on a XFS partition. Ubuntu filesystem lives on EXT4.
Wine 1.2.3 (Tried with 1.3, no dice)
Tried all possible resolutions and video modes. No dice

[HKEY_CURRENT_USER]/Software/Wine/Direct3D
DirectDrawRenderer = opengl
Multisampling = disabled
OffscreenRenderingMode = fbo
StrictDrawOrdering = disabled
UseGLSL = disabled
VertexShaders = hardware
VideoMemorySize = 256
[HKEY_CURRENT_USER]/Software/Wine/DllOverrides
*msvcr100 = native,builtin
*msvcr80 = native,builtin
*msvcr90 = native,builtin
*msxml3 = native

the vcrun20** all reported as "failed" during their installment, but they still show up there.
Portal 1 and GTA San Andreas works flawlessly with this configuration.

Terminal lines:


fixme:d3d_surface:IWineD3DSurfaceImpl_LoadLocation 0x187620: Downloading rgb texture to reload it as srgb
fixme:d3d_surface:IWineD3DSurfaceImpl_LoadLocation 0x187620: Downloading rgb texture to reload it as srgb
fixme:d3d_surface:IWineD3DSurfaceImpl_LoadLocation 0x187620: Downloading rgb texture to reload it as srgb
Forcing breakpad minidump interfaces to load
Looking up breakpad interfaces from steamclient
Looking up breakpad interfaces from steamclient
Looking up breakpad interfaces from steamclient
Looking up breakpad interfaces from steamclient
Looking up breakpad interfaces from steamclient
mediacenter@mediacenter:/$

Hope there's a fix. Game looks promising, as I've seen with UseGLSL enabled


P.S.: No, I cannot play with UseGLSL enabled. Computer freezes when I get out of the room.

[post new] [reply to this]

Yellow flicker
by Nicolas Joyard on Sunday June 12th 2011, 2:22
If some textures become plain yellow on some places as in these screenshots:
i.imgur.com/hVKmz.jpg
i.imgur.com/e2drQ.jpg

Just disable multicore rendering (options > video > advanced) and restart the game (if you don't, some transparent textures such as fences will be invisible).

[post new] [reply to this]

crash on startup/menu like others
by sinatosk on Tuesday May 17th 2011, 9:12
I have a legit version ( for those who are asking ) and not going to try the crack.

portal 2 goes full screen, a background image shows of portal 2 for example and then it just closes before the menu is shown...

when I run portal2.exe like this

$wine portal2.exe

this is the output

fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:win:EnumDisplayDevicesW ((null),0,0x33e1cc,0x00000000), stub!
Using breakpad crash handler
Setting breakpad minidump AppID = 620
Forcing breakpad minidump interfaces to load
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Steam_SetMinidumpSteamID: Caching Steam ID: xxx [API loaded yes]
Steam_SetMinidumpSteamID: Setting Steam ID: xxx
fixme:keyboard:X11DRV_LoadKeyboardLayout L"00000409", 0000: stub!
fixme:d3d:debug_d3dformat Unrecognized 0x434f5441 (as fourcc: ATOC) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x434f5441) in the format lookup table
fixme:d3d:debug_d3dformat Unrecognized 0x41415353 (as fourcc: SSAA) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x41415353) in the format lookup table
fixme:d3d:debug_d3dformat Unrecognized 0x434f5441 (as fourcc: ATOC) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x434f5441) in the format lookup table
fixme:d3d:debug_d3dformat Unrecognized 0x41415353 (as fourcc: SSAA) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x41415353) in the format lookup table
Convar r_flashlightscissor has conflicting FCVAR_CHEAT flags (child: no FCVAR_CHEAT, parent: has FCVAR_CHEAT, parent wins)
fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),0,3,(nil),0,(nil)) - stub!
fixme:wbemprox:wbem_locator_ConnectServer 0x13d070, L"ROOT\\CIMV2", (null), (null), (null), 0x00000000, (null), (nil), 0x33e120)
fixme:win:RegisterRawInputDevices (pRawInputDevices=0x33de5c, uiNumDevices=1, cbSize=12) stub!
err:x11settings:X11DRV_ChangeDisplaySettingsEx No matching mode found 1680x1050x32 @60! (XRandR)
fixme:d3d9:D3DPERF_SetOptions (0x1) : stub
fixme:d3d:debug_d3dformat Unrecognized 0x31495441 (as fourcc: ATI1) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x31495441) in the format lookup table
fixme:d3d:debug_d3dformat Unrecognized 0x31495441 (as fourcc: ATI1) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x31495441) in the format lookup table
fixme:d3d:debug_d3dformat Unrecognized 0x31495441 (as fourcc: ATI1) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x31495441) in the format lookup table
fixme:d3d:debug_d3dformat Unrecognized 0x31495441 (as fourcc: ATI1) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x31495441) in the format lookup table
fixme:d3d:debug_d3dformat Unrecognized 0x31495441 (as fourcc: ATI1) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x31495441) in the format lookup table
fixme:d3d:debug_d3dformat Unrecognized 0x31495441 (as fourcc: ATI1) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x31495441) in the format lookup table
fixme:d3d:debug_d3dformat Unrecognized 0x31495441 (as fourcc: ATI1) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x31495441) in the format lookup table
fixme:d3d:debug_d3dformat Unrecognized 0x31495441 (as fourcc: ATI1) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x31495441) in the format lookup table
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 10000 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 10000 channels, pretending there's only 2 channels
fixme:mmdevapi:MMDevice_Activate IID_IAudioSessionManager unsupported
Convar building_cubemaps has conflicting FCVAR_CHEAT flags (child: has FCVAR_CHEAT, parent: no FCVAR_CHEAT, parent wins)
Game.dll loaded for "Half-Life 2"
fixme:thread:SetThreadIdealProcessor (0xfffffffe): stub
fixme:thread:SetThreadIdealProcessor (0x258): stub
fixme:thread:SetThreadIdealProcessor (0x274): stub
fixme:thread:SetThreadIdealProcessor (0x290): stub
fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
fixme:dbghelp:elf_search_auxv can't find symbol in module

[post new] [reply to this]

failed to create D3D device
by Mark  Ackerman  on Sunday May 15th 2011, 5:00
I have installed Portal 2 (seemingly fine) from a downloaded skidrow that works in Windows, but always gives the error:
failed to create D3D device

when trying to start the game, any ideas anyone??

[post new] [reply to this]

Works fine
by Oskenso on Tuesday May 3rd 2011, 17:12
Game works out of the box for me. Just install and run.
Wine: 1.3.18
Version: Portal 2 DVD

[post new] [reply to this]

DVD Version Again?
by Josh on Saturday April 30th 2011, 7:10
Should this version exist?

The installer on the DVD installs Steam and automatically updates to the current Steam version before running.

Last week there was a "dvd" version which was deleted.

[post new] [reply to this]

No text and exit after complitly loading the first level
by Frenk on Thursday April 28th 2011, 4:28
at first: I dont speak a good english.

I don t can play the game, cause there a lot of bugs:
-I cannot see the letterings / buttons at the main menu
-you can only see the letterings / buttons in submenu if you click on it. and than the lettering is underlaing with black...
-if I m in the submenu singleplayer (I only think, it is called so) and I click the first mission, the game load 5 seconds, than it s ready to start, but it don t start the first level, portal exits himself...

whats fine: ; )
-I can look the trailers and films
-it don t exit at the main menu

I m using:
-wine 1.2.2.
-ubuntu 10.10
-I have installed with DVD and than i have take the client.dll and the server.dll and the portal.exe and a skidrow.ini from a crack




I hope you have understood me, pls help! I´m looking forward to a answer, Frenky.

[post new] [reply to this]




   << Back

Page loaded in 0.32293 seconds.