WineHQ
Path of Exile Release



Category: Main > Games > Online (MMORPG) Games > Path of Exile > Release


NamePath of Exile
VersionRelease
License Free to use
URLhttps://pathofexile.com/
Votes 8
RatingSilver
Wine Version1.7.19
Free Download Installer [msi] (direct link)
Maintainers of this version:
Description

The official release version, should be akin to a `stable' branch.


Stable releases began with version 1.0.0

Selected Test Results (selected in 'Test Results' table below)

What works
Everything, from main menu to gameplay


What does not


What was not tested
The twitch integrated functionality


Additional Comments

Tested with a Nvidia Card

msvcp100(native, builtin) override requird to make the launcher work.

UseGLSL = "disabled" in registry inorder to reduce lag spikes when a new monster is loaded on the screen.

This will cause bugs such as flickering borders in the main menu and loading screen is all black. But isn't gameplay breaking.
Test Results
DistributionTest dateWine versionInstalls?Runs?RatingSubmitter
CurrentUbuntu 13.04 "Raring" amd64 (+ variants like Kubuntu)Jul 09 20141.7.19 N/A Yes Gold Richard Orilla 
ShowArch Linux x86_64May 24 20141.7.19 Yes Yes Bronze Justin Soulia 
ShowArch Linux x86_64May 01 20141.7.17 Yes Yes Silver smilzoboboz 
ShowArch Linux x86_64Apr 28 20141.7.17 Yes Yes Gold smilzoboboz 
ShowArch Linux x86_64Apr 09 20141.7.15 Yes Yes Garbage jc 


Known bugs
Bug # Description Status Resolution Other apps affected
32463 Font artefacts in Path of Exile NEW View
34011 Path of Exile stutters constantly UNCONFIRMED View
34791 Path of Exile: minimap don't work, when I hit "Tab" UNCONFIRMED View
34820 Path of Exile crashes on resize UNCONFIRMED View
35718 Multiple games have extreme flicker, stutter, slowdown (Path of Exile, Roller Coaster Tycoon, Counter Strike: Global Offensive, Warframe, Crysis, Anno 1602, Splinter Cell: Blacklist) NEW View

 

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

Problem updating to 1.1.3
by Eelco Bosselaar on Thursday May 1st 2014, 11:50
Having problems updating to 1.1.3. Patcher screen stays stuck on 97.5% downloaded and will eventually throw a timeout error about not being able to download a certain sound file.

Trying to workaround this by having steam download the game update and then copying it to my standalone version for PoE.

Already ran PackCheck.exe and it said it fixed my ggpk but the error remains.

I will update when I find out more.

[post new] [reply to this]

Black screen
by Marcin Falkiewicz on Thursday April 10th 2014, 12:06
Regarding the black screen issue, changing in regedit (check wiki.winehq.org/UsefulRegistryKeys ) OffscreenRenderingMode to 'backbuffer' solves the problem.

[post new] [reply to this]

Crash with Debian Jessie and latest fglrx-driver
by Anb on Tuesday March 18th 2014, 10:41
Since the last update of debian jessie and fglrx-driver (14.2~beta1.3), path of exile crash at startup.

For now, the only way to have it work is to not upgrade your debian.

The upgrade will update xorg-server to a newer major version which is not compatible with previous fglrx-drivers, so downgrade is very difficult.

I'm trying to update to latest ati drivers manually (14.3) to check.

[post new] [reply to this]

it no longer works in wine 1.7.14 or
by Joël on Saturday March 8th 2014, 12:00
i upgraded wine to version 1.7.14 and the path of exile client won't work anymore.
It seems the updater still works fine, but as soon as the actual client starts, it crashes the X server.
So i bet something was changed from version 1.7.13 :(

Any help would be appreciated (also i don't know how to create bug reports).

[post new] [reply to this]

Wrong install path
by Dan Johansen on Friday February 14th 2014, 16:30
I only have one problem with my PoE install. It doesn't install the files in the folder I specify. It installs them directly into my Home directory, without a subdirectory.

How to fix that?

PS: I use a seperate prefix for it.

[post new] [reply to this]

d3derr
by aobe5dhk on Wednesday February 12th 2014, 8:09
Hi,

I have linux Mint 16 x64 and I have installed PoE from PlayOnLinux.
I have got "error unable to create texture d3derr ... ".

I have read some threads about this problem but I can't find a solution.
I have installed libosmesa6 but no luck.
I also tried to enable GLSL=enable from playonlinux menu but still no luck.

I have mesa 10.2 development version drivers that I have installed from ppa: xorg-edgers/ppa/ubuntu/ and my video card is ATI MSI R6870.

here is my debug log from game:

pastebin.com/raw.php?i=PmRnTefc

I hope you can help me.
Thanks

[post new] [reply to this]

  • RE: d3derr by aobe5dhk on Wednesday February 12th 2014, 12:56
Installation over Steam
by pfftzo on Monday January 27th 2014, 14:54
I just installed it via Steam and when I started it, it said "Installing VCRedist step 1/2" and then finished and nothing happened, ie the game didn't start, the window just terminated and I was back in plain steam. :(

[post new] [reply to this]

Font artifacts
by RT on Wednesday December 25th 2013, 14:29
Text is much more readable after adding the following into the Wine registry:

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\FontSubstitutes]
"Fontin SmallCaps"="Fontin"

Before: bugs.winehq.org/attachment.cgi?id=46992
And after: bugs.winehq.org/attachment.cgi?id=46993

wiki.winehq.org/UsefulRegistryKeys

[post new] [reply to this]

Gentoo users, help?
by Pekka Paalanen on Friday December 13th 2013, 14:34
I'm hitting the "Cannot create texture." D3DERR_NOTAVAILABLE error too, and no matter what I tried, it won't go away. 32-bit mesa, osmesa and whatnot. This is not the first game, where other people (even on Gentoo) get it running, but I cannot.

Could a Gentoo user who got PoE running, put the output of the following commands available somewhere?
$ emerge --info
$ emerge -evp wine
$ winetricks list-installed

Note, that the output is probably too long to be pasted as a comment here.

Also the *.reg files from your $WINEPREFIX would be nice to see.

Thanks.

[post new] [reply to this]

Chat window affects performance
by Silviu C. on Monday December 9th 2013, 15:33
I've found that disabling both trade chat and general chat will improve the performance of this game significantly. Easy to observe by pressing F1 while in game. FPS shot from 30-ish to over 100 on my GTX 660.

Can anyone else confirm this?

[post new] [reply to this]

Strange Crash
by Mojo Troll on Monday November 11th 2013, 10:20
I just installed this using a pc version of steam and everything seemed to be running fine with it until a strange crash occurred where even launching my wine command through terminal (showed nothing only showed launch after it loaded) it just locks up and a transparent box appears on my screen titled Path of Exile and this happens every so often playing it so i'm thinking its a memory allocation crash. Anyone else have this?

[post new] [reply to this]

Failed Resetting Direct3D device objects
by Drake on Wednesday October 23rd 2013, 23:54
When I try to launch I get the error "Failed resetting Direct3D device objects."

Anyone know what might cause this? Followed all of the steps listed.

The only thing worth mentioning is that I have almost every single version of DirectX installed because this is my Steam wrapper (lots of games with different requirements). Could this be causing the issues?

I'm on OS X 10.8.5

[post new] [reply to this]

D3DERR_UNAVAILABLE
by tsimbaloff yuri on Sunday October 20th 2013, 16:40
Hi All!
I'm using gentoo64, and I saw error message after logging and loading the first location. I have seen in this site, that lib32osmesa is required to play PoE. I compile mesa with ABI_X86="64 32" and USE="osmesa", but game always crashed...

Can anybody help me with gentoo64 and PoE?

[post new] [reply to this]

how to fix msvcp and msvcr dll errors
by Joël on Wednesday July 17th 2013, 14:50
Today i couldn't run the game because of errors with these 'dll's.
It seems this game uses some 2010 year version of those MS files so you'll want the files with number 100 in filename.

And there's probably a winetricks command to make all this automagically but i didn't find which one it is.

So i downloaded msvcr100.dll and msvcp100.dll, i unzipped it in the game directory.
Then i added them as native in the library tab of winecfg (for Client.exe which i first added in the applications tab).

So far the game seems to be happy with only these 2 files.

[post new] [reply to this]


by Tom Hackers on Tuesday June 25th 2013, 10:07
Ferg's "manual" is best. appdb.winehq.org/objectManager.php?sClass=version&iId=25078&iTestingId=78043

[post new] [reply to this]

  • RE: by Tom Hackers on Tuesday June 25th 2013, 10:09
Memory Problem
by wehde on Saturday May 18th 2013, 19:09
has anyone managed to figure out why the drops frames and seems to lag when new abilities or mobs are loaded in memory? I'm using wine version 1.5.28 with usp10 riched20 d3dx9_42 msvcr100 openal32 d3dcompiler_43.

[post new] [reply to this]

client link don't work
by muzzol on Thursday May 2nd 2013, 6:37
not a big deal, I know.

this is the right one: webcdn.pathofexile.com/downloads/PathOfExileInstaller.msi

[post new] [reply to this]

openal32.dll
by eXpander on Thursday April 18th 2013, 17:41
How exactly do you "override" openal32.dll in winecfg? I cannot find it in my library list in winecfg? Do I have to install it somehow separately?

[post new] [reply to this]

Fonts
by Ferg on Thursday April 18th 2013, 0:44
To fix problem with fonts (like that ferg.in/storage/m2nGe6t3/) just move game to a new wine prefix (installer breaks something during installation)

[post new] [reply to this]

  • RE: Fonts by Tom Hackers on Saturday June 22nd 2013, 6:12
    • RE: Fonts by Tom Hackers on Saturday June 22nd 2013, 6:20
  • RE: Fonts by dimitri on Thursday August 22nd 2013, 15:35
Works awesome suace in Playonlinux.
by Damon on Wednesday April 17th 2013, 17:20
I couldn't get this working due to the allocating disk space bug, until I downloaded the new wine version entitled: 1.5.28-pathofexile. Now it works perfectly :)

[post new] [reply to this]

Allocating Space slow easy fix
by zyvy on Monday April 8th 2013, 16:50
go to
www.pathofexile.com/forum/view-thread/233564
very easy fix

[post new] [reply to this]

ATI
by marcel on Tuesday March 12th 2013, 3:47
with ATI HD 4xxx game is unplayable with high FPS drops when using new skills. It's like they are loading when they are only being used. Because after you use them the FPS drops stop, and when something new is there it starts to lag again.

[post new] [reply to this]

  • RE: ATI by mathew on Thursday April 11th 2013, 1:54
Sound
by Joseph on Thursday February 28th 2013, 23:54
I have a very low "gargling" sound when turning on any kind of sound under the options.

[post new] [reply to this]


by lahtis on Tuesday February 26th 2013, 13:34
Installing version 0.10.1f Allocating Space takes about 8 hours time in my Intel® Core™2 Duo CPU E4400 @ 2.00GHz × 2 prosessor. it is not fast.

[post new] [reply to this]

GLSL
by a51ts2 on Tuesday February 12th 2013, 11:51
Using ATI catalyst drivers I had to leave GLSL enabled, otherwise the screen (except for some UI) is black.

[post new] [reply to this]


by Oleg on Friday February 1st 2013, 20:53
Hi guys, I have problem with video. Game is opening fine, I can log into my account and choose character. But after that, when the game map is loading, error comes out:
Unable to create texture. D3DERR_NOTAVAILABLE Not Available.

Can you help me please? I'm desperate.

prefix configuration:
winetricks d3dx9_36 vcrun2010 sound=alsa
openal32 native (windows)
virtual desktop 1024x768

Distro: ArchLinux
kernel: 3.7.5-1-ARCH x86_64
video: intel i915 driver (xf86-video-intel 2.20.19-1) - adapter_name=Intel(R) Ivybridge Desktop
wine: 1.5.22-1
Desktop enviroment: i3 WM (i3-wm 4.4-2)
Audio system: alsa/jack

wine log pastebin.com/v3SZm8md
production_Config.ini pastebin.com/8QF7d6pW
list of installed 32bit libs pastebin.com/EjMkynjc
full wine log with WINEDEBUG=warn+all pastebin.com/AppWUFfd

[post new] [reply to this]

Fps drops
by alex on Wednesday January 30th 2013, 11:42
There is a common problem causing huge fps drops (or even complete freezes for seconds) every time certain effects are loaded, especially when new boss monsters appear.

It has been reported by multiple users that this issue can very easily be fixed for nvidia cards by just disabling GLSL shaders. On Ati cards however this seems to cause major graphics glitches or crashes.

[post new] [reply to this]

Resolution glitch
by Keenan Verbrugge on Tuesday January 29th 2013, 23:15
Not sure what's happened now but the game is really loving this tiny resolution. Not sure how to best describe it so here is a pic: i.imgur.com/RgxEll6.jpg

[post new] [reply to this]

Ram issue
by fotis on Monday December 31st 2012, 6:11
i have a problem with my ram path of exile after 20m loads up 3.2 gb of ram wtf??
and my fps always going crazy from 100 to 10 non-stop
i created a swap file cause my system was frezzing after POE for 20m
but still 3.2gb of ram for a game is much...

PS: FPS are crazy from the start of the game its not cause of the ram.

GPU: ATI Radeon hd 6670
CPU: AMD FX 4100
RAM: 4GB RAM DDR3

[post new] [reply to this]

audio causing freeze
by Netsrotti on Wednesday May 9th 2012, 19:34
To solve the audio freeze when using active skills I added openal32 native under winecfg libraries tab.

[post new] [reply to this]




   << Back

Page loaded in 0.15772 seconds.