WineHQ

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

RE: Loki Installer Gone
by Antonio López on Sunday July 8th 2007, 12:44
Try:

wine eject :

(in a shell, of course) :-)
RE: Loki Installer Gone
by Antonio López on Sunday July 8th 2007, 12:46
Sorry, it seems this site does not allow "tags":

wine eject drive_letter:
RE: Loki Installer Gone
by Ben on Sunday July 8th 2007, 13:16
That works. My problem is that the second CD will not mount properly afterward. I put it in but it appears to be an empty disk. If I mount it outside of the installation process it's ok and I can see everything... but during install it won't work.

Maybe I have to manually do some part of the mounting process. I have 2 CD drives in my computer; is it possible that I could tell it to check the second one somehow?
RE: Loki Installer Gone
by Antonio López on Sunday July 8th 2007, 18:32
Maybe you are trying to change cd while keeping some app (i.e. browser, shell) "occupying" the cd directory so the 1st cd cannot be properly unmounted. Try to start the installation process taking care of not doing that.

For example, if you are running wine from a shell and your 1st cd is mounted on /media/cdrom0, try doing "wine /media/cdrom0/Launch.exe" rather than doing "cd /media/cdrom0" first and running "wine Launch.exe" afterwards.
RE: Loki Installer Gone
by Matt Wrenn on Sunday July 15th 2007, 14:15
I got past the CD swap problem when installing the "Game of the Year" edition of CoD using "wine eject d:", but that introduced a new issue. After the install is complete with the second CD, it asks for the first CD again. I can swap the first CD back in without using the "wine eject d:" command, but the install routine produces this error:

"An I/O error occurred while installing a file. This
is normally caused by bad installation media or
a corrupt installation file
Abort Retry"

I have checked the CD visually and run the install in Windows to confirm that there is nothing wrong with my installation media. I have also re-run the install in Wine using the "wine eject d:" to swap back to the first CD and the same error occurs. Something about this error is preventing the complete installation of the game and it will not run, even after applying a cracked exe. Any suggestion on how to get around this would be greatly appreciated.
RE: Loki Installer Gone
by Antonio López on Wednesday July 18th 2007, 19:05
Hi Matt,

I get the same results as you, but have a look and check out the game is installed anyway. Multiplayer game runs OK, but not the single player game (probably that I/O error got something to do with it).

Maybe it's time to bring this game rating down to Bronze since the Loki installer is not available anymore (I tried to, but to no avail, I don't know why).
RE: Loki Installer Gone
by jeff on Tuesday August 21st 2007, 19:41
I installed the GotY edition too and got this same error. But using Wine 0.9.43 and the v1.4 no-cd fix the single player works fine (so far). I do find it a little ridiculous that even with this installation error non-cracked multiplayer works perfectly.
Loki Installler Found!
by AB on Friday July 20th 2007, 22:21
Excuse me for using a BugMeNot Account
I did a quick google and found this: mirrors.reallan.net/pub/games/liflg/Call%20of%20Duty/call.of.duty_1.5-english.run
I suggest someone mirror this in case this gets taken down
RE: Loki Installler Found!
by Antonio López on Sunday July 22nd 2007, 15:34
Thank you! However I get an error message when trying to use the installer:

mount: /dev/ is not a block device

and the installer is unable to find the manually mounted cd. Anyone has experienced this?