WineHQ

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

RE: Blank LOTRO Store
by Björn Bidar on Friday October 19th 2012, 19:49
It don't have the issue, but it may be caused by your wine_gecko installation?
RE: Blank LOTRO Store
by Apoc on Friday October 19th 2012, 21:34
That was my first thought aswell. However using same version of wine to run the wine version of Internet Explorer seemed to work fine, and a re-install of the wine-gecko package didn't help.

I then tried removing every version of gecko I had installed, and let wine re-install it manually. Still no luck.

What I did find though, is that if I load up the wine version of IE, and run lsof, I find it's accessing a heap of stuff to do with gecko (as expected). But doing the same thing with LOTRO open, I get nothing returned. It seems as if LOTRO is never even accessing gecko (which I guess would explain the complete blankness of the store). Not entirely sure where to go from here though.
RE: Blank LOTRO Store
by Chuck on Friday October 19th 2012, 19:49
The store works for me. Ubuntu 12.04 under play on Linux with fix from above and opengl.
RE: Blank LOTRO Store
by steelsnake on Thursday October 25th 2012, 1:08
This appears to be related to proxy changes. The client seems to query proxy autoconfig, which fails. Setting a proxy manually in the ini file doesn't seem to fix it either.

There's a lot of output on the console about it:
[8:54:19251:ERROR:chrome_url_request_context.cc(94)] Cannot use V8 Proxy resolver in single process mode.
[8:64:24321:ERROR:proxy_resolver_winhttp.cc(95)] WinHttpGetProxyForUrl failed: 0

Whatever Turbine is doing, it's not good for people using Linux.
RE: Blank LOTRO Store
by Marko Friedemann on Thursday October 25th 2012, 10:01
Yeah, having the problem since yesterday also.

I am not sure, but the error messages steelsnake posted hadn't been there before the maintenance on 10/24, but there was no client update.

Or was there and I missed it? Will report back.
RE: Blank LOTRO Store
by William Magill on Thursday October 25th 2012, 12:39
It looks like the 10/24 "changes" had to do with Turbine's internal network. (DDO folks are reporting issues also.)

I started getting a "massive" (i.e. many more than the previous zero) number of proxy failure messages in the PyLotRO "console" window.

Hopefully this is merely a TTL issue and within a day or two the problem will resolve itself.
RE: Blank LOTRO Store
by William Magill on Thursday October 25th 2012, 12:41
I should Add, I'm running the MacPorts "Patched" CrossOver Wine version (1.4.1) on OS X 10.8.2
RE: Blank LOTRO Store
by Marko Friedemann on Thursday October 25th 2012, 12:51
Well, there was no patch yesterday, just maintenance. Maybe there are two code-paths in the client and the server config triggers one of them. Steelsnake, what patch are you referring to in the lotro forum? The one for WinHttpProxyGetUrl that was posted to the ml in november?
RE: Blank LOTRO Store
by Dave on Wednesday January 2nd 2013, 20:14
I was getting a blank white box (no store background as others have posted about)

"winetricks vcrun2008 corefonts" fixed it for me.
RE: Blank LOTRO Store
by Michael Davenport on Wednesday January 2nd 2013, 23:03
This page is considered out of date since December 17th, 2012.