WineHQ

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

RE: LoTRO not working now
by Jeremiah Ragsdale on Sunday December 21st 2014, 12:20
Is yours still running? I didn't play for a week and now when I try this .21 version (in this thread) I'm getting this:

LOG NAME: C:\users\jeremiah\Local Settings\Application Data\The Lord of the Rings Online\CrashHandler_2.log
Launched with args: [C:\Program Files (x86)\Turbine\The Lord of the Rings Online\turbineclientlauncher.exe /r {CRASHRECEIVER} /t {UPLOADTHROTTLE} // -a JCZYXHWJKRK4WP7KHZXDXR7FC -h 74.201.107.57:9004 --glsticketdirect yyVjjGOslhrTMnucKqaehm9PRs/twF9eAUGK19JInhTIpvB2PZSZNGeluO1HgtConDAD7e6Zye7w21/MZCSY3L8E8nmY0k9+pV/asyqcNJw1rLQ/CMZKOBqnqU62p4j8Q0AeH3BytLAMbIrVrL1KM8MmFDrvUyQAftxWMlg900ilZ74eUqYKnf1Pf5E0/KhZU80co2Xkd4lWvswOMfdMfiMkmo6nWuzebAq8y6F/cao1Oee49wUN+gxjpMAQulUx --chatserver 74.201.107.57:2900 --rodat on --language English --bugurl lotrobugs.turbine.com?task=ticket --gametype LOTRO --authserverurl gls.lotro.com/gls.authserver/service.asmx --glsticketlifetime 21600 --supporturl tss.turbine.com/TSSTrowser/trowser.aspx --supportserviceurl tss.turbine.com/TSSTrowser/SubmitTicket.asmx]

PARSE ERROR: Argument: /t (~~throttle)
Couldn't read argument value from string '{UPLOADTHROTTLE}'

Brief USAGE:
C:\Program Files (x86)\Turbine\The Lord of the Rings
Online\turbineclientlauncher.exe
[/t ] [/n ] [/g]
[/p ] [/i] [/d ] [/r ] [//] [~~version]
[/h]

For complete USAGE and HELP type:
C:\Program Files (x86)\Turbine\The Lord of the Rings Online\turbineclientlauncher.exe --help


*** Finished ***
RE: LoTRO not working now
by Dr. Wes Snyder V on Sunday December 21st 2014, 13:56
I just checked and received the same error.
RE: LoTRO not working now
by Don Koch on Wednesday December 24th 2014, 20:25
Sorry for the delay, been out on vacation.

The 15.1 drop needs a new pylotro which can be gotten either from:
github.com/nwestfal/pylotro (the quasi-official copy, I guess)
or
www.kaitou.org/downloads/pylotro.0.2.1.5.tar.gz

If you still have the problem about /t, you've probably run into the same bug I have (you need to upgrade lotroclient, but pylotro won't let you). If so, you can run my modified, upgrade-only version of the old linuxlotro script at:
www.kaitou.org/downloads/llupdate
RE: LoTRO not working now
by Tracey Pitloun on Thursday January 1st 2015, 12:36
I ran the llupdate script and then the new version of pylotro but Im still running into an error that is accross 2 machines now. This happens immediately after logging in. Any ideas?

err:module:import_dll Library OPENGL32.dll (which is needed by L"C:\\Program Files\\Turbine\\The Lord of the Rings Online\\Awesomium.dll") not found

err:module:import_dll Library Awesomium.dll (which is needed by L"C:\\Program Files\\Turbine\\The Lord of the Rings Online\\lotroclient.exe") not found

err:module:LdrInitializeThunk Main exe initialization for L"C:\\Program Files\\Turbine\\The Lord of the Rings Online\\lotroclient.exe" failed, status c0000135

LOG NAME: C:\users\tracey\Local Settings\Application Data\The Lord of the Rings Online\CrashHandler_1.log
Launched with args: [C:\Program Files\Turbine\The Lord of the Rings Online\turbineclientlauncher.exe /r crash.lotro.com:8080/CrashReceiver-1.0 /t 1 // -a JA7CXXF4DPWX3M3JT3LCXZ7LT -h 74.201.107.58:9004 --glsticketdirect eQL3WFk05aMKDptQzM6KcIajI8BF2YzeTS27tbrkUpcjW9KmcMaDoYS+gt/5LcxmYpcRAigpqs/NN1V8V9TAIa+BO/YBRtu8Tx4V2H3goJ7AgpTdLtdBL17AkmUWcHgxkN9IT9s56dhvRa18gs8VS0k5RcRCUbH6hnME+MNawNFe+/3eC4YpTYAAiobRgbcb7PiXiKFhEJaHtRfleEYH8K3eOnXCsIAJ9kTE2AwSplMIN6Z62Cw7p4FXfreFoiYh --chatserver 74.201.107.58:2900 --rodat on --language English --bugurl lotrobugs.turbine.com?task=ticket --gametype LOTRO --authserverurl gls.lotro.com/gls.authserver/service.asmx --glsticketlifetime 21600 --supporturl tss.turbine.com/TSSTrowser/trowser.aspx --supportserviceurl tss.turbine.com/TSSTrowser/SubmitTicket.asmx --HighResOutOfDate]
Crash Receiver [crash.lotro.com:8080/CrashReceiver-1.0]
Dump Type [mini]
Upload Dumps [TRUE]
Client Args [-a JA7CXXF4DPWX3M3JT3LCXZ7LT -h 74.201.107.58:9004 --glsticketdirect eQL3WFk05aMKDptQzM6KcIajI8BF2YzeTS27tbrkUpcjW9KmcMaDoYS+gt/5LcxmYpcRAigpqs/NN1V8V9TAIa+BO/YBRtu8Tx4V2H3goJ7AgpTdLtdBL17AkmUWcHgxkN9IT9s56dhvRa18gs8VS0k5RcRCUbH6hnME+MNawNFe+/3eC4YpTYAAiobRgbcb7PiXiKFhEJaHtRfleEYH8K3eOnXCsIAJ9kTE2AwSplMIN6Z62Cw7p4FXfreFoiYh --chatserver 74.201.107.58:2900 --rodat on --language English --bugurl lotrobugs.turbine.com?task=ticket --gametype LOTRO --authserverurl gls.lotro.com/gls.authserver/service.asmx --glsticketlifetime 21600 --supporturl tss.turbine.com/TSSTrowser/trowser.aspx --supportserviceurl tss.turbine.com/TSSTrowser/SubmitTicket.asmx --HighResOutOfDate]
Executable [C:\Program Files\Turbine\The Lord of the Rings Online\lotroclient.exe]
Working Dir [C:/Program Files/Turbine/The Lord of the Rings Online/]
Artifact Dir [C:\users\tracey\Local Settings\Application Data\The Lord of the Rings Online\]
Upload Throttle [1 Mbps]
Create Debugged Process: 1, process handle: 164, thread handle: 168, processID: 21, threadID: 25
Command Line ["C:\Program Files\Turbine\The Lord of the Rings Online\lotroclient.exe" -a JA7CXXF4DPWX3M3JT3LCXZ7LT -h 74.201.107.58:9004 --glsticketdirect eQL3WFk05aMKDptQzM6KcIajI8BF2YzeTS27tbrkUpcjW9KmcMaDoYS+gt/5LcxmYpcRAigpqs/NN1V8V9TAIa+BO/YBRtu8Tx4V2H3goJ7AgpTdLtdBL17AkmUWcHgxkN9IT9s56dhvRa18gs8VS0k5RcRCUbH6hnME+MNawNFe+/3eC4YpTYAAiobRgbcb7PiXiKFhEJaHtRfleEYH8K3eOnXCsIAJ9kTE2AwSplMIN6Z62Cw7p4FXfreFoiYh --chatserver 74.201.107.58:2900 --rodat on --language English --bugurl lotrobugs.turbine.com?task=ticket --gametype LOTRO --authserverurl gls.lotro.com/gls.authserver/service.asmx --glsticketlifetime 21600 --supporturl tss.turbine.com/TSSTrowser/trowser.aspx --supportserviceurl tss.turbine.com/TSSTrowser/SubmitTicket.asmx --HighResOutOfDate]
Working Dir [C:/Program Files/Turbine/The Lord of the Rings Online/]
CheckForOldCrashes: Looking for pending .crashuploadcontext ... in [C:\users\tracey\Local Settings\Application Data\The Lord of the Rings Online\]
EXIT_PROCESS_DEBUG_EVENT: The program '[21]' has exited with code 3221225781 (0xc0000135)

*** Finished ***
RE: LoTRO not working now
by Don Koch on Wednesday January 7th 2015, 22:03
It would appear that you're missing the drive_c/windows/system32/opengl32.dll file or it's failing to init. Do you have /usr/lib/libGL.so* and /usr/lib/libGLU.so* installed? Which graphics card(s)? Which X11 driver(s)?