WineHQ

Age of Empires

The first Version of the War/Strategy Game

Application Details:

Version: 1.0
License: Retail
URL: http://www.microsoft.com/games...
Votes: 3
Latest Rating: Gold
Latest Wine Version Tested: 1.9.22

Maintainers: About Maintainership

Link Download update

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Installed fine and ran when launched from install after installing Direct Play

What does not

Text color on menus is always black.

Only ran directly from install. Afterwards error: "Could not initialize graphics system. Make sure that your video card and driver are compatilbe with DirectDraw."



Workarounds

What was not tested

nothing

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowFedora 24 x86_64Nov 17 20161.9.22Yes Yes GoldFederico Guerra 
ShowLinux Mint 17 "Qiana" x86_64Aug 23 20141.7.24Yes Yes Bronzean anonymous user 
ShowUbuntu 12.10 "Quantal" amd64 (+ variants like Kubuntu)Oct 28 20121.5.15Yes Yes Goldan anonymous user 
ShowKaliNov 18 20141.4.1Yes Yes GoldBob Niemöller 
ShowArch Linux x86_64Dec 10 20111.3.34Yes Yes Platinuman anonymous user 

Known Bugs

Bug # Description Status Resolution Other apps affected
1830 Multiplayer problem in age of empires (All versions) NEW View
3548 .lnk file is created on the desktop together with the program icon... NEW View
4066 Online Play Doesn't Work (DirectPlay) NEW View
17682 AoE Help graphics immediately whitened, no text NEW View
34166 Fullscreen flickering on Mac RESOLVED NOTOURBUG View

Show all bugs

HowTo / Notes

HOWTO
­Use Wine version 0.9.36 or newer (version 0.9.31 or earlier also work)

To prevent installer windows from being hidden, change Wine's settings so that the window manager is not allowed to control Wine applications (can be done with winecfg).

In Wine versions prior to 0.9.17, elements such as taskbars designed to cover other applications are not hidden when Age of Empires II is run in full-screen. This can be fixed by not allowing the window manager to control Wine applications (can be changed in winecfg), or by changing the taskbar's options so that windows are allowed to cover it.

Crack
If the game does not recognice your CD, use a crack. This may or may not be legal, depending on where you live.

Multiplayer
To get multiplayer working, place the following DLLS in Wine's windows/system32 directory, then start winecfg and add dll overrides (native, builtin) for them: dplayx, dpnet, dpnhpast and dpwsockx.
NOTE: the game freezes when exiting a multiplayer game.

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

AOE on Ubuntu 8.04 Hardy Desktop (64bit)
by Sastry Tumuluri on Thursday July 31st 2008, 8:42
The install went through with the usual minor issues like:
a) long (2minutes +) pause at "listing files" or something like that
b) partial display / no display of buttons / menu items (during installation)
c) crib about Direct X 5.0 (I chose "Don't Install')

The game started up fine (except very dark button text) when I clicked "play" from the installer menu.
It also starts up fine whenever I insert the CD, navigate to it, start the installer and click "play" from the installer menu.

Real Problems:
1. It did not install any shortcuts on desktop; no addition to menu items. I added them manually through the menu-editor, and landed with the next (below) problem.
2. When I start wine (file) explorer , navigate to the game directory, and dbl-click on Empires.exe (or start the game through the manually added menu item), it says "Could not initialize the graphics system. Make sure your video card and driver are compatible with DirectDraw."
RE: AOE on Ubuntu 8.04 Hardy Desktop (64bit)
by Philip Wagenknecht on Wednesday November 26th 2008, 5:07
I have experienced the second problem on Gentoo amd64 with wine 1.1.4 and trial version of AoE. I have observed, that the problem disappears after X server restart. Switching to text console and back does not help though.

by Andurian on Saturday May 10th 2008, 6:34
i tried AoE and AoEx and neither worked for me.
aoe gave me some directdraw problem(dont ask, my video card is fine, i run aoe2 and others fine). and rise of rome crashes on me big time. go figure...

oh, and yes i did all the recommended steps and etc...
RE:
by Reuben on Sunday April 26th 2009, 7:06
I've found that if you run Empires.exe from within the aoe directory it will stop giving the directdraw message.
Constant stuttering
by Hiperi0n on Wednesday May 7th 2008, 18:05
AoE 1.0c under Ubuntu Hardy and wine-0.9.61. I experience constant slowdowns/stuttering, which are quite annoying. The games slows/pauses every second more or less. It also happens with the AoE trial version. Any fix?

Also, I can't get the midi music to work.
(fixme:mcimidi:MIDI_mciPlay NIY: MIDI port=0, track=1 )

by Luuk de Waal Malefijt on Wednesday May 7th 2008, 7:31
or use this: wine empires2.exe -- -opengl
CD not found
by Tim Scharrenborg on Sunday January 20th 2008, 14:57
I've tried everything I could think of, but, for some reason, the program fails to find the CD. Install works fine, however.

Anyone have a fix?
RE: CD not found
by Tim Scharrenborg on Sunday January 20th 2008, 17:00
okay, apparently it was my own fault. should have installed it in the default install directory, else it will not work.

bug?
installation
by Martin Spelt on Tuesday January 3rd 2006, 8:41
@the person who tried to install on arch linux and other people with this problem.
I had the same problem during installation, the problem probably is that the window saying that the chosen directory does not exist, and asks if you want to create it, appears behind the normal installation window, so I couldn't choose OK.
Solution: Run wine in a virtual desktop, go to winecfg, Graphics, and choose emulate a virtual desktop (or something similar, I have a non-English version). The next time you try to install AoE the window should appear somewhere in the wine window and you're able to click OK and continue with the installation.
Multiplayer: connected!
by Pavel Reznicek on Saturday July 23rd 2005, 5:14
Hi all,

I had problems with the multiplayer mode in AoE on WINE and I finally solved them and want to report my success for those who are intersted.

Generally, take a look at this discussion post:
www.winehq.org/hypermail/wine-users/2004/02/0174.html

If I'm correct, you should follow these steps:

1) You should have DirectX installed. It doesn't need to be the current version. Why? Because of the native DLL's of DirectPlay network playing system.

2) Make sure your WINE registry file (~/.wine/system.reg) includes the registry information that can be found in the link mentioned above. These entries are absolutely necessary for the network play.

3) In order to play via TCP/IP protocol, you should configure WINE to prefer native form of these DLL's:

- dplayx
- dpnhpast
- dpwsock
- dpwsockx

I din't test other types of connection but, if you want, you can go through the registry entries mentioned above and figure out which other libraries do you need to connect other ways (let's say, serial line or modem). These may include:

- dpmodemx
- dpserial

4) Beware of the sound! WINE still has problems playing the sound from AoE. Playing with music & sound can cause WINE to crash. This is just another episode, but just for start, you can turn the sound off in AoE :-)

Tested with the latest WINE version (20050628) from Mandriva LE 2005 RPMs.
Back