WineHQ

Call of Duty 4: Modern Warfare

Update to the 1.0 version

Application Details:

Version: 1.6
License: Retail
URL: http://charlieoscardelta.com/
Votes: Marked as obsolete
Latest Rating: Silver
Latest Wine Version Tested: 2.1

Maintainers: About Maintainership

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

playing MP, hosting an MP session(did not test if any clients could connect), sound works not perfect(full hardware accelerated, no emulation needed in OSS and ALSA)

What does not

Game is playable and sound effect sound perfect, however there is always noise and glitches during startup or menu selection (before entering a game). I have ALSA and OSS support, but the game makes random small beepies and small glitch noises. The noises seem to go away when actually playing the game.

Shutting down the CoD 4 application in window mode, makes the CoD4 process defunct. When I click yes on the question do you want to quit, it just hangs. I must kill the wine window to close the game. The same applies when in full screen mode.

I have a dual screen tft, but seperate Xwindows instances.
in full screen mode with tft native res: 1600 * 1200
game resolution: 800*600, The screen is split in half. I have set wine to emulate window to fix this. (I can barely select quit and click yes.)
game resolution: 1027*768: game shows normal and is playable as normal, but still hangs when wanting to exit

Game runs slow on res 1024*768 with no extra features off. (I think) it is because due to my old graphics card, the game was not running smooth in full screen with a game res of 1024*768.

Single player, in windowed mode and full screen: When selecting new game, the sound hangs by repeating a 2 second sample of the intro, but loading continues for a while. during loading the game becomes really slow and stops eventually. Have to use kill command to stop the process. Even when lowering res to 800*600 and setting it from full hardware accelrated to emulation, it is not playable.

(I havent applied patch of 3d mark yet)

Workarounds

What was not tested

letting users connect to my host.
installing the game (I did this with 0.9.52)
and everything else I forgot to mention.

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

graphics card: Nvidia Geforce 6800 motherboard: Asus A7V600 onboard sound: VIA VT8237 AC97 Audio Controller with ALSA and OSS support.

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowUbuntu 16.04 "Xenial" i386 (+ variants like Kubuntu)Apr 05 20172.1Yes Yes Silverprezes 
ShowUbuntu 16.04 "Xenial" amd64 (+ variants like Kubuntu)Apr 03 20172.1Yes Yes Platinumprezes 
ShowLinux Mint 14 "Nadia" x86_64Jun 29 20131.6-rc4Yes Yes Platinumoujae 
ShowLinux Mint 15 "Olivia"Jun 01 20131.5.31Yes Yes Silveroujae 
ShowUbuntu 10.04 "Lucid" amd64 (+ variants like Kubuntu)Oct 10 20101.2.1Yes Yes GoldOrkanPaL 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

HowTo / Notes

Informations
The notes about COD4 and wine are moved to 1.7, please check it out there.

Comments

Back