WineHQ
Category: Main Utilities VAG-COM 409.1s

VAG-COM

No Screenshot

Submit Screenshot
Release 409.1 (serial)

Application Details:

Version: 409.1s
License:
URL: http://www.ross-tech.com/vag-c...
Votes: 0
Latest Rating: Silver
Latest Wine Version Tested: 1.3.11

Maintainers: About Maintainership

No maintainers. Volunteer today!

Test Results

Old test results
The test results for this version are very old, and as such they may not represent the current state of Wine. Please consider submitting a new test report.
Selected Test Results

What works

Everything except a baud rate bug (see below)

What does not

Serial port baud rate would reset to 0 when running a new "Test" or "Select" after a "Test". This makes port unusable

Workarounds

What was not tested

Different adapters (incl. genuine Ross-Tech cables and pure serial), only a noname KKL-USB

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

It seems that almost any version of VAG-COM/VCDS would work with the configuration described. I tried VAG-COM 311.2, VAG-COM 409.1 and VCDS-Lite 1.1 - all worked well. Tested using a KKL-USB cable with Serial-to-USB FTDI_FT232R inside. Full device name as seen by OS: /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A400h11D-if00-port0 Device driver: ftdi_sio Do not forget to add a symlink $WINEPREFIX/dosdevices/comN to this device and change permissions (see http://www.winehq.org/docs/wineusr-guide/misc-things-to-configure) Works flawlessly except one issue: if port baud rate is set to 0, the app fails to communicate with "Interface not found" error. When launched from console, a message "err:comm:get_baud_rate unknown speed 1000" is generated by Wine The fix is to use stty and set baud rate to something acceptable, i.e. 9600: stty -F $WINEPREFIX/dosdevices/com1 speed 9600 This is to be repeated after each "Options->Test" and after first "Select". To automate the process, I have created a launcher: #!/bin/bash #VAG-COM launcher for Linux #Does what: # - Launches VAG-COM via Wine # - Specifies COM port baud rate, if set to zero (fixes an "Interface not found" bug") # - If necessary, applies fix to VAG-COM 409.1 (fake registered version) # - Repeats on specified interval # Copyright (c) Alexey Antipov 2011. Public domain. [ -z "$WINEPREFIX" ] && WINEPREFIX="$HOME/.wine" #These settings may vary between VAG-COM installations and systems #Change them according to your needs #COM port (should be a symlink in $WINEPREFIX/dosdevices to /dev/ttyUSBx or /dev/serial/by-id/blablabla) PORT="com1" #Path to VAG-COM executable VAGCOM="$WINEPREFIX/drive_c/Program Files/VAG-COM/VagCom.exe" #Default baud rate for COM port BAUD=9600 #Polling interval INTERVAL=0.5 #Bad WINEPREFIX [ -d "$WINEPREFIX" ] || exit 1 #No COM port found [ -h "$WINEPREFIX/dosdevices/$PORT" ] || exit 1; VAGCOM_DIR=`dirname "$VAGCOM"` cd "$VAGCOM_DIR" PROG=`basename "$VAGCOM"` if [ -z `pidof "$PROG"` ]; then #VAG-COM not running, launch wine "$PROG" & sleep 1 fi while true; do if [ -z `pidof "$PROG"` ]; then #VAG-COM exited exit 0; fi #Set COM port baud rate, if not set or reset by VAG-COM if [ `stty -F "$WINEPERFIX/dosdevices/$PORT" speed` = "0" ]; then stty -F "$WINEPERFIX/dosdevices/$PORT" speed $BAUD fi sleep $INTERVAL done

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
CurrentUbuntu 10.10 "Maverick" amd64 (+ variants like Kubuntu)Jan 16 20111.3.11Yes Yes Silveran anonymous user 
ShowUbuntu 8.04 "Hardy" i386 (+ variants like Kubuntu)Oct 24 20081.0.1Yes Yes Bronzean anonymous user 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

Comments

Comments Disabled

Comments for this application have been disabled because there are no maintainers.
Back