WineHQ

Avant Browser

Application Details:

Version: 11.x
License: Free to use
URL: http://www.avantbrowser.com
Votes: 0
Latest Rating: Bronze
Latest Wine Version Tested: 1.1.16

Maintainers: About Maintainership

No maintainers. Volunteer today!

Free Download Avant Browser download page Free Download Avant Browser 11.6, build 6 Free Download Avant Browser main page (latest version may not match this test results version) Free Download Latest Avant Browser version download (may not be v11.7b19)

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

The UI comes up alright, but having to use the Gecko plugin for the IE rendering plays havoc with the AB. When the browser is run with a default wine config, the browser doesn't properly accept URLs (from either the 'Address:' bar or 'Open a Link' dialogbox). When installed and run with ies4linux, the browser installs/runs with a few caveats. There are a few hiccups (see below), but in general it works. The jiggling (and subsequent lock-up of the UI) of the Address: bar is fixed, and the Address: bar, the 'Open new link' popup, and the Home page input (Tools->Avant Options) render properly.

What does not

1) When installed under the default wine config, URLs cannot be entered into the Address: or 'Open new link' popup. You can enter them, but after hitting return or clicking 'OK', the text is truncated to the first letter of the URL. This does not happen when IE is installed using ies4linux.

2) The toolbar shortcuts. They work at first, but then (inexplicably) they don't. Workaround: Hit ALT+D (send focus to the Address: bar), and the keyboard shortcuts will start working after that.

3) Sites with Flash embedded on them (e.g., the Yahoo! homepage). Sites with Flash on them constantly refresh for a time. It becomes very annoying.

Workarounds

What was not tested

I hope I got it all.

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

Will install and run under a default wine config, but websites can only be viewed when installed under ies4linux.

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowSlackware 12.2Mar 12 20091.1.16Yes Yes Bronzean anonymous user 
ShowSlackware 12.2Feb 14 20091.1.15Yes Yes Bronzean anonymous user 
ShowSlackware 12.2Jan 31 20091.1.14Yes Yes Bronzean anonymous user 
ShowSlackware 12.2Jan 19 20091.1.13Yes Yes Bronzean anonymous user 
ShowSlackware 12.2Jan 02 20091.1.12Yes Yes Bronzean anonymous user 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

HowTo / Notes

Running Avant Browser 10.1, build

On versions of Wine prior to 0.9.8 (you shouldn't really be doing this, use the latest version of Wine), the operation of the browser appears to work better if:

1) You start-up the browser with the following command:

WINEDLLOVERRIDES='ole32=n' wine c:\program files\avant browser\avant.exe

2) And turn-off the 'Address' bar (View->Address Bar).  Once you turn-off the 'Address' bar, the UI seems to start responding more correctly (not perfectly, but more correctly).

HOWTO

The AvantBrowser will install and run under a default wine config in 0.9.34, but doesn't render websites. Therefore, use following install/run procedure:

1. Install IE (ies4linux works for me).

2. Download and install the Avant Browser to the ies4linux WINEPREFIX location (default WINEPREFIX location for ies4linux is, ${HOME}/.ies4linux/ie6).

3. Change to the Avant Browser install directory (default location is 'C:\Program Files\Avant Browser).

4. Start the browser:

WINEPREFIX=${HOME}/.ies4linux/ie6 wine avant.exe

(See Note below if you're using a pre-0.9.8 Wine version)

5. The browser will start and a splash screen will be displayed. If the splash screen doesn't disappear of its own accord, continue on. Else, if everything appears to be working fine, stop here.

6. Click the 'View' toolbar menuitem and uncheck the 'Address Bar' option. If you can't see the toolbar, just click where the toolbar would be (the row just below the titlebar). Eventually, you'll hit a toolbar menuitem (the default menuitems position is about two-thirds the way along the top bar when maximized [initial size] and about halfway along the top bar when 'restored'), and the other menuitems should show. Click 'View' and uncheck the 'Address Bar' option.

7. Things should start going then.

Running Avant Browser 11.0, build 43, on pre-0.9.8 Wine versions

On versions of Wine prior to 0.9.8, the operation of the browser appears to work better if:

1) You start-up the browser with the following command:

WINEDLLOVERRIDES='ole32=n' wine c:\program files\avant browser\avant.exe

2) And turn-off the 'Address' bar (View->Toolbars->Address Bar).  Once you turn-off the 'Address' bar, the UI seems to start responding more correctly (not perfectly, but more correctly).

Note: This has _not_ been tested.  It was true of AB10.1, build 41, and I'm assuming it's going to be true of AB11.0, build 25.  I'm just too lazy to try it myself. *grin*

HOWTO

The AvantBrowser will install and run under a default wine config in 0.9.34, but doesn't render websites. Therefore, use following install/run procedure:

1. Install IE (ies4linux works for me).

2. Download and install the Avant Browser to the ies4linux WINEPREFIX location (default WINEPREFIX location for ies4linux is, ${HOME}/.ies4linux/ie6).

3. Change to the Avant Browser install directory (default location is 'C:\Program Files\Avant Browser).

4. Start the browser:

WINEPREFIX=${HOME}/.ies4linux/ie6 wine avant.exe

(See Note below if you're using a pre-0.9.8 Wine version)

5. The browser will start and a splash screen will be displayed. If the splash screen doesn't disappear of its own accord, continue to the next step. Else, if everything appears to be working fine, stop here.

6. Click the 'View' toolbar menuitem and uncheck the 'Address Bar' option. If you can't see the toolbar, just click where the toolbar would be (the row just below the titlebar). Eventually, you'll hit a toolbar menuitem (the default menuitems position is about two-thirds the way along the top bar when maximized [initial size] and about halfway along the top bar when 'restored'), and the other menuitems should show. Click 'View' and uncheck the 'Address Bar' option.

7. Things should start going then.

Running Avant Browser 11.0, build 46, on pre-0.9.8 Wine versions

On versions of Wine prior to 0.9.8, the operation of the browser appears to work better if:

1) You start-up the browser with the following command:

WINEDLLOVERRIDES='ole32=n' wine c:\program files\avant browser\avant.exe

2) And turn-off the 'Address' bar (View->Toolbars->Address Bar).  Once you turn-off the 'Address' bar, the UI seems to start responding more correctly (not perfectly, but more correctly).

Note: This has _not_ been tested.  It was true of AB10.1, build 41, and I'm assuming it's going to be true of AB11.0, build 25.  I'm just too lazy to try it myself. *grin*

Comments

Comments Disabled

Comments for this application have been disabled because there are no maintainers.
Back