WineHQ

Avant Browser

Application Details:

Version: 11.x
License: Free to use
URL: http://www.avantbrowser.com
Votes: 0
Latest Rating: Bronze
Latest Wine Version Tested: 1.1.16

Maintainers: About Maintainership

No maintainers. Volunteer today!

Free Download Avant Browser download page Free Download Avant Browser 11.6, build 6 Free Download Avant Browser main page (latest version may not match this test results version) Free Download Latest Avant Browser version download (may not be v11.7b19)

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Installs, runs, skins can be changed.  URLs can be entered in the Address bar, options can be changed and saved.  Menus can be opened (e.g., 'Alt+f' opens the 'File' menu) with keyboard shortcuts but only after using the focus has been delivered to the Address bar with 'Alt+D'.  Unchecking the 'Compact Style' option will show the menu bar(right-click the tab bar to view the options. 

What does not

- Clicking on links (the cursor changes to a 'hand' icon, but nothing happens when a click is delivered). 

- When the focus is delivered to the Address bar using the keyboard shortcut, Alt+D, the 'Alt' becomes sticky.  So, for example, if an 'f' is typed immediately after doing an 'Alt+D', the 'File' menu will open.  Make sure the blicking caret is visible in the Address bar before typing (this can be done by hitting 'Esc' after a 'Alt+D').  If the 'Compact Style' option has been unchecked, this can be seen on the menu. 

- The 'AD Blocker' can be enabled, but it doesn't seem to work. 

- The various 'Disable...' options can be checked, but don't seem to work as well. 

- The floating toolbar doesn't show up (either in the default mode or if the 'Hold [Ctrl]' option [in the Tools menu] is checked). 

- The 'Edit' menu can never be viewed.

- Entering text into the Yahoo search textbox can't ever be search with (either by hitting 'Enter', clicking the 'Web Search' button, or changing the focus to the 'Web Search' button and hitting the Spacebar.  Google, and MSN searches work.


Workarounds

What was not tested

I'm sure there's a lot, but I'm not going to try to test everything.

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowSlackware 12.2Mar 12 20091.1.16Yes Yes Bronzean anonymous user 
ShowSlackware 12.2Feb 14 20091.1.15Yes Yes Bronzean anonymous user 
ShowSlackware 12.2Jan 31 20091.1.14Yes Yes Bronzean anonymous user 
ShowSlackware 12.2Jan 19 20091.1.13Yes Yes Bronzean anonymous user 
ShowSlackware 12.2Jan 02 20091.1.12Yes Yes Bronzean anonymous user 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

HowTo / Notes

Running Avant Browser 10.1, build

On versions of Wine prior to 0.9.8 (you shouldn't really be doing this, use the latest version of Wine), the operation of the browser appears to work better if:

1) You start-up the browser with the following command:

WINEDLLOVERRIDES='ole32=n' wine c:\program files\avant browser\avant.exe

2) And turn-off the 'Address' bar (View->Address Bar).  Once you turn-off the 'Address' bar, the UI seems to start responding more correctly (not perfectly, but more correctly).

HOWTO

The AvantBrowser will install and run under a default wine config in 0.9.34, but doesn't render websites. Therefore, use following install/run procedure:

1. Install IE (ies4linux works for me).

2. Download and install the Avant Browser to the ies4linux WINEPREFIX location (default WINEPREFIX location for ies4linux is, ${HOME}/.ies4linux/ie6).

3. Change to the Avant Browser install directory (default location is 'C:\Program Files\Avant Browser).

4. Start the browser:

WINEPREFIX=${HOME}/.ies4linux/ie6 wine avant.exe

(See Note below if you're using a pre-0.9.8 Wine version)

5. The browser will start and a splash screen will be displayed. If the splash screen doesn't disappear of its own accord, continue on. Else, if everything appears to be working fine, stop here.

6. Click the 'View' toolbar menuitem and uncheck the 'Address Bar' option. If you can't see the toolbar, just click where the toolbar would be (the row just below the titlebar). Eventually, you'll hit a toolbar menuitem (the default menuitems position is about two-thirds the way along the top bar when maximized [initial size] and about halfway along the top bar when 'restored'), and the other menuitems should show. Click 'View' and uncheck the 'Address Bar' option.

7. Things should start going then.

Running Avant Browser 11.0, build 43, on pre-0.9.8 Wine versions

On versions of Wine prior to 0.9.8, the operation of the browser appears to work better if:

1) You start-up the browser with the following command:

WINEDLLOVERRIDES='ole32=n' wine c:\program files\avant browser\avant.exe

2) And turn-off the 'Address' bar (View->Toolbars->Address Bar).  Once you turn-off the 'Address' bar, the UI seems to start responding more correctly (not perfectly, but more correctly).

Note: This has _not_ been tested.  It was true of AB10.1, build 41, and I'm assuming it's going to be true of AB11.0, build 25.  I'm just too lazy to try it myself. *grin*

HOWTO

The AvantBrowser will install and run under a default wine config in 0.9.34, but doesn't render websites. Therefore, use following install/run procedure:

1. Install IE (ies4linux works for me).

2. Download and install the Avant Browser to the ies4linux WINEPREFIX location (default WINEPREFIX location for ies4linux is, ${HOME}/.ies4linux/ie6).

3. Change to the Avant Browser install directory (default location is 'C:\Program Files\Avant Browser).

4. Start the browser:

WINEPREFIX=${HOME}/.ies4linux/ie6 wine avant.exe

(See Note below if you're using a pre-0.9.8 Wine version)

5. The browser will start and a splash screen will be displayed. If the splash screen doesn't disappear of its own accord, continue to the next step. Else, if everything appears to be working fine, stop here.

6. Click the 'View' toolbar menuitem and uncheck the 'Address Bar' option. If you can't see the toolbar, just click where the toolbar would be (the row just below the titlebar). Eventually, you'll hit a toolbar menuitem (the default menuitems position is about two-thirds the way along the top bar when maximized [initial size] and about halfway along the top bar when 'restored'), and the other menuitems should show. Click 'View' and uncheck the 'Address Bar' option.

7. Things should start going then.

Running Avant Browser 11.0, build 46, on pre-0.9.8 Wine versions

On versions of Wine prior to 0.9.8, the operation of the browser appears to work better if:

1) You start-up the browser with the following command:

WINEDLLOVERRIDES='ole32=n' wine c:\program files\avant browser\avant.exe

2) And turn-off the 'Address' bar (View->Toolbars->Address Bar).  Once you turn-off the 'Address' bar, the UI seems to start responding more correctly (not perfectly, but more correctly).

Note: This has _not_ been tested.  It was true of AB10.1, build 41, and I'm assuming it's going to be true of AB11.0, build 25.  I'm just too lazy to try it myself. *grin*

Comments

Comments Disabled

Comments for this application have been disabled because there are no maintainers.
Back