WineHQ

Catia

CATIA V5 Release 19

Application Details:

Version: V5R19
License: Retail
URL: http://www.3ds.com/de/corporat...
Votes: 3
Latest Rating: Bronze
Latest Wine Version Tested: 1.5.7

Maintainers: About Maintainership

Test Results

Old test results
The test results for this version are very old, and as such they may not represent the current state of Wine. Please consider submitting a new test report.
Selected Test Results

What works

Installing and starting. Creating elements like points, planes and surfaces (...). Triming, Fillet, etc. But only short test.

What does not

Graphic is not always up-2-date. Means: Toolbars are flickering, and sometimes the whole screen is flickering.

 

Bug 1788 is active and the known problem with opengl.dll certification is also available.

Workarounds

What was not tested

many things, opening huge assemblies etc...

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
CurrentArch LinuxJun 24 20121.5.7Yes Yes Bronzean anonymous user 
ShowUbuntu 11.10 "Oneiric" amd64 (+ variants like Kubuntu)Feb 12 20121.4-rc2Yes Yes Goldan anonymous user 
ShowUbuntu 10.10 "Maverick" i386 (+ variants like Kubuntu)Feb 10 20111.3.13Yes Yes Goldnemo 136 
ShowDebian GNU/Linux Unstable "Sid" x86_64Mar 17 20101.1.35Yes Yes GoldSafir Secerovic 
ShowMandriva 2010.0 x86_64Mar 10 20101.1.35Yes Yes Platinuman anonymous user 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

HowTo / Notes

WARNING

by ­NSLW on (April 5th 2010)

If application hags up for you on its start-up on Wine 1.1.34 or higher then you can fix it in two different ways:

Method #1

Please fire up terminal and do following:

su - root
ulimit -n 16384
su - your_user_name
cd ~/.wine/drive_c/Program Files/Dassault Systemes/B19/intel_a/code/bin
wine "catstart.exe" -run "CNEXT.exe" -env CATIA.V5R19.B19 -direnv "C:\users\Public\Application Data\DassaultSystemes\CATEnv" -nowindow 
You will have to do it always to run CATIA V5 without hang up.

Method #2

If you don't want to do it every time then do following:

1) open /etc/security/limits.conf with root permissions
2) add following line to that file
*                -    nofile             3000
3) save the file, log out then log in to apply the change

Now you can start CATIA V5 just as you would do normally.­

Above informations were given by Dan Kegel.To know more, why you have to do this, look at bug #22230

 

WARNING

Please do not use Wine version from 1.1.19 till 1.1.23 because there is an regression which prevents successful installation of CATIA V5

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

works for me on Slackware 13.37
by da uti on Wednesday November 16th 2011, 8:06
by using
+ Playonlinux to install the packages vc2005, vc2008, vc2010
+ copying the opengl.dll from original windows/system32 to ~/.wine /drive_c/windows/system32/
+ running the following commands from terminal:
su - root
ulimit -n 16384
su - "your_username"
cd "/home/"your_username"/.wine/drive_c/Programme/Dassault Systemes/B19/intel_a/code/bin" ( I have a german name path)
wine "catstart.exe" -run "CNEXT.exe" -env CATIA.V5R19.B19
CATIA v5 R19 SP2 hangs on start up
by Tish on Saturday September 25th 2010, 7:50
Hello Community

I did the following steps and catia still hangs on start up.

Platform: Ubuntu 10.04
wine: 1.2

Steps:

1.Obtain msdrm.dll
Copy msdrm.dll into .wine/drive_c/windows/system32 directory.
Use winetricks to install Visual C++ runtimes:
winetricks vcrun2005 vcrun2008
Install Catia V5r19 by running setup.exe from install CD/DVD.

2.Method #2 from the post of NSLW

3. Copied opengl32.dll from an XP machine to the system32 dir of wine.

Description:

Catia starts. I am getting the message: No warm start available(which is a catia setting(nothing to troubleshoot here).I can see the menus but nothing happens further and catia is not responding.

Please advise.
RE: CATIA v5 R19 SP2 hangs on start up
by coco on Thursday October 7th 2010, 5:24
Hello,

I have the same problem with any version of catia newer than 1.1.35
Actually I'm running it quite well on wine 1.1.31, except that sometimes (around 5 times for a day of 3D modeling) catia hangs up when I try to access to the menus and I need to restart the X server to make it works again...
RE: CATIA v5 R19 SP2 hangs on start up
by NSLW on Friday January 14th 2011, 9:58
AFAIK nothing beyond step 2 is required. I run CATIA V5R20 SP1 on Wine 1.3.11. At installation I didn't install all components.
RE: CATIA v5 R19 SP2 hangs on start up
by Thomas Bittner on Monday February 20th 2012, 5:29
If you are using a 64bit linux, you have to install the 32 graphics driver. I'm using 64bit archlinux and had the same problem until i installed lib32-intel-dri (for my intel graphics) and used the command:

LIBGL_DRIVERS_PATH=/usr/lib32/xorg/modules/dri wine /path/to/catia/code/bin/CNEXT.exe

now its working just fine.
CATIAV5R19 seems to have a problem with a *.dll and the C++ Runtimes
by Maximilian on Friday May 14th 2010, 10:38
Hi,
I just installed Catia V5R19 according to the instructions. I also replaced the opengl.dll as described by Vico and used the Method #1. Still Catia hangs after startup. The terminal gives me the following output:

max@max-laptop:~$ sudo su root
root@max-laptop:/home/max# ulimit -n 16384
root@max-laptop:/home/max# sudo su max
max@max-laptop:~$ cd /home/max/.wine/dosdevices/c:/Programme/Dassault\ Systemes/B19/intel_a/code/bin
max@max-laptop:~/.wine/dosdevices/c:/Programme/Dassault Systemes/B19/intel_a/code/bin$ wine "catstart.exe" -run "CNEXT.exe" -env CATIA.V5R19.B19 -direnv "C:\users\Public\Anwendungsdaten\DassaultSystemes\CATEnv" -nowindow
fixme:win:EnumDisplayDevicesW ((null),0,0x33eef0,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),1,0x33eef0,0x00000000), stub!
fixme:service:EnumServicesStatusA 0x155110 type=30 state=1 0x33f2e0 168 0x33f448 0x33f44c 0x33f450
fixme:service:EnumServicesStatusA 0x155110 type=30 state=1 0x33f5f0 168 0x33f758 0x33f75c 0x33f760
fixme:service:EnumServicesStatusA 0x155488 type=30 state=1 0x33f88c 168 0x33f9f4 0x33f9f8 0x33f9fc
fixme:ole:TLB_ReadTypeLib Header type magic 0x00905a4d not supported.
err:ole:TLB_ReadTypeLib Loading of typelib L"C:\\Programme\\Dassault Systemes\\B19\\intel_a\\code\\bin\\CNEXT.exe" failed with error 0
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
fixme:activeds:ADsGetObject (L"({3e37e320-17e2-11cf-abc4-02608c9e7553},0x33d714)!stub">")->({3e37e320-17e2-11cf-abc4-02608c9e7553},0x33d714)!stub
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.VC80.CRT" (8.0.50727.762)
err:module:import_dll Library DNBMHIEngineServices.dll (which is needed by L"C:\\Programme\\Dassault Systemes\\B19\\intel_a\\code\\bin\\CATIPDAdapter.dll") not found
err:module:import_dll Library DNBMHIOpenEngine.dll (which is needed by L"C:\\Programme\\Dassault Systemes\\B19\\intel_a\\code\\bin\\CATIPDAdapter.dll") not found

It seems like there's some problem with the Visual Runtime as it states that "Microsoft.VC80.CRT" couldn't be found. Though I installed vc2005 and vc2008 via winetricks.
Also there seems to be missing some kind of dll.
Does anyone have an idea how to solve my problem?
Thanks for the help in advance :)!
Menu bar flickering
by Vico on Sunday March 21st 2010, 7:30
I am using Catia v5 R19 since a few months, currently with the latest version (1.1.41), on opensuse 11.2, and everything works well, including using a license server.

I sometimes reinstall it after a few new versions, to see if there's any improvement after doing it; the last time was on a clean 1.1.40 wine on a fresh Opensuse install.

I didn'h have to do anything before installing; without installing any prerequistes mentioned here, I ran setup, and it installed, and worked almost perfectly.

Regarding the 'uncerified opengl...' error message: it is solved by copying opengl32.dll from an XP machine to the system32 dir of wine. If I remember well, this solved the issue before around 1.1.3?, then the error message reappeared for a few versions, and now it works again. Important, only copy, and don't override the dll!!

There are two issues I would like to solve:

-If I click on properties, or edit properties of a part, for example, the " Start File Edit ..." menu bar flickers for a few seconds (which is sometimes long if you are using Catia for production and do lots of clicks). Sometimes it happens when loading a part, etc. It is a bit disturbing. I tried to debug it, without luck. Did someone solve this, or does this happen only on my computer?

-It would be nice to use my spacenavigator device with it; until now I was unable to achieve that.
Additional comments on running CATIA with Wine
by Safir Secerovic on Thursday March 18th 2010, 18:38
I forgot to mention that you also need to install winbind package as well (apt-get install winbind) it is required for running CATIA.

Thus, for Wine versions higher that 1.1.35 the reason for CATIA not running is that Visual C++ runtime libraries are not installed/loaded correctly by Wine, so it is a Wine regression.
One solution might be to manually copy WinSxS folder from an XP installation to .wine/drive_c/windows/ and try running CATIA afterwards.
Another is of course to fix Wine in future releases.
3D view doesn't work + No certified OpenGL library
by aaahaaap on Saturday January 2nd 2010, 15:32
Installation of V5R19 (and V5R18 and V5R16) in a clean WINEPREFIX works, except for these error messages:
"CORBARuntime_post
WARNING Get Domain Name Server failed
Registry Key S was not found

Environment variable IT_LOCAL_DOMAIN cannot be initialized in file C:\Program Files\Dassault Systemes\B19\intel_a\startup\orbix\config\common.cfg"

Not sure if these pose a problem or not.


Starting V5R19 (CNEXT.exe) or the options screen (CATOptionsMgt.exe) first displays the message "No certified OpenGL library has been found. Check your system installation." as per bug 10490 bugs.winehq.org/show_bug.cgi?id=10490 which I feel is a wine issue, not a driver issue (I'm using either the radeon opensource driver or Mesa).
This message can't be dismissed (but the other windows can be positioned over it).
Then it sometimes gives the warning/message "No warm start available"
After that it just hangs and finally exits with the warning/message "Runtime exception Click OK to terminate". The 3D view is never shown, most of the time it shows CATIA's background.

When using opengl32.dll from a WinXP install in virtualbox it doesn't crash, but I get a black 3D view. In Virtualbox itself the 3D view works.

Anybody got any ideas?
RE: 3D view doesn't work + No certified OpenGL library
by Jon Pry on Thursday February 4th 2010, 11:41
The no certified opengl library isn't really a problem. Afaik the opengl implementation under linux is in fact not certified by the consortium as this cost megabucks, but it is standards compliant and works fine. Some other people have mentioned that you can't dismiss this message. I can, but I have to wait until the program finishes starting up. The not working 3d view problem was fixed for me by switching to ME compatibility mode in the wine configuration.
Installation
by Crisu on Tuesday November 24th 2009, 8:02
I am rather unexperienced with all of Wine and PlayonLinux; therefore, does anybody have experience with the installation using 3 CDs instead of a DVD.
I have tried several times:
1. "installing" Catia 3 times - once for each CD
2. at the end of all I get a message of successful installation.
3. I cannot even find any directory of Catia (inside of /.../playonlinux/Catia/drive_c/Program Files)

(I doubt that it matters but my Cds are actually iso's mounted to a virtual drive: /media/virtual)

Please, help!!
Thank you in advance, best regards
RE: Installation
by NSLW on Tuesday November 24th 2009, 8:22
You give to few informations.
Back