WineHQ
SolidWorks 2009



Category: Main > Scientific/Technical/Math > CAD/CAE > SolidWorks > 2009


NameSolidWorks
Version2009
License Retail
URLhttp://www.solidworks.com
Votes  
RatingSilver
Wine Version1.7.16
Maintainers of this version:
Description
SolidWorks 2009
Old test results
The test results for this version are very old, and as such they may not represent the current state of Wine. Please consider submitting a new test report.
Selected Test Results (selected in 'Test Results' table below)

What works
Most of it! Graphics performance is good, using OpenGL and shaded view. Photoworks renders fine.


What does not

  • winetricks vcrun2005 msxml6 is required
  • Selecting "Custom Properties" tab crashes application.
  • Maximising main window results in it moving randomly between monitors and being positioned off the top of the visible screen. This might be specific to having two dissimilar monitors.
  • Titles on the various controls for features (e.g. extrude depth, sheet metal thickness) disappear shortly after appearing. Doesn't stop it working, but will be confusing if you don't know what to expect and don't read it in time!

  • What was not tested

  • "new" installer (sldim.exe)
  • Most of the other "office" bits

  • Additional Comments

    Installed 32-bit product under a 32-bit wine environment (WINEARCH="win32"), on a 64-bit distro, had to install the 32-bit X libraries for the proprietary NVidia driver (yum install xorg-x11-drv-nvidia-libs.i686) to get shaded view to work.
    
    Test Results
    DistributionTest dateWine versionInstalls?Runs?RatingSubmitter
    CurrentFedora 20 x86_64Jun 01 20141.7.16 Yes Yes Silver Funkster 
    ShowUbuntu 10.04 "Lucid" i386 (+ variants like Kubuntu)May 25 20101.2-rc1 Yes Yes Silver denis 
    ShowUbuntu 9.10 "Karmic" i386 (+ variants like Kubuntu)Dec 04 20091.1.33 Yes Yes Bronze denis 
    ShowFedora 11Oct 16 20091.1.31 No Not installable Garbage NSLW 


    Known bugs
    Bug # Description Status Resolution Other apps affected
    27403 Collapsable section headers in Solidworks property manager are overdrawn, thus unusable NEW View
    34394 SolidWorks 2010: No text in sidebar UNCONFIRMED View

     

    The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

    Latest notes and tweaks
    by Funkster on Thursday October 30th 2014, 4:58
    Latest observations:

    When trying to add a note (i.e. "Note" tool on Annotations bar) to a drawing, the text style dialog box would show no font, size was -389point and -1000mm, and these couldn't be changed. When you tried to type text it would either be blank or a series of square boxes.

    Running wine from a terminal threw out error richedit:fnTextSrv_OnTxInplaceActivate when the font style dialog appeared.

    Copied over native riched20.dll and riched32.dll from a WinXP SP3 image, set them in winecfg to use native first, BOOM! it works fine and I can now add notes!


    Hole wizard (and probably anything else wanting to use .mdb databases) didn't work, throwing a dialog with the error "Out of memory or other error trying to initialize data source from
    standards file '...\HoleWizardFavorites.mdb'". Bringing up System Options to see where it is looking for the file, it says it can't open the database (but gives blank reason).

    winetricks jet40 fixes this (despite complaining about not finding a .dll after installation)


    Having done winetricks wsh57 in order to fix bug 34394, the terminal is spewing many many ole: and msxml: fixmes, especially if you hover the cursor over the sidebar. Doesn't appear to be causing any problems though.


    Now if we could just find a fix / workaround for bug 27403 this could get a gold rating! Anyone got any further thoughts on this?

    [post new] [reply to this]

    Some more observations
    by Funkster on Sunday August 31st 2014, 15:48
    - Text menu and the usual new/open buttons are not drawn at startup, so you just get a blank grey bar with the solidworks logo on the left. The menus appear if you press Alt. Something to do with "fixme:toolbar:TOOLBAR_Restore send TBN_GETBUTTONINFO for each button"?

    - Some of the time, after right-clicking to bring up a context menu, subsequent left-clicks seem to go *under* the menu. If you use cursor keys and enter to navigate the context menu then actions on the menu can be performed.

    [post new] [reply to this]




       << Back

    Page loaded in 0.1723 seconds.