WineHQ
Category: Main Games Strategy Games Sins of a Solar Empire Sins of a Solar Empire Trinity

Sins of a Solar Empire

SoaSE : Trinity - a set of base SoaSE game and two addons.

Versions in the retail Trinity package:

Base game 1.19

Diplomacy 1.00

Entrenchment 1.05

(If You want to play with both Entrenchment and Diplomacy on the same time, run the game through the Diplomacy's executable file, because it is the newest one and contains both base game and Entrenchment.)

Application Details:

Version: Sins of a Solar Empire Trinity
License: Retail
URL: http://www.sinsofasolarempire....
Votes: 0
Latest Rating: Platinum
Latest Wine Version Tested: 1.7.10

Maintainers: About Maintainership

Test Results

Old test results
The test results for this version are very old, and as such they may not represent the current state of Wine. Please consider submitting a new test report.
Selected Test Results

What works

  • LAN Multiplayer
  • Single Player
  • Adjusting settings in and out of game
  • DLC

Tested with the Steam version

What does not

Nothing so far

Workarounds

What was not tested

  • ICO Multiplayer

Additional Comments

I had to adjust my video settings lower to prevent a minidump (crash), however this bug is also present with my computer in Windows 7 and 8.
selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
CurrentUbuntu 14.04 "Trusty" amd64 (+ variants like Kubuntu)Jan 05 20141.7.10Yes Yes PlatinumAJ Fite 
ShowMac OS X 10.7 "Lion"Feb 23 20131.5.23Yes Yes PlatinumMichael Armbruster 
ShowDebian GNU/Linux 7.x "Wheezy"Feb 19 20121.4-rc3Yes Yes GoldCaleb Totten 
ShowUbuntu 10.10 "Maverick" amd64 (+ variants like Kubuntu)Feb 18 20121.4-rc2Yes Yes Goldan anonymous user 
ShowGentoo LinuxDec 29 20111.3.35N/A No GarbageJohannes S. 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

Activator from Stardock Central works
by Michael Ballantyne on Sunday September 23rd 2012, 18:57
Can download the installer here:
www.stardock.com/stardockcentral/

Installs to drive_c/users//Local Settings/Application Data/Stardock/Stardock Central

Copy sdActivate.exe and Activate.lng from there.

Full write up on my blog for how I got everything going on mac wine wineskin is here:
mballantyne.blogspot.com/2012/09/sins-of-solar-empire-trinity-steam-on.html
Activator doesn't work
by Dheart on Monday May 21st 2012, 12:20
As we all know activator doesn't work. Is there any way to play the game/get it activated (Purchased through steam)?
RE: Activator doesn't work
by Colton on Friday August 24th 2012, 20:40
There is no other way, that I am aware of, other than replacing the SDActivate.exe and SDActivate.lng files. I have the sins original disc, which has older versions of the files. If you wish, I can give you to them, you will still need to register as normal, but it should work. Doing it this way does not affect what version of sins you play, it just allows you to register properly.
RE: Activator doesn't work
by Dheart on Friday August 24th 2012, 22:34
I would much appreciate it! Could you put them somewhere online (like a dropbox?)
Activation Window doesn't work
by Andreas on Sunday November 20th 2011, 5:00
I could install sins trinity without a problem from the stardock website.

But if I try to start the game with the Sins of a Solar Empire Diplomacy.exe, the Stardock Account Registration Window appears but the register button doesn't work. Nothing happens. No console output. The Quit button works. Is something in my wine configuration missing?

I use wine 1.32. Did someone got this problem, too?
RE: Activation Window doesn't work
by Vítor Ferreira on Sunday November 20th 2011, 21:11
I use wine 1.3.33 and I have the exact same problem, whether I use the version downloaded from Stardock.com or downloaded through steam.
In order to see what happens behind the scenes when I click Register, I use WINEDEBUG="+winhttp" and I get the output annexed.
RE: Activation Window doesn't work
by Vítor Ferreira on Sunday November 20th 2011, 21:24
RE: Activation Window doesn't work
by Andreas on Monday November 21st 2011, 3:57
Good to know that I'm not alone. I have also installed playonlinux, so I could test it with different wine versions. But I can't get it to work. I testet it on 1.3.31, 1.3.25, 1.3.5 and 1.3.1.
RE: Activation Window doesn't work
by Vítor Ferreira on Monday November 21st 2011, 12:21
I think it the problem is not the wine version, but the new SDActivate.exe, which perhaps was introduced with version 1.34.
As such, I discovered a workaround. In the SoaSE Trinity installation folder, I replaced the SDActivate.exe and SDActivate.lng with the corresponding files from the retail dvd. And again I was asked to activate my copy of SoaSE, the dialog being different and after clicking Activate, the game started, though not successfully. I had to go back to at least wine 1.3.30 to get the game to start sucessfully. Even then, the sound is far from perfect. There's some alsa sound underruns. Something to report with more detail later.
RE: Activation Window doesn't work
by Andreas on Monday November 21st 2011, 16:46
Wow perfect. I also got it to work. Thank you for the advice. I took the activate.exe and the activate.lng from the old sdcentral application, renamed them and was then able activate my game, finally. With the newer wine versions the videos were very slow and I could't get to the menu. But now with the 1.3.25 it works very well.
RE: Activation Window doesn't work
by Vítor Ferreira on Monday November 21st 2011, 17:05
How's the audio working?
RE: Activation Window doesn't work
by Andreas on Monday November 21st 2011, 17:39
I played for 30 minutes. The sound was normal. I had no problems at all.
Losing Sound
by john on Wednesday May 4th 2011, 14:56
After 10-40 minutes I lose sound on sins of a solar empire. I haven't tried checking console yet.
No user.setting
by Lyr on Tuesday September 14th 2010, 6:06
I've been looking in the "Application Data/Ironclad Games/Sins of a Solar Empire" folder, there's nothing else than an empty "License" folder.
Tried to launch the game, change a few setting, play 5 minutes and save, but no user.setting file anywhere. I tried to create it myself, but nothing work so far.
RE: No user.setting
by Maciej Warnecki on Tuesday September 14th 2010, 13:07
Have You tried creating "user.setting" in a "Setting" folder?

See here:
frogboy.impulsedriven.net/article/174432/Sins_of_a_Solar_Empire_Technical_FAQ

"
Where is my Sins settings file found?
This file is located at:

Vista:
C:\Users\username\AppData\Local\Ironclad Games\Sins of a Solar Empire\Setting\user.setting

XP:
C:\Documents and Settings\username\Local Settings\Application Data\Ironclad Games\Sins of a Solar Empire\Setting\user.setting
"

I'm positive it should be there. Are You sure You have the latest version installed? Installed it properly? Have You tried reinstalling?
RE: No user.setting
by Lyr on Tuesday September 14th 2010, 13:50
True that I did a mistake, I forgot to create a "Setting" directory to put my test "user.setting" in it. But as I said, there's nothing in the "Sins of a Solar Empire" directory. And I mean it, there's nothing hidden... And still, the game remember the others settings I set like "high resolution for ship".

I'll check again this evening, I must have missed something.

By the way just in case, I don't know for sure what the "user.setting" does look like, except for the 3 lines you gave in your fix about the resolution. Can you please copy/paste yours here?
RE: No user.setting
by Maciej Warnecki on Thursday September 16th 2010, 13:41
Unfortunately, I don't have it installed right now (different computer)

I'd suggest You post in official SoaSE forums and ask about an example user.setting file + whether it could be located somewhere else.
RE: No user.setting
by Maciej Warnecki on Thursday September 16th 2010, 13:45
Oh, and just a guess: The file may be located somewhere else. It's definitely *somwehere* since Your settings are saved.

If I were You, I'd d a full filesystem search for "user.setting" file.
Much obliged!
by Tibi on Wednesday September 1st 2010, 20:16
A thousand thankyous for the font fix. It's been buggin' me for WAY too long.
Back