WineHQ
Category: Main Games Online (MMORPG) Games EverQuest II 06 - Sentinel's Fate

EverQuest II

The sixth EQ2 expansion.

Application Details:

Version: 06 - Sentinel's Fate
License: Retail
URL: http://www.everquest2.com/
Votes: Marked as obsolete
Latest Rating: Bronze
Latest Wine Version Tested: 1.3.10

Maintainers: About Maintainership

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Installation via Station Launcher, all aspects of the game.

What does not

Nothing.

Workarounds

What was not tested

End-game raiding.

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

Works great for me. :) Station Launcher still needs vcrun2005, but that's not an EQ2 issue.

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowLinux Mint 10 "Julia" x86_64Jan 07 20111.3.10Yes Yes Bronzean anonymous user 
ShowUbuntu 10.10 "Maverick" amd64 (+ variants like Kubuntu)Jan 03 20111.3.10No, but has workaround Yes Goldan anonymous user 
CurrentDebian GNU/Linux 6.x "Squeeze"Dec 19 20101.3.9Yes Yes PlatinumColin Wetherbee 
ShowLinux Mint 10 "Julia"Dec 04 20101.3.8No, but has workaround No GarbageMartin 
ShowUbuntu 10.10 "Maverick" amd64 (+ variants like Kubuntu)Nov 21 20101.3.7No, but has workaround Yes Goldan anonymous user 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

HowTo / Notes

HOWTO
EQ2 is rated "garbage" with Wine versions above 1.1.18 and below 1.2-rc7. Please install Wine 1.2-rc7 or higher, as 1.1.18 will necessitate some irritating registry changes, documented below.

When EQ2 starts for the first time, it will try to run in full-screen mode  This is not supported in Wine, but you can easily switch to windowed mode by alt-tabbing to another window. If you have a dual monitor setup, your fonts will then be twice as wide as they should be; restarting the game fixes this.This isn't true for all users, but it may affect you.

Please ensure your system (and especially your graphics card) meets the minumum requirements set by Sony Online Entertainment for running this game.

To run launchpad 3, you need to install ie8 with winetricks.

Suggested registry settings for Wine 1.1.18 (you do not need these for 1.2-rc7 and up):

HKEY_CURRENT_USER -
  Software -
    Wine -
      Direct3D - (you'll have to create this folder)
        DirectDrawRenderer -> opengl
        OffScreenRenderingMode -> fbo (with newer video cards)
        PixelShaderMode -> enabled
        RenderTargetLockMode -> texdraw


Also, for 1.01, you will need to edit eq2.ini to disable some font rendering. Put the following line in eq2.ini:

r_font_ft 0 (Not needed unless you are using wine 1.01 or lower)

For wine 1.1.18 and lower: wine_gecko crashes the patcher screen (no BITS support in wine yet. See bug 6253) so if you want to run patcher, rename the HKCU/wine/MSHTML. That should disable Gecko. Or, you can simply not install wine_gecko in the first place. With 1.27-rc7 some functionailty of gecko with the launcher may or may not work, but it wont crash the game.
Download Locations
The station launcher is no longer supported by SOE. Launchpad 4 is now the default launcher. Using any other will cause it to upgrade itself to Launchpad 4. It can be downloaded directly from:

http://launch.soe.com/eq2//
shader 3.0 and bug reporting

I'd like to remind everyone, that tho shader 3.0 is in fact awesome and better than 1.0, though please before we start complaining about bugs and whatnot especially with shader 3.0 please remember that its buggy in windows too, and try to get bugs that are only in wine only please.

 If we can get this working and looking exactly the same in windows and linux and there's still stupid bugs that SOE wont fix that makes the game platinum here even tho there are major graphical glitches.

WARNING

Please everyone remember that this is a buggy buggy game.  Please try to only post here about bugs that are not present in windows.  Sometimes its really hard to tell the difference between bugs in wine and bugs in Everquest yourself.

 

Please Please, before you submit bug reports or testing feedback. If at all possible try to compare anything you do here in Linux  with the same thing in windows.

Please post data and questions under the correct version!
PLEASE DO NOT POST "Destiny of Velious" test results under the "Sentinel's Fate"!
You may select the Destiny of Velious version of EQ2 by scrolling to the top of your screen, clicking on EverQuest 2 in the game hierarchy, and then, at the next page, clicking Sentinel's Fate.
Versions of EverQuest II

The game requires you to run the newest version of the game, so nobody uses an older version. Because of this, the only "versions" we maintain are the full install client and the streaming install client. Please place all test results in the proper one.

 EverQuest II Extended has been merged with the Live game. The Steam version is a wrapper around the Full Install Client and still uses Launchpad.

Comments

Back