WineHQ

Total War: Napoleon

Napoleon Total War version available on steam. 

Application Details:

Version: Definitive Edition
License: Retail
URL: http://www.totalwar.com/
Votes: 1
Latest Rating: Platinum
Latest Wine Version Tested: 4.0-rc3-staging

Maintainers: About Maintainership

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

-Starting

-Options

-Videos

-Gameplay (Campaign, Battles)

-Menu

-Mods (DarthMod)

What does not

Workarounds

What was not tested

-Multiplayer 

-Long play

-Extensive Testing

Hardware tested

Graphics:

  • GPU: Nvidia
  • Driver: proprietary

Additional Comments

I used Wine-Staging 2.21.


selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowUbuntu 18.10 "Cosmic" amd64 (+variants like Kubuntu)Jan 05 20194.0-rc3-stagingYes Yes NoPlatinumMaquis196 
CurrentDebian 10.x "Buster"Mar 01 20182.0.4Yes Yes NoPlatinumGero45 
ShowUbuntu 12.10 "Quantal" amd64 (+ variants like Kubuntu)Oct 24 20121.5.15Yes Yes Bronzesdog 
ShowGentoo Linux x86_64Dec 20 20111.3.34Yes Yes BronzeMaquis196 
ShowUbuntu 10.04 "Lucid" amd64 (+ variants like Kubuntu)Jun 28 20101.2-rc5Yes Yes GoldEdward 

Known Bugs

Bug # Description Status Resolution Other apps affected
23356 Napoleon Total War: needs native d3dx9 (HLSL ascii effects not supported) NEW View

Show all bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

setPixelFormat patch
by Ditrich Michael on Thursday November 29th 2012, 16:33
there was same problem reported in release version of Napoleon: Total War. As workaround was suggested patch of setPixelFormat function. Does somebody moved this patch on wine 1.5? And also tested?
Screen Shots
by Maquis196 on Tuesday December 20th 2011, 16:10
Napoleon Total War does something to remove the winedesktop border :). So that's why my screenshots look weird (and didn't want to post any screenshots that weren't obviously the game running in Linux).

by Ramirez on Tuesday June 14th 2011, 15:47
bugs2.winehq.org/attachment.cgi?id=23393
How i can compiled this patch?
RE:
by kroq-gar78 on Thursday February 9th 2012, 14:45
So, from the link you posted, copy all of the stuff under the first "---" in the post. Then, paste it into a file "NapoleonTW.diff" somewhere close to where you'll keep your WINE source code (preferably your home directory).

Download the latest WINE (stable or development) and extract it into the directory "~/wine"

then use the command "cd ~/wine"

Then, apply the patch using the command "cat ~/NapoleonTW.diff | patch -p1"


Now, you need to compile WINE. Refer to this guide: www.winehq.org/docs/wineusr-guide/installing-wine-source
Compile patch?
by Paulo Rogerio on Tuesday March 15th 2011, 12:44
How do i compile this patch into Wine?

I´m new in Linux and am trying to do what Napoleon Total War work on Ubuntu 10.10. If they can help me take my email: granadian@gmail.com

Thanks,
Paulo Rogerio.
To successfully run the game
by Duarte Loreto on Thursday October 28th 2010, 17:41
Steps to successfully run the game:

It has to be version 1.2. The 1.3.x versions at least up to 1.3.4 don't work. The patch from bug #18490 is required for battles (and tutorial).

On a vanilla wine, using winetricks install several packages:
winetricks vcrun2005, vcrun2008 ie6 d3dx9

No more fidling needed.
Tested with DVD version.
RE: To successfully run the game
by marko on Monday January 6th 2014, 19:32
Where in Winetricks can I find these packages?
RE: To successfully run the game
by Duarte Loreto on Monday January 6th 2014, 20:35
I no longer use Linux at home but as far as I recall, if you executed "winetricks vcrun2005 etc" on a console line with a user that had permissions to execute winetricks and had it in the PATH, the packages and dependencies would simply install.
Don't know how much winetricks changed in 3 years, though.
RE: To successfully run the game
by marko on Monday January 6th 2014, 19:32
Where in Winetricks can I find these packages?
IGameExplorer could not verify access
by Duarte Loreto on Sunday October 24th 2010, 18:55
Hello,

Trying to run this game and it is failing with the above error.

First it was complaining abount C++ dlls so I used winetricks to install vcrun2005, vcrun2008 and ie6. The complaint about the C++ classes disappeared but I'm still getting the "IGameExplorer" error.

Running wine-1.3.4.

Any ideas? Thank you,
DL
RE: IGameExplorer could not verify access
by Duarte Loreto on Monday October 25th 2010, 18:56
Replying to myself, downgrading to 1.2 soled this error. 1.3.x has an initial implementation of the Game Server that prevents the game from starting up.

Now the game starts and I see a mouse cursor, I hear music but the screen is all black (apart from the cursor). Tried with both settings of "backbuffer" and "fbo" for the key "OffscreenRenderingMode" but can't see anything besides black.

Would really appreciate some help :)
Thank you,
DL
RE: IGameExplorer could not verify access
by Duarte Loreto on Monday October 25th 2010, 19:18
Answering myself again...

bugs.winehq.org/show_bug.cgi?id=23356

So, after "winetricks d3dx9" I can open the game and navegate the menus. Tomorrow I'll try to play.

No need to set any regedit settings so far.
Patching
by St. Augustine on Sunday October 10th 2010, 17:18
Could anyone possibly upload a patched Debian/Ubuntu version of Wine for this? I've been trying to do it myself and have encountered quite a few difficulties. It'd be great to have everything working properly.
Unable to unmoung CD1
by waglik on Wednesday September 15th 2010, 12:38
Hi

I have strange problem. Instalation of the first CD goes fine till the moment I need to switch discs. When I remove cd no other disc can be mounted. It looks like the old one is not umounted. Does anybody have sth similar?
RE: Unable to unmoung CD1
by K7522 on Wednesday February 16th 2011, 16:08
In Ubuntu, you can use the following line to force an unmount.

sudo umount -l /media/xxxxx

When using ISOs I had to make sure the second disk mounted to the same directory as the first for the installer to recognize it, just a warning.
Back