WineHQ

Worms Armageddon

All versions after and including the 3.6.30.0 update, which no longer requires a hacked Wine. A complete changelog can be found here: http://wa.team17.com/main.html?page=supp&area=upda&file=16

Application Details:

Version: 3.6.30.0+
License: Retail
URL: http://wormsarmageddon.team17....
Votes: 0
Latest Rating: Gold
Latest Wine Version Tested: 1.5.29

Maintainers: About Maintainership

Free Download Update download page

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Everything except online play (not tested)

What does not

Workarounds

What was not tested

online play

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowGentoo Linux x86_64May 12 20131.5.29Yes Yes GoldHAARP 
CurrentArch Linux x86_64Jan 15 20131.5.21Yes Yes Platinuman anonymous user 
ShowArch Linux x86_64Jan 15 20131.5.21Yes Yes Platinuman anonymous user 
ShowopenSUSE 11.4 x86_64Jul 22 20111.3.25Yes Yes GoldZhenya 
ShowFedora 13 x86_64Dec 26 20101.3.9N/A Yes PlatinumKiiro Yakumo 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

W:A versions on AppDB
by Vladimir Panteleev on Wednesday July 17th 2013, 5:07
Previously, when all but the very latest versions of W:A required a hacked Wine to work, we decided to avoid registering each individual update in AppDB (as there have been quite a few W:A updates), and split up all released versions into two groups - 1.0-3.6.29.0 (which couldn't work at all in a vanilla Wine) and 3.6.30.0 and above (which worked on Wine out-of-the-box). Thus, I moved HAARP's test results from his submitted version 3.7.0.0 to 3.6.30.0+.

However, now I'm doubting that decision, as W:A has begun moving quickly in terms of graphics API support and rendering approaches recently, such as software vs. hardware rendering, and optional support for graphics APIs like Direct3D 7 and 9, and shader-based palette transform.

I'm thinking that 3.6.30.0+ ought to be split up again. We could avoid confusion with some consistence in the version specs:
1) Put the update page (page which links to the latest update download) in the game's description
2) Put direct links to updates in each version's update URL
RE: W:A versions on AppDB
by Zebediah Figura on Wednesday July 17th 2013, 11:25
Yeh... I just updated it for 1.6 and Raring. I'm quite glad myself that it uses D3D, seeing as my graphics card is obsolete and won't run GL well.

Re #2... is that possible?
Back