WineHQ

Mass Effect

No Screenshot

Submit Screenshot
Default Steam install

Application Details:

Version: Steam
License: Retail
URL: http://masseffect.bioware.com/
Votes: 5
Latest Rating: Silver
Latest Wine Version Tested: 3.10

Maintainers: About Maintainership

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Almost everything. Start, menu, saving, loading, sound, mouse (with dinput8), keyboard, except...

What does not

No textures AT ALL. Even on the start screen with Earth and "press any button", the earth is non-textured dark-blue.

All objects in game are without textures at all too, and they are very dark also with screen gamma turn to maximum, so it can be played only by very patient people.

Also, mouse in game has too low sensitivity.

Workarounds

What was not tested

Whole gameplay. 

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

This is a Radeon HD5670 with xorg-edgers drivers. The most fresh ATI fglrx drivers (11.9) make me cry with my 5670. So I decided to test r600g-driver. FPS is rather good, but not ideal, about 17-20. But this textures problem is very sad.

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowUbuntu 18.04 "Bionic" amd64 (+variants like Kubuntu)Jun 14 20183.10Yes Yes NoSilverCarlos Rodriguez 
ShowManjaro LinuxJan 14 20183.0-rc5Yes Yes YesGoldOdisej 
ShowArch LinuxJun 14 20172.10Yes Yes GoldLiam 
ShowGentoo LinuxAug 27 20161.9.17N/A Yes Goldaililoh 
ShowArch Linux x86_64Jun 24 20161.9.12Yes Yes Silvervorpalblade 

Known Bugs

Bug # Description Status Resolution Other apps affected
40898 Mass Effect (Steam) has no sounds with native OpenAL (except for cutscenes) NEW View

Show all bugs

HowTo / Notes

HOWTO

Get audio to work

Edit "Documents/BioWare/Mass Effect/Config/BIOEngine.ini"
Add the following under the "[ISACTAudio.ISACTAudioDevice]" section:

DeviceName=Generic Software
UseEffectsProcessing=False

Ensure "Hardware Audio" is turned off in Sound settings in game

To get the MEUITM installer to work

A custom MassEffectModder.exe must be suppliedThis is seemingly due to it using functions not fully implemented in wine/mono
A hacky, usable version can be found here: https://github.com/DougTy/Mass...

Occasional "rendering exception" error while playing MEIUTM requires your game's binary be large address aware.
MassEffect.exe can be patched using this tool: https://www.techpowerup.com/fo...
Make a backup before patching!

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

Sound
by sairuk on Thursday September 1st 2016, 6:49
Edit BIOEngine.ini

Add the following lines to the section labelled [ISACTAudio.ISACTAudioDevice]

DeviceName=Generic Software
UseEffectsProcessing=False

Disabling hardware audio
Back