WineHQ

Mass Effect

No Screenshot

Submit Screenshot
Default Steam install

Application Details:

Version: Steam
License: Retail
URL: http://masseffect.bioware.com/
Votes: 5
Latest Rating: Silver
Latest Wine Version Tested: 3.10

Maintainers: About Maintainership

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Everything except "Motion Blur". Mouse and keyboard controls!

What does not

Motion Blur - this can cause the intro to hang and make the rest of the game unplayable.

Workarounds

What was not tested

Playing to the end, but I'm not having any trouble progressing thru the game thus far.



Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

Make sure to disable motion blur before you start a new game! All other settings work. The game can get slightly choppy at max settings and resolution (compared to Windows). There are some odd 3d glitches here and there (screenshot attached), but it's very much playable without any winetrickery. Mass Effect plays so much better now. Its so close to Platinum... intel i7-920, nvidia gtx 295 (290.10), 6gb ram

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowUbuntu 18.04 "Bionic" amd64 (+variants like Kubuntu)Jun 14 20183.10Yes Yes NoSilverCarlos Rodriguez 
ShowManjaro LinuxJan 14 20183.0-rc5Yes Yes YesGoldOdisej 
ShowArch LinuxJun 14 20172.10Yes Yes NoGoldLiam 
ShowGentoo LinuxAug 27 20161.9.17N/A Yes NoGoldaililoh 
ShowArch Linux x86_64Jun 24 20161.9.12Yes Yes NoSilvervorpalblade 

Known Bugs

Bug # Description Status Resolution Other apps affected
40898 Mass Effect (Steam) has no sounds with native OpenAL (except for cutscenes) NEW View
54352 Performance tanks when looking at occluded part of the level UNCONFIRMED View

Show all bugs

HowTo / Notes

HOWTO

Get audio to work

Edit "Documents/BioWare/Mass Effect/Config/BIOEngine.ini"
Add the following under the "[ISACTAudio.ISACTAudioDevice]" section:

DeviceName=Generic Software
UseEffectsProcessing=False

Ensure "Hardware Audio" is turned off in Sound settings in game

To get the MEUITM installer to work

A custom MassEffectModder.exe must be suppliedThis is seemingly due to it using functions not fully implemented in wine/mono
A hacky, usable version can be found here: https://github.com/DougTy/Mass...

Occasional "rendering exception" error while playing MEIUTM requires your game's binary be large address aware.
MassEffect.exe can be patched using this tool: https://www.techpowerup.com/fo...
Make a backup before patching!

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

Sound
by sairuk on Thursday September 1st 2016, 6:49
Edit BIOEngine.ini

Add the following lines to the section labelled [ISACTAudio.ISACTAudioDevice]

DeviceName=Generic Software
UseEffectsProcessing=False

Disabling hardware audio
Back