WineHQ

Limbo

The game on steam.

Application Details:

Version: Steam
License: Retail
URL: http://limbogame.org/
Votes: 0
Latest Rating: Gold
Latest Wine Version Tested: 1.9.18

Maintainers: About Maintainership

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

  • Clean 32-bit Wineprefix
  • Bundled DirectX installer deleted / not installed
    (to properly test builtin dll support)
  • Installation (from Steam client)
  • Launching game fullscreen, on dual-screen setup (single head)
  • Sound / Video
  • Input
  • Steam Cloud saves
  • What does not

  • Nothing - with overrides in place
  • Workarounds

    What was not tested

  • DirectX redistributable installer (deliberately purged - for testing purposes)
  • > 10 minutes of gameplay
  • Hardware tested

    Graphics:

    • GPU:
    • Driver:

    Additional Comments

    DLL Overrides winetricks d3dx9_43 d3dcompiler_43 System Software ================================================================= wine-1.9.18 [ebuild R ~] app-emulation/wine-1.9.18::bobwya USE="X alsa capi cups fontconfig gecko gphoto2 gsm gstreamer jpeg lcms mono mp3 ncurses nls openal opencl opengl osmesa png pulseaudio realtime run-exes samba scanner ssl threads truetype udisks xcomposite xinerama xml -custom-cflags -dos -ldap -netapi -odbc -oss -pcap -perl -prelink (-selinux) {-test} -v4l" ABI_X86="32 64 (-x32)" LINGUAS="en en_US -ar -bg -ca -cs -da -de -el -eo -es -fa -fi -fr -he -hi -hr -hu -it -ja -ko -lt -ml -nb_NO -nl -or -pa -pl -pt_BR -pt_PT -rm -ro -ru -sk -sl -sr_RS@cyrillic -sr_RS@latin -sv -te -th -tr -uk -wa -zh_CN -zh_TW" 0 KiB [ebuild R #] dev-qt/qtcore-5.7.0:5/5.7::gentoo [5.7.0:5/5.7::qt] USE="icu systemd -debug {-test}" 42,962 KiB [ebuild R ~] kde-frameworks/plasma-5.25.0:5/5.25::gentoo USE="X debug -egl -gles2 {-test}" 4,382 KiB [ebuild R ~] kde-plasma/plasma-desktop-5.7.4:5::gentoo [5.7.4:5::kde] USE="debug fontconfig handbook pulseaudio qt4 -gtk2 -gtk3 -ibus -legacy-systray (-packagekit) -scim {-test}" INPUT_DEVICES="evdev synaptics" 6,076 KiB [ebuild R #] media-libs/mesa-12.0.1-r1::bobwya USE="classic egl gbm nptl osmesa udev wayland xvmc -bindist -d3d9 -debug -dri3 -gallium -gles1 -gles2 -llvm -opencl -openmax -pax_kernel -pic (-selinux) -vaapi -valgrind -vdpau -xa" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="(-freedreno) -i915 -i965 -ilo -intel -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi (-vc4) -vmware" 8,371 KiB [ebuild R #] x11-base/xorg-server-1.18.4-r1:0/1.18.4::bobwya USE="ipv6 kdrive suid systemd udev xephyr xorg -dmx -doc -fop -glamor -libressl -minimal (-selinux) -static-libs -tslib -unwind -wayland -xnest -xvfb" 5,869 KiB [ebuild R #] x11-drivers/nvidia-drivers-370.23-r1:0/370::bobwya USE="X acpi driver kms multilib tools uvm -compat -gtk3 -pax_kernel -static-libs -wayland" 74,324 KiB System Hardware Device Class Description ========================================================= system G751JT (ASUS-NotebookSKU) /0 bus G751JT /0/0 memory 64KiB BIOS /0/8 processor Intel(R) Core(TM) i7-4710HQ /0/8/9 memory 1MiB L2 cache /0/8/a memory 256KiB L1 cache /0/8/b memory 6MiB L3 cache /0/c memory 32GiB System Memory /0/c/0 memory 8GiB SODIMM DDR3 Synchronous 1600 MHz (0.6 ns) /0/c/1 memory 8GiB SODIMM DDR3 Synchronous 1600 MHz (0.6 ns) /0/c/2 memory 8GiB SODIMM DDR3 Synchronous 1600 MHz (0.6 ns) /0/c/3 memory 8GiB SODIMM DDR3 Synchronous 1600 MHz (0.6 ns) /0/100 bridge Xeon E3-1200 v3/4th Gen Core Processor DRAM Controller /0/100/1 bridge Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller /0/100/1/0 display GM204M [GeForce GTX 970M] /0/100/1/0.1 multimedia GM204 High Definition Audio Controller /0/100/14 bus 8 Series/C220 Series Chipset Family USB xHCI /0/100/14/0 usb1 bus xHCI Host Controller /0/100/14/0/2 bus USB2.0 Hub /0/100/14/0/2/4 bus USB2.0 Hub /0/100/14/0/3 bus USB 2.0 Hub /0/100/14/0/3/2 bus USB2.0 Hub /0/100/14/0/3/2/1 input USB Receiver /0/100/14/0/3/2/3 input Corsair K65 Gaming Keyboard /0/100/14/0/4 multimedia Corsair Gaming H2100 Headset /0/100/14/0/5 communication Bluetooth wireless interface /0/100/14/0/7 multimedia USB2.0 HD UVC WebCam /0/100/14/0/a input ASUS ROG Macrokey /0/100/14/1 usb2 bus xHCI Host Controller /0/100/14/1/2 bus USB3.0 Hub /0/100/14/1/2/4 bus USB3.0 Hub /0/100/16 communication 8 Series/C220 Series Chipset Family MEI Controller #1 /0/100/1b multimedia 8 Series/C220 Series Chipset High Definition Audio Controller /0/100/1c bridge 8 Series/C220 Series Chipset Family PCI Express Root Port #1 /0/100/1c.2 bridge 8 Series/C220 Series Chipset Family PCI Express Root Port #3 /0/100/1c.2/0 wls1 network Wireless 7260 /0/100/1c.3 bridge 8 Series/C220 Series Chipset Family PCI Express Root Port #4 /0/100/1c.3/0 p3p1 network RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller /0/100/1f bridge HM87 Express LPC Controller /0/100/1f.3 bus 8 Series/C220 Series Chipset Family SMBus Controller

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
CurrentGentoo Linux x86_64Sep 02 20161.9.18Yes Yes GoldRob 
ShowGentoo Linux x86_64Feb 19 20161.9.3-stagingYes Yes GoldRob 
ShowGentoo Linux x86_64Dec 29 20131.7.8Yes Yes GoldFletch Hasues 
ShowopenSUSE Tumbleweed (rolling release)Dec 26 20121.5.20Yes Yes PlatinumRob 
ShowGentoo Linux x86_64Dec 01 20131.4.1Yes Yes GoldFletch Hasues 

Known Bugs

Bug # Description Status Resolution Other apps affected
27078 Limbo needs native d3dx9_43 and d3dcompiler_43 (purist) NEW View

Show all bugs

HowTo / Notes

Pre- / Post- Installation Steps

Override the following dll 's before (or after) installing Limbo:

export WINEPREFIX="❚❚❚❚❚❚"
winetricks d3dx9_43 d3dcompiler_43

In the instance of a failure you would find Limbo might fail to launch successfully (backtrace will indicate a failure in d3dcompiler_43), e.g.:

Backtrace:
=>0 0x056396a9 in d3dcompiler_43 (+0x1e96a9) (0x0033e238)
1 0x055285e4 in d3dcompiler_43 (+0xd85e3) (0x0033e63c)
2 0x0552750e in d3dcompiler_43 (+0xd750d) (0x0033e668)
3 0x054b6e6f in d3dcompiler_43 (+0x66e6e) (0x0033f3a4)
4 0x100e6186 in d3dx9_43 (+0xe6185) (0x0033f650)
5 0x004862e3 in limbo (+0x862e2) (0x03058489)

Alternatively you might see a vertex error KW_VERTEX popup dialog from Wine.

Note: you only need to specify the WINEPREFIX env variable if you are not using the default location: WINEPREFIX="${HOME}/.wine"

More recent test indicates that the issue is still present in Wine release wine-1.9.18 (Vanilla).

Tweaks

"First Time" Setup

To stop the firstevery time (!!) setup of the MS DirectX redistributable, for the default SteamApps location, in a 32-bit Wineprefix:

rm -rf "${WINEPREFIX}/drive_c/Program Files/Steam/steamapps/common/Limbo/DirectX_Redist"

... or for the default SteamApps location, in a 64-bit Wineprefix:

rm -rf "${WINEPREFIX}/drive_c/Program Files/Steam/steamapps/common/Limbo/DirectX_Redist"

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

Limbo is going crazy after 5-10 minutes
by Marcin on Sunday August 28th 2016, 4:24
I have wine 1.9.16 and wine-staging 1.9.16 and Limbo is working well but after 5-10 minutes of playing is going crazy - the character moves by himself and the game becomes unplayable.
RE: Limbo is going crazy after 5-10 minutes
by Rob on Sunday August 28th 2016, 17:10
Are you running Limbo in a Wine Virtual Desktop or an X fullscreen session?
What's your Desktop Environment?
Graphics card and driver?
Any fancy (Wine) mouse warp settings? :-)

I'll try and reproduce the issue - if you can give me some idea of your setup!!

Thanks
Bob
RE: Limbo is going crazy after 5-10 minutes
by Marcin on Monday August 29th 2016, 1:40
OK, I have forgot about it.
So I have a laptop with Kubuntu 14.04.3 x86.
I have wine 1.9.16 + wine-staging 1.9.16
installed DirectX.
My graphic card is intel graphics 3000 (my built-in card, I haven't installed my nvidia card drivers because I have been afraid of my linux will crash).
I have default driver.
No, any fancy settings. Mouse is working fine, but the game is not.
RE: Limbo is going crazy after 5-10 minutes
by Rob on Monday August 29th 2016, 4:30
So I'd fix your graphics stack - before raising spurious issues about Wine!! It's probably just the same old, same old broken Ubuntu/Debian stock configuration...

I've just supported a chappie (who I used to work with) fix his Ubuntu Mate 16.04.1 install... He's using a decent Intel Haswell generation IGP Core i5... The interface was freezing up and the CPU core's were spinning hard just to run Mate's Compton compositor (yeh - even a RaspPi Zero could run that DE!!)
Wtf - I thought - time to nuke that out-of-date Intel graphics driver...

You would need to purge:
launchpad.net/ubuntu/+source/xserver-xorg-video-intel

I set a grub kernel modeset line (I think - appeared to work):
i915.modeset=1

See:
wiki.archlinux.org/index.php/intel_graphics

I'm an "Nvidia guy" so I don't much about the Intel i915 graphics stack. But what I did seemed to fix all the stock Ubuntu weirdness...

Your graphics stack is from the Sandy Bridge generation... That's the first of the "modern" Intel IGP's that this procedure would apply for.
RE: Limbo is going crazy after 5-10 minutes
by Marcin on Monday August 29th 2016, 5:25
I have reviewed package list on my kubuntu and I see that I haven't package "xserver-xorg-video-intel" , but only I have packages :
xserver-xorg-video-intel-codename, where codename is vivid, trusty, and others.
I have trusty (14.04) but I have installed video graphic driver for vivid , but why ?
RE: Limbo is going crazy after 5-10 minutes
by Marcin on Monday August 29th 2016, 5:26
"xserver-xorg-video-intel" is on the list, but it's not installed.
RE: Limbo is going crazy after 5-10 minutes
by Rob on Friday September 2nd 2016, 18:38
I had a good crack to re-produce this issue - but I can't. I'd file a bug report if I was you!

Btw I see you've edited your test results a bit - but left them in a limbo state (sorry couldn't resist that one!!) I can't currently access the updated test submission...
Back