WineHQ
Path of Exile Release



Category: Main > Games > Online (MMORPG) Games > Path of Exile > Release


NamePath of Exile
VersionRelease
License Free to use
URLhttps://pathofexile.com/
Votes 11
RatingGold
Wine Version1.8.1
Free Download Installer [msi] (direct link)
Maintainers of this version:
No maintainers. Volunteer today!
Description

The official release version. Beginning with versions 1.x.

Selected Test Results (selected in 'Test Results' table below)

What works

  • Menus
  • Changing video settings and keybindings.
  • Custom loot filters.
  • Playing through the game normally. 
  • Endgame maps etc.

    Installed on a clean 32bit wine prefix without any overrides. Used a 2560x1440 virtual desktop (native for my monitor).


    What does not

    I have serious performance issues on a high end gaming PC. See extra comments for details.


    What was not tested
    PvP


    Additional Comments

    My system:
    CPU: Intel Core i7-3770K
    GPU: GeForce GTX 970
    RAM: 16GB
    Storage: 512GB SSD
    
    
    The game has multiple performance issues, and playing around with the video settings in the game did not appear to help in any meaningful way.
    
    1: Overall FPS appears to drop a lot lower than normal when any kind of life/mana regeneration is happening. (other people in the wine thread on Path of Exile's forums have also reported this)
    2. Whenever new assets are loaded (or drawn?) it causes stuttering. This can be mitigated, but not eliminated, by disabling GLSL (winetricks glsl=disable).
    3. Stuttering gets worse the longer I play, gradually turning into an unplayable slideshow, requiring a client restart. Feels like a memory leak.
    
    Ever since version 1.9.8 of Wine I get graphical glitches with GLSL disabled: https://i.imgur.com/Fyk2cyi.jpg
    This does not happen if I re-enable GLSL, but then my stuttering is far worse, so it's not really a good alternative.
    
    Test Results
    DistributionTest dateWine versionInstalls?Runs?RatingSubmitter
    CurrentArch Linux x86_64Apr 17 20161.9.8 Yes Yes Bronze Carsten Jakobsen 
    ShowUbuntu 14.04 "Trusty" i386 (+ variants like Kubuntu)Mar 09 20161.8.1 Yes Yes Gold Jaroslav Smutek 
    ShowArch Linux x86_64Dec 29 20151.9.0 N/A Yes Gold Mayfair 
    ShowUbuntu 15.10 "Wily" amd64 (+ variants like Kubuntu)Dec 21 20151.8 Yes Yes Gold David 
    ShowArch Linux x86_64Dec 15 20151.8-rc3 Yes Yes Gold SmutnySmok 


    Known bugs
    Bug # Description Status Resolution Other apps affected
    32463 Font artefacts in Path of Exile NEW View
    34011 Path of Exile stutters constantly UNCONFIRMED View

     
    Required fixes (as of 2014-08-07)
    Set fullscreen
    Edit the production_Config.ini file located in ${Documents}/My Games/Path of Exile/. Change fullscreen to true. This prevents the "Failed Resetting Direct3D device objects" crash.

    Override openal32.dll:
    In winecfg, set the openal32 library to native,builtin or native. This prevents errors involving sound files at launch.
    Unconfirmed: An alternative is to launch Path of Exile with sound off with the -nosound flag. 

     
    Recommended fixes (as of 2014-08-07)
    winetricks riched20.dll // for launcher
    winetricks usp10.dll    // fix unicode missing symbols


     

    The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

    Crash (possibly Nvidia proprietary drivers) in certain areas
    by Tom on Friday January 29th 2016, 5:40
    I keep having my whole system go down (screens blank and then glow bright colors), most frequently in certain areas of act 2 (Southern Forest, Riverways, Wetlands, Western Forest). Mostly posting here to see if anyone else has this issue.

    Some strange details of crashes I've had lately w.r.t. PoE on wine:

    Graphics go tits up -- screens blank and redraw as a solid color, color seems arbitrary.

    Filesystems go read-only -- dmesg shows a libsata error queueing an operation (have seen read and write both, with fqdma (hope I put that right) enabled and disabled. This persists regardless of wine version and even if PoE and its wineprefix are on a ramdisk (so libsata shouldn't bitch) which leads me to believe it's related to the graphics issue and I *think* it might be nvidia drivers going tits up and shitting on the sata bus somehow.

    If nobody else has similar issues, perhaps it's just something wonky with my setup and I can accept that, just posting here for posterity in case someone else has such issues (or in case they point to some egregious error somewhere along the codepaths).

    Cheers!

    [post new] [reply to this]

    Lower left corner not rendering properly
    by defn on Saturday September 12th 2015, 13:27
    The lower left corner is missing some effects. Please see the screenshot.

    i.imgur.com/z9LhYGA.png

    [post new] [reply to this]

    Getting the installer to work
    by John on Saturday August 8th 2015, 18:33
    So I just installed wine (it looks to be version 1.6.2 on my imac mid 2011 running 10.10.2) and i cd to the desktop where the POE installer folder is. I then try to run "wine icon.clienticon.exe" since that is the only .exe file that I see in the installer folder but I keep getting the error from wine that says "Bad EXE format for ...".
    Am I not selecting the right file to launch the installer or is there something else that I need to do? Thanks for the help!
    John

    [post new] [reply to this]

    Game crashes during game load after character selection
    by eNTi on Wednesday July 8th 2015, 16:08
    as i've posted on the path of exile forums (www.pathofexile.com/forum/view-thread/8980/page/119/#p10912549) the game crashes a short moment when i press play after the character selection screen.

    fixme:font:freetype_GdiRealizationInfo (0x317d81c8, 0x33de58): stub!
    fixme:font:freetype_GdiRealizationInfo (0x317d81c8, 0x33de08): stub!
    fixme:dbghelp:elf_search_auxv can't find symbol in module
    wine: Unhandled page fault on read access to 0x178033f0 at address 0x100d6de9 (thread 0021), starting debugger...
    fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
    fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x33f90c 1 C) semi-stub
    Unhandled exception: page fault on read access to 0x178033f0 in 32-bit code (0x100d6de9).
    Register dump:
    CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
    EIP:100d6de9 ESP:0033e0fc EBP:0033e154 EFLAGS:00210202( R- -- I - - - )
    EAX:3c9f5f40 EBX:178033f0 ECX:00000000 EDX:00000000
    ESI:00000000 EDI:00000000
    Stack dump:
    0x0033e0fc: 00000000 3c9f4f30 7e6b57b4 0033e158
    0x0033e10c: 7e64f723 00000000 00000800 00080000
    0x0033e11c: 3ac10000 00000400 00000400 0033e150
    0x0033e12c: 7e6b57b4 0033e2b0 00000f00 0033e168
    0x0033e13c: 7e64f710 00000001 0033e1cc 7e632d25
    0x0033e14c: 3c9f4f30 00000000 0033e1a0 100cabc4
    Backtrace:
    =>0 0x100d6de9 in d3dx9_42 (+0xd6de9) (0x0033e154)
    1 0x100cabc4 in d3dx9_42 (+0xcabc3) (0x0033e1a0)
    2 0x100d1dc4 in d3dx9_42 (+0xd1dc3) (0x0033e1c4)
    3 0x100d4431 in d3dx9_42 (+0xd4430) (0x0033e1d4)
    4 0x100ba71a in d3dx9_42 (+0xba719) (0x0033e2bc)
    5 0x100bce4c in d3dx9_42 (+0xbce4b) (0x0033e3c0)
    6 0x00906118 in pathofexile (+0x506117) (0x100bcc2d)
    0x100d6de9: movzwl 0x0(%ebx),%esi
    Modules:
    Module Address Debug info Name (145 modules)
    PE 400000- f2c000 Export pathofexile
    PE 1a70000- 1c57000 Deferred d3dcompiler_42
    ...

    [post new] [reply to this]

    Help please
    by Kyle Kuntz on Monday May 11th 2015, 11:04
    I am still running into the failed to "Failed Resetting Direct3D device objects" error. Even tho my fullscreen is set to true. what else should i do?

    [post new] [reply to this]

    Chaotic gamma changes, wine 1.7.19
    by Greg Cohen on Tuesday September 16th 2014, 17:32
    I'm not that good with words, so i figured it would be easier to show.

    Since patch 1.2 of the POE i had some serious performance issues with this game, so i built wine 1.7.19 from the sources, as was recommended,
    and applied the patch 'wgl_surface.patch'

    Performance is great, game runs stable, but i still can't figure the issue of chaotic gamma (or maybe full screen light) changes.

    As i told you before, i don't really know how to describe the situation, so i decided to upload a short 'demo'

    www.youtube.com/watch?v=fShWPZ6kuno&feature=youtu.be

    Please point me into the direction of solution!

    [post new] [reply to this]

    1.2.2 update fps drop
    by gary on Thursday September 11th 2014, 20:51
    New patch was released and with it anytime I encounter a enemy or cast a spell fps drops from 60fps to 5fps. I am using Ubuntu Gnome 14.04 with wine version 1.6-rc4. Anyone else experiencing this?

    [post new] [reply to this]

    i'm trying to install wine compholio x86_64
    by Joël on Tuesday August 19th 2014, 7:21
    It's a precompiled package from Sebastian Lackner in this bug report :
    bugs.winehq.org/show_bug.cgi?id=35718#c67
    But it's for Archlinux and i'm using OpenSuse.
    So if anyone knows of an easy way to do this, i'd love some help.

    (all this in the hope of stopping the game from blinking so much that i can't play it)

    [post new] [reply to this]

    Problem updating to 1.1.3
    by Eelco Bosselaar on Thursday May 1st 2014, 11:50
    Having problems updating to 1.1.3. Patcher screen stays stuck on 97.5% downloaded and will eventually throw a timeout error about not being able to download a certain sound file.

    Trying to workaround this by having steam download the game update and then copying it to my standalone version for PoE.

    Already ran PackCheck.exe and it said it fixed my ggpk but the error remains.

    I will update when I find out more.

    [post new] [reply to this]

    Black screen
    by Marcin Falkiewicz on Thursday April 10th 2014, 12:06
    Regarding the black screen issue, changing in regedit (check wiki.winehq.org/UsefulRegistryKeys ) OffscreenRenderingMode to 'backbuffer' solves the problem.

    [post new] [reply to this]

    Crash with Debian Jessie and latest fglrx-driver
    by Anb on Tuesday March 18th 2014, 10:41
    Since the last update of debian jessie and fglrx-driver (14.2~beta1.3), path of exile crash at startup.

    For now, the only way to have it work is to not upgrade your debian.

    The upgrade will update xorg-server to a newer major version which is not compatible with previous fglrx-drivers, so downgrade is very difficult.

    I'm trying to update to latest ati drivers manually (14.3) to check.

    [post new] [reply to this]

    it no longer works in wine 1.7.14 or
    by Joël on Saturday March 8th 2014, 12:00
    i upgraded wine to version 1.7.14 and the path of exile client won't work anymore.
    It seems the updater still works fine, but as soon as the actual client starts, it crashes the X server.
    So i bet something was changed from version 1.7.13 :(

    Any help would be appreciated (also i don't know how to create bug reports).

    [post new] [reply to this]

    Wrong install path
    by Dan Johansen on Friday February 14th 2014, 16:30
    I only have one problem with my PoE install. It doesn't install the files in the folder I specify. It installs them directly into my Home directory, without a subdirectory.

    How to fix that?

    PS: I use a seperate prefix for it.

    [post new] [reply to this]

    d3derr
    by aobe5dhk on Wednesday February 12th 2014, 8:09
    Hi,

    I have linux Mint 16 x64 and I have installed PoE from PlayOnLinux.
    I have got "error unable to create texture d3derr ... ".

    I have read some threads about this problem but I can't find a solution.
    I have installed libosmesa6 but no luck.
    I also tried to enable GLSL=enable from playonlinux menu but still no luck.

    I have mesa 10.2 development version drivers that I have installed from ppa: xorg-edgers/ppa/ubuntu/ and my video card is ATI MSI R6870.

    here is my debug log from game:

    pastebin.com/raw.php?i=PmRnTefc

    I hope you can help me.
    Thanks

    [post new] [reply to this]

    • RE: d3derr by aobe5dhk on Wednesday February 12th 2014, 12:56
    • RE: d3derr by Felipe Milani on Saturday December 13th 2014, 19:43
    Installation over Steam
    by pfftzo on Monday January 27th 2014, 14:54
    I just installed it via Steam and when I started it, it said "Installing VCRedist step 1/2" and then finished and nothing happened, ie the game didn't start, the window just terminated and I was back in plain steam. :(

    [post new] [reply to this]

    Font artifacts
    by rt on Wednesday December 25th 2013, 14:29
    Text is much more readable after adding the following into the Wine registry:

    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\FontSubstitutes]
    "Fontin SmallCaps"="Fontin"

    Before: bugs.winehq.org/attachment.cgi?id=46992
    And after: bugs.winehq.org/attachment.cgi?id=46993

    wiki.winehq.org/UsefulRegistryKeys

    [post new] [reply to this]

    Gentoo users, help?
    by Pekka Paalanen on Friday December 13th 2013, 14:34
    I'm hitting the "Cannot create texture." D3DERR_NOTAVAILABLE error too, and no matter what I tried, it won't go away. 32-bit mesa, osmesa and whatnot. This is not the first game, where other people (even on Gentoo) get it running, but I cannot.

    Could a Gentoo user who got PoE running, put the output of the following commands available somewhere?
    $ emerge --info
    $ emerge -evp wine
    $ winetricks list-installed

    Note, that the output is probably too long to be pasted as a comment here.

    Also the *.reg files from your $WINEPREFIX would be nice to see.

    Thanks.

    [post new] [reply to this]

    Chat window affects performance
    by Silviu C. on Monday December 9th 2013, 15:33
    I've found that disabling both trade chat and general chat will improve the performance of this game significantly. Easy to observe by pressing F1 while in game. FPS shot from 30-ish to over 100 on my GTX 660.

    Can anyone else confirm this?

    [post new] [reply to this]

    Strange Crash
    by Mojo Troll on Monday November 11th 2013, 10:20
    I just installed this using a pc version of steam and everything seemed to be running fine with it until a strange crash occurred where even launching my wine command through terminal (showed nothing only showed launch after it loaded) it just locks up and a transparent box appears on my screen titled Path of Exile and this happens every so often playing it so i'm thinking its a memory allocation crash. Anyone else have this?

    [post new] [reply to this]

    Failed Resetting Direct3D device objects
    by Drake on Wednesday October 23rd 2013, 23:54
    When I try to launch I get the error "Failed resetting Direct3D device objects."

    Anyone know what might cause this? Followed all of the steps listed.

    The only thing worth mentioning is that I have almost every single version of DirectX installed because this is my Steam wrapper (lots of games with different requirements). Could this be causing the issues?

    I'm on OS X 10.8.5

    [post new] [reply to this]

    D3DERR_UNAVAILABLE
    by tsimbaloff yuri on Sunday October 20th 2013, 16:40
    Hi All!
    I'm using gentoo64, and I saw error message after logging and loading the first location. I have seen in this site, that lib32osmesa is required to play PoE. I compile mesa with ABI_X86="64 32" and USE="osmesa", but game always crashed...

    Can anybody help me with gentoo64 and PoE?

    [post new] [reply to this]

    how to fix msvcp and msvcr dll errors
    by Joël on Wednesday July 17th 2013, 14:50
    Today i couldn't run the game because of errors with these 'dll's.
    It seems this game uses some 2010 year version of those MS files so you'll want the files with number 100 in filename.

    And there's probably a winetricks command to make all this automagically but i didn't find which one it is.

    So i downloaded msvcr100.dll and msvcp100.dll, i unzipped it in the game directory.
    Then i added them as native in the library tab of winecfg (for Client.exe which i first added in the applications tab).

    So far the game seems to be happy with only these 2 files.

    [post new] [reply to this]


    by Tom Hackers on Tuesday June 25th 2013, 10:07
    Ferg's "manual" is best. appdb.winehq.org/objectManager.php?sClass=version&iId=25078&iTestingId=78043

    [post new] [reply to this]

    • RE: by Tom Hackers on Tuesday June 25th 2013, 10:09
    Memory Problem
    by wehde on Saturday May 18th 2013, 19:09
    has anyone managed to figure out why the drops frames and seems to lag when new abilities or mobs are loaded in memory? I'm using wine version 1.5.28 with usp10 riched20 d3dx9_42 msvcr100 openal32 d3dcompiler_43.

    [post new] [reply to this]

    client link don't work
    by muzzol on Thursday May 2nd 2013, 6:37
    not a big deal, I know.

    this is the right one: webcdn.pathofexile.com/downloads/PathOfExileInstaller.msi

    [post new] [reply to this]

    openal32.dll
    by eXpander on Thursday April 18th 2013, 17:41
    How exactly do you "override" openal32.dll in winecfg? I cannot find it in my library list in winecfg? Do I have to install it somehow separately?

    [post new] [reply to this]

    Fonts
    by Ferg on Thursday April 18th 2013, 0:44
    To fix problem with fonts (like that ferg.in/storage/m2nGe6t3/) just move game to a new wine prefix (installer breaks something during installation)

    [post new] [reply to this]

    • RE: Fonts by Tom Hackers on Saturday June 22nd 2013, 6:12
      • RE: Fonts by Tom Hackers on Saturday June 22nd 2013, 6:20
    • RE: Fonts by dimitri on Thursday August 22nd 2013, 15:35
    Works awesome suace in Playonlinux.
    by Damon on Wednesday April 17th 2013, 17:20
    I couldn't get this working due to the allocating disk space bug, until I downloaded the new wine version entitled: 1.5.28-pathofexile. Now it works perfectly :)

    [post new] [reply to this]

    Allocating Space slow easy fix
    by zyvy on Monday April 8th 2013, 16:50
    go to
    www.pathofexile.com/forum/view-thread/233564
    very easy fix

    [post new] [reply to this]

    ATI
    by marcel on Tuesday March 12th 2013, 3:47
    with ATI HD 4xxx game is unplayable with high FPS drops when using new skills. It's like they are loading when they are only being used. Because after you use them the FPS drops stop, and when something new is there it starts to lag again.

    [post new] [reply to this]

    • RE: ATI by mathew on Thursday April 11th 2013, 1:54
    Sound
    by Joseph on Thursday February 28th 2013, 23:54
    I have a very low "gargling" sound when turning on any kind of sound under the options.

    [post new] [reply to this]


    by lahtis on Tuesday February 26th 2013, 13:34
    Installing version 0.10.1f Allocating Space takes about 8 hours time in my Intel® Core™2 Duo CPU E4400 @ 2.00GHz × 2 prosessor. it is not fast.

    [post new] [reply to this]

    GLSL
    by a51ts2 on Tuesday February 12th 2013, 11:51
    Using ATI catalyst drivers I had to leave GLSL enabled, otherwise the screen (except for some UI) is black.

    [post new] [reply to this]


    by Oleg on Friday February 1st 2013, 20:53
    Hi guys, I have problem with video. Game is opening fine, I can log into my account and choose character. But after that, when the game map is loading, error comes out:
    Unable to create texture. D3DERR_NOTAVAILABLE Not Available.

    Can you help me please? I'm desperate.

    prefix configuration:
    winetricks d3dx9_36 vcrun2010 sound=alsa
    openal32 native (windows)
    virtual desktop 1024x768

    Distro: ArchLinux
    kernel: 3.7.5-1-ARCH x86_64
    video: intel i915 driver (xf86-video-intel 2.20.19-1) - adapter_name=Intel(R) Ivybridge Desktop
    wine: 1.5.22-1
    Desktop enviroment: i3 WM (i3-wm 4.4-2)
    Audio system: alsa/jack

    wine log pastebin.com/v3SZm8md
    production_Config.ini pastebin.com/8QF7d6pW
    list of installed 32bit libs pastebin.com/EjMkynjc
    full wine log with WINEDEBUG=warn+all pastebin.com/AppWUFfd

    [post new] [reply to this]

    Fps drops
    by alex on Wednesday January 30th 2013, 11:42
    There is a common problem causing huge fps drops (or even complete freezes for seconds) every time certain effects are loaded, especially when new boss monsters appear.

    It has been reported by multiple users that this issue can very easily be fixed for nvidia cards by just disabling GLSL shaders. On Ati cards however this seems to cause major graphics glitches or crashes.

    [post new] [reply to this]

    Resolution glitch
    by Keenan Willem on Tuesday January 29th 2013, 23:15
    Not sure what's happened now but the game is really loving this tiny resolution. Not sure how to best describe it so here is a pic: i.imgur.com/RgxEll6.jpg

    [post new] [reply to this]

    Ram issue
    by fotis on Monday December 31st 2012, 6:11
    i have a problem with my ram path of exile after 20m loads up 3.2 gb of ram wtf??
    and my fps always going crazy from 100 to 10 non-stop
    i created a swap file cause my system was frezzing after POE for 20m
    but still 3.2gb of ram for a game is much...

    PS: FPS are crazy from the start of the game its not cause of the ram.

    GPU: ATI Radeon hd 6670
    CPU: AMD FX 4100
    RAM: 4GB RAM DDR3

    [post new] [reply to this]

    audio causing freeze
    by Netsrotti on Wednesday May 9th 2012, 19:34
    To solve the audio freeze when using active skills I added openal32 native under winecfg libraries tab.

    [post new] [reply to this]




       << Back

    Page loaded in 0.12671 seconds.