WineHQ
Category: Main Games Online (MMORPG) Games TERA Online EU CBT Version

TERA Online

European Closed Beta Version

Application Details:

Version: EU CBT Version
License: Retail
URL: http://tera.hangame.com/
Votes: 0
Latest Rating: Silver
Latest Wine Version Tested: 1.5.5

Maintainers: About Maintainership

Free Download Homepage of Tera Europe with Beta Registration

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Installer and Patcher.

What does not

Game itself, Error Message "Error: 01110002 XML parse error"

Workarounds

What was not tested

-

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

It's definitely a wine Problem, it runs with windows. AMD Phenom II 965 BE Nvidia Geforce 460 GTX 8GB Ram POL, installed MSXML6, but it doesn't help Other DLL overrides and third party software: Wininet, mono 28, ReleaseRevision.txt: $Revision: 1603 $ SrcRegVer: 7697 GoldVer: 7702 ReleaseName: FRG-16.03 ReleaseDate: 2012-01-04 오후 8:52:03 ClientRevision: 201272 ShareRevision: 201356 ReleaseDataRevision: 5781

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowGentoo LinuxJun 09 20121.5.5Yes Yes Silverhaxx 
ShowArch Linux x86_64Apr 22 20121.5.2Yes Yes BronzeSteffen 
ShowArch Linux x86_64Mar 29 20121.5.0Yes No Garbagecorubba 
ShowGentoo Linux x86_64Feb 22 20121.4-rc4Yes No GarbageTonkar 
ShowGentoo Linux x86_64Feb 15 20121.4-rc3Yes No GarbageTonkar 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

Catalyst, xf86 crashes
by qnix on Sunday June 10th 2012, 12:48
All tests are made under arch64 using wine 1.5.5 with OpenInputDesktop and sound disabled.

It used to work perfectly with nvidia gtx295, but I moved to my other cards Radeon 6990 xfire Radeon 6970 and the game started to crash the Launcher runs normally and get the 3GB thing until I get the cursor where the game crashes. I have tried with catalyst 12.6, catalyst 12.4, catalyst 11 and xf86-video-ati 6.14.99
none of them solved the problem and it seems that it's a wine related problem.

I have googled and did many searches and with no luck.
RE: Catalyst, xf86 crashes
by qnix on Sunday June 10th 2012, 12:53
This is the error :

err:d3d:context_create wglSwapIntervalEXT failed to set swap interval 0 for context 0x12eba0b0, last error 0x591
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
err:d3d:state_pscale >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glPointSize(...); @ ../../../dlls/wined3d/state.c / 1562
may not be a wine bug
by haxx on Saturday June 9th 2012, 14:34
The extreme lag with UI windows open might be more obvious when running the game through wine, but may not be a wine issue.

vi.reddit.com/r/TeraOnline/comments/u12os/tera_ui_issue_needs_attention_no_developer/

my framerate in TERA is quite bad (barely playable) with UI showing, but becomes very smooth if I hide the UI completely using CTRL+Z. not the best solution, as you need the UI visible to interact with NPCs, but I can disable UI while out questing or in dungeons and the game plays well.


my system:

gentoo linux
Phenom II 955 @ 3.4 GHz
8GB DDR3
NVidia GTX275
Progress so far...
by Steffen on Wednesday April 18th 2012, 15:08
I managed to get the game up to the point where it switches to fullscreen and displays the cursor, at that point one of the threads crashes however.

To make the patcher work copy a native version of xmllite.dll into the launcher folder, this fixes the xml parser error.

Wine must be compiled with OpenAL support otherwise the client crashes on start.

I changed the OpenInputDesktop function in /dlls/user32/winstation.c to

HDESK WINAPI OpenInputDesktop( DWORD flags, BOOL inherit, ACCESS_MASK access )
{
return CreateDesktopA("Desktop", 0, 0, flags, access, 0);
}

to get past the OpenInputDesktop loop, no idea if its a good way to do this though :P

This way TERA.exe launches and displays a messagebox about the 3GB boot option being enabled, after clicking ok it switches into fullscreen mode and shortly displays the cursor before one of the threads crashes and TERA.exe just remains dead there.

Crash backtrace: pastebox.it/get/plain/3fb30f5e18c88572010cc4199adb0df5ae4f66e7/1334779432.txt/

Using WINEDEBUG=relay makes it crash even earlier with a different error so its not of much use i guess.

This is with wine 1.5.2 on 64 bit Arch Linux.
There we go
by Steffen on Friday April 20th 2012, 1:57
Open regedit and go to HKEY_CU/Software/wine/Drivers and set Audio to an empty string. This disabled wines audio driver and makes the game work.
For whatever reason i still get sound ingame, just not on the first movies which seem to be causing that crash.

Its probably related to this bug: bugs.winehq.org/show_bug.cgi?id=20799
RE: There we go
by Insomnium on Monday April 23rd 2012, 13:45
I can launch the game with the 1.5.2 "Openinputdesktop" Version without this workaround, (i have sound in the movies) but nice work :)
~Insomnium
RE: There we go
by haxx on Saturday May 19th 2012, 21:45
I am running the US retail version on wine 1.5.4 with the OpenInputDesktop function compiled in, and am able to play pretty well. I haven't experienced the audio problems mentioned above, but I was having some serious stuttering/freezing any time I moved my mouse. It seems better after a friend pointed out the "Mouse for UI only" option in game.
RE: Progress so far...
by Starseed13 on Saturday June 16th 2012, 18:20
What program are you using to edit this winsta.dll file? I seem to not be able to with gedit or kwrite. What encoding?
Back