WineHQ

The Darkness II

Version released by Steam

Application Details:

Version: Steam
License: Retail
URL:  
Votes: 2
Latest Rating: Silver
Latest Wine Version Tested: 4.0

Maintainers: About Maintainership

Test Results

Old test results
The test results for this version are very old, and as such they may not represent the current state of Wine. Please consider submitting a new test report.
Selected Test Results

What works

  • Rebinding keys, changing resolution, VSync, brightness setting
  • Achievements
  • Getting through the campaign to the end without crashes, New Game+
  • All cut-scenes
  • Vendettas and hit list(all characters)


What does not

  • Missing(black) textures. Bug 30061
  • Missing dialogues and sound effects.
  • Low frame rate.

Workarounds

What was not tested

Multiplayer

Hardware tested

Graphics:

  • GPU: Nvidia
  • Driver: proprietary

Additional Comments

  • I was using a clean 32-bit wineprefix.
  • I did not modify any wine and steam settings nor used winetricks. So this is out-of-the-box results.
  • It was noted that the Steam client itself is not very stable. The game was installed from a steam backup to save time. Normal download seems to work too.
  • The hook provided in bug 30061 completely solves the missing textures problem.
  • "winetricks xact xact_july2010" suggested in the comments completely solves all audio issues. Though "xact_july2010" is probably redundant now
  • The FPS is lower than it should be, but high enough to fully enjoy the game. It was between 30 and 60 on my NVidia Quadro K4200.

The game works excellently, but has some problems that are easy to fix locally(winetricks + patch).


selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
CurrentGentoo Linux x86_64Feb 06 20194.0Yes Yes NoSilverNick 
ShowArch Linux x86_64Apr 10 20183.4Yes Yes YesBronzeVolpe 
ShowGentoo Linux x86_64May 17 20161.9.8Yes Yes BronzeNick 
ShowGentoo Linux x86_64May 04 20141.7.18Yes Yes BronzeNeverLoved 
ShowGentoo Linux x86_64Jan 18 20141.7.10Yes Yes BronzeNeverLoved 

Known Bugs

Bug # Description Status Resolution Other apps affected
46472 Linux kernel 4.19 breaks startup of BO2 due to change in PTRACE_POKEUSER hw breakpoint behavior UNCONFIRMED View

Show all bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

winetricks xact
by Konrad Materka on Tuesday May 15th 2018, 13:17
Wine now uses build-in XAudio2 by default. Use the latest version of winetricks, it will work correctly with wine newer than 3.5.
Problem
by MonoBOY on Monday September 10th 2012, 2:28
How i can fix this "some textures are black " and sometimes can't see anything

by Martijn Vandecasteele on Wednesday September 5th 2012, 11:58
To solve the no-audio problem, install xact and xact_jun2010 via winetricks.

winetricks xact xact_jun2010
Wrapper
by William Min on Sunday March 4th 2012, 23:36
I know that the game is not fully functional, but I was wondering if someone could upload the wrapper to mediafire or something. I would like to test it on my mac.
RE: Wrapper
by K1773R on Sunday March 4th 2012, 23:49
what are you talking about?
shader glitches
by Yuki on Saturday March 3rd 2012, 7:57
no matter if you add alwaysoffscreen or strictdrawordering, some textures are plain black. Imo, the game is not playable that way, so any rating higher than bronze are questionable
RE: shader glitches
by K1773R on Saturday March 3rd 2012, 8:42
well, i was able to play it, its just a bit anoying. sometimes theres even full light and u cant see anything.
RE: shader glitches
by Yuki on Saturday March 3rd 2012, 11:43
could someone please file a seperate bug report for that shader problem and link it to this one?
I would, but cannot add any terminal output at the moment
RE: shader glitches
by K1773R on Saturday March 3rd 2012, 12:36
done
RE: shader glitches
by Yuki on Saturday March 3rd 2012, 16:53
thanks and sorry..
apparently, the shader issue was part of the original bug..

didn't want to let you do the extra work, sorry again :/
RE: shader glitches
by K1773R on Saturday March 3rd 2012, 18:29
no problem. i always like to help and you did help alot ppls so your welcome ;). if i get enough time i gonna try to fix that.
working all of a sudden?
by Yuki on Friday March 2nd 2012, 6:32
I suppose that the recent nvidia update fixed the render-fail.
At least, according to t800, that would be a possible explanation on why the game ran for him.

Could someone add some screenshots for this game running on wine?
RE: working all of a sudden?
by K1773R on Friday March 2nd 2012, 8:45
will test this now :)
RE: working all of a sudden?
by K1773R on Friday March 2nd 2012, 10:13
not working, 295 driver too on a gtx580 all it does is spamming me with 4 lines of "fixme:d3d:resource_check_usage Unhandled usage flags 0x8." every second.
it really needs the PresentEx() otherwise it wont work, looks like a fake!
RE: working all of a sudden?
by K1773R on Friday March 2nd 2012, 11:13
after some patching and hacking i managed to get it running on 1.3.20, will try to patch and hack the 1.4-rc5 now, unfortunately there is no sound at all in 1.3.20 and the darkness2 isnt even looking for a soundcard (mmdevapi maybe? but there isnt a single fixme/debug info related to sound!) and all it shows is a unavailabe device or something similiar.
RE: working all of a sudden?
by K1773R on Friday March 2nd 2012, 11:42
its not working in 1.4-rc5 too! ingame when configuring sound at the device it says "undefined" and there is no fixme for sound, will post the patch (both) on the bugzilla so u can play it :)
RE: working all of a sudden?
by K1773R on Friday March 2nd 2012, 11:52
The no sound issue happens on winblows too, its liekly a problem with the game :S
Back