WineHQ

Multi Theft Auto: San Andreas

No Screenshot

Submit Screenshot





Several new scripting functions, a new default skin and bugfixes.

Major highlights of this release includes:

  • fixes for various network problems which occured in 1.1 and 1.2 series (including a fix for "Map download breaking often on large transfers" issue)
  • added new scripting functions for removal of default GTASA map objects (including breakable ones)
  • introduced a new scripting event - onClientVehicleCollision
  • implemented a new scripting function - takePlayerScreenShot
  • fixes for various crashes and issues (including "warp glitch", inaccurate heat seekers sync, createProjectile() velocity desync between clients, custom models texture crash, "white models" when using custom models and more)
  • added pixel manipulation functionality
  • introduced new client-side scripting functions - setBirdsEnabled and getBirdsEnabled
  • included a new gui skin - Lighter black - contributed by Aibo

Application Details:

Version: 1.3
License: Open Source
URL: https://multitheftauto.com/
Votes: Marked as obsolete
Latest Rating: Gold
Latest Wine Version Tested: 1.7.43

Maintainers: About Maintainership

Link Announcement Post Free Download MTA home page

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Installs, displays a grey box on start, occasionally the start-up image will display instead of this box.

What does not

Crashes on start.

Workarounds

What was not tested

Game functions could not be tested as it crashed on start.

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

I have tried the following solutions, in no particular order: -Installing DirectX files through Winetricks (No d3d9.dll in the SA folder however) -Installing allfonts through Winetricks -Running MTADiag (Through Wine, it updated MTA) -Deleting the gta_sa.set -Installing C++ 2010, 2008, and 2005 through Winetricks (However, I got an error at the end of one of their installations saying that a .dll file was not found) -Running Wine in Windows XP, Vista and 7 mode, as well as Virtual Desktop mode My specs are as follows: CPU: Intel i7 2600K (Overclocked @ 4.2GHz) GFX: NVIDIA GTX 560 Ti 1GB Motherboard: MSI Z68A-GD55 (B3) RAM: 8GB DDR3

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowMac OS X 10.10 "Yosemite"May 22 20151.7.43Yes Yes Goldan anonymous user 
ShowUbuntu 13.04 "Raring" amd64 (+ variants like Kubuntu)Apr 26 20131.5.29Yes No Garbagean anonymous user 
ShowArch Linux x86_64Oct 14 20121.5.25Yes Yes GoldDimitris Zervas 
ShowMac OS X 10.8 "Mountain Lion"Sep 12 20121.5.12Yes Yes Goldan anonymous user 
ShowUbuntu 13.04 "Raring" amd64 (+ variants like Kubuntu)Apr 27 20131.4.1Yes Yes Garbagean anonymous user 

Known Bugs

Bug # Description Status Resolution Other apps affected
34407 Multi Theft Auto 1.3 loader fails to initialize core infrastructure in GTA:SA process (msvcrt string collation check fails) CLOSED FIXED View

Show open bugs

Comments

Back