WineHQ

Microsoft Office (installer only)

Retail release January 29, 2013

This entry is just for testing the installer of Microsoft Office 2013 (aka Office 15) office suite.

Reports on specific programs included in Office 2013 should be submitted to their respective AppDB entries.

Office 2013 is available in 5 editions:

  • Home & Student (Retail, OEM)
  • Standard (Volume)
  • Home & Business (Retail, OEM)
  • Professional (Retail, OEM)
  • Professional Plus (Volume)
When reporting test results, please follow the Guidelines for Submitting Test Reports below (scroll down to notes section).

Application Details:

Version: 2013 (32 bit)
License: Retail
URL: http://www.office.com
Votes: 12
Latest Rating: Gold
Latest Wine Version Tested: 2.15

Maintainers: About Maintainership

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Everything (regarding the installer) !!!


ON A SIDE NOTE:
As for the software, one needs a directX 10 compatible graphic card and probably also this workaround (I needed it) to avoid a BLACK window, when firing up any of the Office applications:

Problem description:
https://forum.winehq.org/viewtopic.php?f=8&t=28446

And related bug:
https://bugs.winehq.org/show_bug.cgi?id=38648

I used this workaround:

REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\Direct3D]
"MaxVersionGL"=dword:00030002


What does not

--

Workarounds

What was not tested

--

Hardware tested

Graphics:

  • GPU:
  • Driver:
  • Additional Comments

    Using the trial version English (en-us) of Office Professional Plus 2013 downloaded from http://www.microsoft.com/de-de/evalcenter/evaluate-office-professional-plus-2013 And mount the img file OfficeProfessionalPlus_x86_en-us.img to /mnt/iso I installed office 2013 via these commands: mkdir -p /virt/wines/ms.office2013 WINEARCH=win32 WINEPREFIX=/virt/wines/ms.office2013/ winecfg # set Windows Version to "Windows 7" [*] WINEARCH=win32 WINEPREFIX=/virt/wines/ms.office2013/ wine /mnt/iso/setup.exe [*] OR RUN instead: WINEARCH=win32 WINEPREFIX=/virt/wines/ms.office2013/ winetricks settings win7 PLEASE NOTE, that if you install msxml6 (via winetricks), then the setup.exe starts and asks right away for a Product Key... but refuses to accept any valid product key !! ... simple workaround: Don't install msxml6 ;)

    selected in Test Results table below
    Operating systemTest dateWine versionInstalls?Runs?Used
    Workaround?
    RatingSubmitter
    ShowArch Linux x86_64Aug 24 20172.15Yes Yes YesGoldJason Cone 
    ShowArch Linux x86_64Feb 26 20172.2No Not installable GarbageMK 
    ShowArch Linux x86_64Feb 26 20172.2No Not installable GarbageMK 
    CurrentArch Linux x86_64Mar 24 20172.1Yes Yes PlatinumTormen 
    ShowArch Linux x86_64Feb 08 20172.1No Not installable GarbageAurélien 

    Known Bugs

    Bug # Description Status Resolution Other apps affected
    38648 Multiple games and applications need support for Mesa OpenGL >= 3.2 core profiles, Shader Model 4, GLSL 1.50 (Microsoft Office 2013 installer, .NET/XNA games) NEW View
    39810 Office 2010/2013/2016 Pro Plus uninstallation fails NEW View
    43581 Office 2013 365 installer: Something went wrong NEW View

    Show all bugs

    HowTo / Notes

    Guidelines for Submitting Test Reports
    1. Test in a clean wineprefix, using plain Wine. 
    2. Specify exactly which edition of Office 2013 you tested (Standard, Pro, etc.). This is crucial--bugs that affect one edition may not affect others.
    3. Specify exactly what type of ­install you tested (Typical, Custom, Minimal, etc.)
    4. Limit your report to the installer only. Reports on the performance of individual apps should be filed under their respective AppDB entries. Problems with running any of the apps should only be mentioned if it is clear that it is due to a problem with the installer.
    5. If you used any overrides during the install, please list them and explain exactly what problem each override was needed to solve.
    6. Test reports that do not follow these guidelines will be rejected. ­

    Guidelines for Submitting Test Reports

     

    1. Test in a clean wineprefix, using plain Wine. 
    2. Specify exactly which edition of Office you tested (Standard, Pro, etc.). This is crucial--bugs that affect one edition may not affect others.
    3. Specify exactly what type of install you tested (Typical, Custom, Minimal, etc.)
    4. Limit your report to the installer only. Reports on the performance of individual apps should be filed under their respective AppDB entries. Problems with running any of the apps should only be mentioned if it is clear that it is due to a problem with the installer.
    5. If you used any overrides during the install, please list them and explain exactly what problem each override was needed to solve.
    6. Test reports that do not follow these guidelines will be rejected.

    Comments

    The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

    Really strange problem: With msxml6 installed, no product key works anymore!
    by Tormen on Friday March 24th 2017, 13:39
    Hi,

    It seems really bizzarre, but I tried it several times:

    With the trial version (both German (de-de) and English (en-us)) downloaded from
    www.microsoft.com/de-de/evalcenter/evaluate-office-professional-plus-2013
    And mount the img file OfficeProfessionalPlus_x86_en-us.img to /mnt/iso.

    When I create a fresh WINEPREFIX, set it to win7 and then install winetricks msxml6 and then run the setup, like so:

    mkdir -p /virt/wines/ms.office2013
    WINEARCH=win32 WINEPREFIX=/virt/wines/ms.office2013/ winetricks settings win7
    WINEARCH=win32 WINEPREFIX=/virt/wines/ms.office2013/ winetricks msxml6
    WINEARCH=win32 WINEPREFIX=/virt/wines/ms.office2013/ wine /mnt/iso/setup.exe

    The behaviour of the setup changes!

    It starts with first asking you to enter a product key.
    And no matter what product key I entered, they all never worked (even though they should).

    Without installing the msxml6, I saw a bunch of xml related messages in the output when launcching the setup, but in this case the setup right away offers to configure and install ms office!

    Is that logical that with the msxml6 installed, this would then actually /break/ something ?
    If helpful, I could provide debug output and/or file a bug report.

    Thanks a lot in advance for any feedback!

    Tormen
    Back