WineHQ

Microsoft Office (installer only)

Retail release January 29, 2013

This entry is just for testing the installer of Microsoft Office 2013 (aka Office 15) office suite.

Reports on specific programs included in Office 2013 should be submitted to their respective AppDB entries.

Office 2013 is available in 5 editions:

  • Home & Student (Retail, OEM)
  • Standard (Volume)
  • Home & Business (Retail, OEM)
  • Professional (Retail, OEM)
  • Professional Plus (Volume)
When reporting test results, please follow the Guidelines for Submitting Test Reports below (scroll down to notes section).

Application Details:

Version: 2013 (32 bit)
License: Retail
URL: http://www.office.com
Votes: 12
Latest Rating: Gold
Latest Wine Version Tested: 2.15

Maintainers: About Maintainership

Test Results

Selected Test Results

What works

Everything, once wine config work-around is in place (q.v.)

What does not

Installer presented some blank (white) dialogs near the end of the installation. The problem is corrected with regedit (see workarounds).

Workarounds

Some installer dialogs showed up as blank (white, in my case, although I've heard others report a similar "black screen" problem). Using regedit to add the following solved the problem:


[HKEY_CURRENT_USER\Software\Wine\Direct3D]
"MaxVersionGL"=dword:00030002

What was not tested

Uninstall

Hardware tested

Graphics:

  • GPU:
  • Driver:
  • Additional Comments

    I installed Microsoft Office Home and Student 2013 (Retail). I used a 32-bit wine arch configured as Windows 7, and with dotnet40 and msxml6 installed through winetricks.

    selected in Test Results table below
    Operating systemTest dateWine versionInstalls?Runs?Used
    Workaround?
    RatingSubmitter
    CurrentArch Linux x86_64Aug 24 20172.15Yes Yes YesGoldJason Cone 
    ShowArch Linux x86_64Feb 26 20172.2No Not installable GarbageMK 
    ShowArch Linux x86_64Feb 26 20172.2No Not installable GarbageMK 
    ShowArch Linux x86_64Mar 24 20172.1Yes Yes PlatinumTormen 
    ShowArch Linux x86_64Feb 08 20172.1No Not installable GarbageAurélien 

    Known Bugs

    Bug # Description Status Resolution Other apps affected
    31349 Office 365 (Office 2013) web installer aborts early (needs support for string alias for common RID in sid strings) CLOSED FIXED View
    31468 Office 2013 installer crashes with a "serious problem" error CLOSED DUPLICATE View
    31487 kernel32.dll.InitOnceExecuteOnce needed for several MS installer (Office2013 / Windows Essentials 2012 / .NET Framework 4.5 / Skydrive / ARM Applications) CLOSED FIXED View
    34869 Microsoft Office 2013 full offline installer crashes on startup (TEB access with NULL TLS array pointer, failure to handle case where only late-bound modules have TLS directory) CLOSED FIXED View
    35342 Office 2013 full offline install setup crash at startup CLOSED FIXED View
    36092 Microsoft Office 2013 (15.0) and OneNote web installer crashes on unimplemented function IPHLPAPI.DLL.CreateSortedAddressPairs CLOSED FIXED View
    38648 Multiple games and applications need support for Mesa OpenGL >= 3.2 core profiles, Shader Model 4, GLSL 1.50 (Microsoft Office 2013 installer, .NET/XNA games) NEW View
    39810 Office 2010/2013/2016 Pro Plus uninstallation fails NEW View
    43581 Office 2013 365 installer: Something went wrong NEW View

    Show open bugs

    HowTo / Notes

    Guidelines for Submitting Test Reports
    1. Test in a clean wineprefix, using plain Wine. 
    2. Specify exactly which edition of Office 2013 you tested (Standard, Pro, etc.). This is crucial--bugs that affect one edition may not affect others.
    3. Specify exactly what type of ­install you tested (Typical, Custom, Minimal, etc.)
    4. Limit your report to the installer only. Reports on the performance of individual apps should be filed under their respective AppDB entries. Problems with running any of the apps should only be mentioned if it is clear that it is due to a problem with the installer.
    5. If you used any overrides during the install, please list them and explain exactly what problem each override was needed to solve.
    6. Test reports that do not follow these guidelines will be rejected. ­

    Guidelines for Submitting Test Reports

     

    1. Test in a clean wineprefix, using plain Wine. 
    2. Specify exactly which edition of Office you tested (Standard, Pro, etc.). This is crucial--bugs that affect one edition may not affect others.
    3. Specify exactly what type of install you tested (Typical, Custom, Minimal, etc.)
    4. Limit your report to the installer only. Reports on the performance of individual apps should be filed under their respective AppDB entries. Problems with running any of the apps should only be mentioned if it is clear that it is due to a problem with the installer.
    5. If you used any overrides during the install, please list them and explain exactly what problem each override was needed to solve.
    6. Test reports that do not follow these guidelines will be rejected.

    Comments

    The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

    Really strange problem: With msxml6 installed, no product key works anymore!
    by Tormen on Friday March 24th 2017, 13:39
    Hi,

    It seems really bizzarre, but I tried it several times:

    With the trial version (both German (de-de) and English (en-us)) downloaded from
    www.microsoft.com/de-de/evalcenter/evaluate-office-professional-plus-2013
    And mount the img file OfficeProfessionalPlus_x86_en-us.img to /mnt/iso.

    When I create a fresh WINEPREFIX, set it to win7 and then install winetricks msxml6 and then run the setup, like so:

    mkdir -p /virt/wines/ms.office2013
    WINEARCH=win32 WINEPREFIX=/virt/wines/ms.office2013/ winetricks settings win7
    WINEARCH=win32 WINEPREFIX=/virt/wines/ms.office2013/ winetricks msxml6
    WINEARCH=win32 WINEPREFIX=/virt/wines/ms.office2013/ wine /mnt/iso/setup.exe

    The behaviour of the setup changes!

    It starts with first asking you to enter a product key.
    And no matter what product key I entered, they all never worked (even though they should).

    Without installing the msxml6, I saw a bunch of xml related messages in the output when launcching the setup, but in this case the setup right away offers to configure and install ms office!

    Is that logical that with the msxml6 installed, this would then actually /break/ something ?
    If helpful, I could provide debug output and/or file a bug report.

    Thanks a lot in advance for any feedback!

    Tormen
    Back