WineHQ

SolidWorks

No Screenshot

Submit Screenshot
SolidWorks 2012

Application Details:

Version: 2012
License: Retail
URL: http://www.solidworks.com
Votes: 1
Latest Rating: Garbage
Latest Wine Version Tested: 1.6-rc2

Maintainers: About Maintainership

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Installer (with some tricks), program run

What does not

all other things

Workarounds

What was not tested

create|open file

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

Installs with these tricks: 0. create a clean wineprefix 1. winetricks vcrun6 vcrun2003 vcrun2005 vcrun2008 vcrun2010 2. winetricks msxml3 3. winetricks dotnet35 despite the fact that the installer will tell about the impossibility of setting dotnet35 should fulfill all the requirements (download all the files that will be offered) 4. Try to install [SW_drive]/prereqs/vsta_aide.msi ; If installer was crashed, simply ignore this, run wineboot and wait for post-wineboot autoruns will completed. 5. winetricks ie8 6. Run a SolidWorks installer: wine [SW_drive]/swwi/data/setup.exe

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowUbuntu 13.04 "Raring" amd64 (+ variants like Kubuntu)Jun 24 20131.6-rc2No, but has workaround Yes Garbageveger 
ShowFedora 17 x86_64Aug 18 20121.5.11No Not installable GarbageNSLW 
CurrentDebian GNU/Linux 7.x "Wheezy" x86_64Feb 25 20141.4.1Yes Yes Goldfeeker 

Known Bugs

Bug # Description Status Resolution Other apps affected
12458 Multiple apps fail due to RichEdit ITextDocument_fnRange stub (MySQL Workbench, BlitzMaxDemo137) CLOSED FIXED View
25936 SolidWorks 2010: sldim.exe shows blank window UNCONFIRMED View
31056 .NET Framework 3.x/4.x WPF Media Integration Layer deadlocks between ui and render thread when calling SetPixelFormat CLOSED FIXED View
31486 SolidWorks 2012: sldim crashes UNCONFIRMED View
31652 .NET Framework Setup Verification Tool stopped working with dotnet20sp1 CLOSED FIXED View
31710 Regression Error - OpenGL display blanked out with grey rectangle CLOSED FIXED View
31724 SolidWorks Explorer 2012 fails to install, reporting 'Could not get typeinfo of hreftype 384 for VT_USERDEFINED, hr = 0x80004005' CLOSED FIXED View

Show open bugs

Comments

Back