WineHQ

Euro Truck Simulator 2

Application Details:

Version: 1.x
License: Retail
URL: http://www.eurotrucksimulator2...
Votes: 3
Latest Rating: Platinum
Latest Wine Version Tested: 1.6.2

Maintainers: About Maintainership

Test Results

Old test results
The test results for this version are very old, and as such they may not represent the current state of Wine. Please consider submitting a new test report.
Selected Test Results

What works

Gameplay

Sound Effects

Music

What does not

Nothing Tested

Workarounds

What was not tested

Controller support

wheel support

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
CurrentUbuntu 16.04 "Xenial" amd64 (+ variants like Kubuntu)Mar 04 20171.6.2Yes Yes PlatinumKyle B 
ShowUbuntu 15.04 "Vivid" amd64 (+ variants like Kubuntu)Aug 17 20151.6.2Yes Yes Goldan anonymous user 
ShowUbuntu 14.04 "Trusty" amd64 (+ variants like Kubuntu)Aug 17 20141.6.2Yes Yes Platinuman anonymous user 
ShowMac OS X 10.9 "Mavericks"Dec 06 20131.7.7Yes Yes Platinuman anonymous user 
ShowUbuntu 13.04 "Raring" amd64 (+ variants like Kubuntu)Aug 19 20131.6Yes Yes Platinuman anonymous user 

Known Bugs

Bug # Description Status Resolution Other apps affected
32771 Euro Truck Simulator 2 in-game radio does not work UNCONFIRMED View
36883 Euro Truck Simulator 2: Game crashes after logo screen. UNCONFIRMED View

Show all bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

Internet radio issues
by dhasenan on Saturday August 30th 2014, 10:44
The internet radio integration isn't working for me. I've confirmed that I can connect to the URLs listed in the config file ("Euro Truck Simulator 2/live_streams.sii"), but when I enable a stream and double-click on it to start it playing, I see a loading indicator and nothing else. When I check off two of them, it highlights one for a few moments, then switches to the next, then switches to the first, repeat.

I tried installing another codec to replace the builtin wine mp3 codec, but that had no noticeable effect.

I tried to run the application with WINEDEBUG=all, but this didn't work; the application appears to fork and exit very quickly.
Back