WineHQ

SimCity 2013

No Screenshot

Submit Screenshot

The Version sold through Origin.

SimCity is updated automatically, so it makes no sense to maintain separate versions.

Application Details:

Version: Latest
License: Retail
URL: http://www.simcity.com/
Votes: 5
Latest Rating: Platinum
Latest Wine Version Tested: 3.0.3

Maintainers: About Maintainership

Free Download (Time-limited) free trial version

Test Results

Old test results
The test results for this version are very old, and as such they may not represent the current state of Wine. Please consider submitting a new test report.
Selected Test Results

What works

Sound, graphics

What does not

Workarounds

What was not tested

Didn't finish the whole game (was still in the tutorial)

Hardware tested

Graphics:

  • GPU: Nvidia
  • Driver: proprietary

Additional Comments

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
CurrentUnknownSep 23 20183.0.3Yes Yes NoPlatinumWin 
ShowUbuntu 18.04 "Bionic" amd64 (+variants like Kubuntu)Sep 02 20183.0.2Yes Yes NoPlatinumAkati 
ShowFedora 28 x86_64Jul 01 20183.11-stagingYes Yes NoPlatinumDesperalaw 
ShowFedora 26 x86_64Jul 30 20172.13-stagingYes Yes GoldDesperalaw 
ShowUbuntu 16.04 "Xenial" amd64 (+ variants like Kubuntu)Jul 16 20161.9.12Yes Yes GoldBloodyIron 

Known Bugs

Bug # Description Status Resolution Other apps affected
33141 Problem to start SimCity 2013 UNCONFIRMED View
33159 Loading a .dll without relocations fails under Mac OS X (needs preloader) STAGED View
38331 Graphical glitch in Simcity 2013 UNCONFIRMED View

Show all bugs

HowTo / Notes

HOWTO download and install the game with Origin
  1. Download and install Origin:

    cd ~
    wget download.dm.origin.com/origin/live/OriginSetup.exe
    wine OriginSetup.exe

    ... and follow the graphical Origin installer process.

  2. Do not login, yet.

    Just click away the login window.

  3. Only for wine version 1.7.34 or older: Patch Origin's Qt5Network.dll to buffer the QTcpSocket again

    This is needed for a smooth download. Otherwise the download rate will drop to zero within a few seconds, or even hang on "Preparing ...". See bug #31438, which was fixed in wine 1.7.35.
    Use the python patch script from this bug report (first it makes a backup of the dll, then patches one byte in it, and finally shows the files' md5sum).

    cd ~
    wget -O patch_qt5network_wine.py https://bugs.winehq.org/attachment.cgi?id=49988
    chmod +x patch_qt5network_wine.py
    cd ~/.wine/drive_c/Program\ Files/Origin/
    ~/patch_qt5network_wine.py

    Above commands download the python patch script to your home directory, make it executable and then execute it in the correct folder. In case the lines are wrapped on your display: the lines start with "cd", "wget", "chmod", "cd" and the last line with "~/patch_qt5network_wine.py".

    This script is quite flexible in finding the correct byte to patch, even if Origin comes with a new version of the dll. If it fails anyway check the bug report for news.

  4. Start Origin:

    cd ~/.wine/drive_c/Program\ Files/Origin
    wine Origin.exe

    ... and download & install SimCity in there.

  5. Force the installation to finish:

    If the SimCity installer gets stuck after downloading on "Installing..." for more than 5 minutes do a

    killall EAProxyInstaller.exe

    See bug #33723 (this symptom was described in its duplicate #29876).

  6. Disable Origin in Game:

    Otherwise SimCity.exe will crash shortly after starting it.

    In the Origin window go to "Origin - Application Settings - Origin In Game" and untick "Enable Origin In Game".
    (In the past it was recommended to remove IGO32.dll instead. But this doesn't work anymore.)

    See bugs #36863, #33141 and probably more (TODO).

  7. Start SimCity in Origin:

    cd ~/.wine/drive_c/Program\ Files/Origin
    wine Origin.exe

    In Origin hover over SimCity and click "Play".

Troubleshooting

  • If SimCity freezes in fullscreen and you can't get back to your desktop hit "Control" + "Alt" + "F1", this will bring you to a text terminal. There login and type:

     killall SimCity.exe
    After that get back to your graphical session by hitting "Control" + "Alt" + "F7" (or sometimes "F8"). This might be necessary e.g. with Intel graphics and a broken driver, see bug #37475.

  • If you started the game, can hear the sounds of the intro, but the actual SimCity game is not visible, then try to bring it to the foreground by cycling through your windows with "Alt" + "Tab" several times. If this doesn't work, quit everything, start winecfg, choose the "Graphics" rider and select "Emulate a virtual desktop" (choose a resolution just a littlebit smaller than your display's resolution). Then start SimCity again.

  • If you get an error message in the login prompt of Origin that the EA servers are currently not available, enable the insecure GTE CyberTrust Global Root certificate. (See bug #35828). Note that this certificate is not secure because its key length is only 1024 bits. Check in /etc/ca-certificates.conf which certificates are installed.
    Check your distribution's help to learn how to enable this cerificate. E.g. in Debian do a

    sudo dpkg-reconfigure ca-certificates
    ... and check the "mozilla/GTE_CyberTrust_Global_Root.crt".

  • Origin is not aware of what is happening in SimCity.

    After quitting SimCity it will complain that it is still running. Further the "Last Played" is not updated. Just ignore it. Or use a patched version of wine, see bug #33723.

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

Won't start
by Alex on Friday February 27th 2015, 15:45
Im using wine 1.7.34 and im getting "Origin has encountered a serious problem and must close" error. I dont know what im doing wrong because I see that other people got it to run.
RE: Won't start
by jre on Friday February 27th 2015, 16:42
Have you disabled "Origin in Game (IGO)"? See Howto.
Webkit DLL file not found
by Alex on Thursday March 5th 2015, 11:33
Okay now I fixed that error... and then tried in fullscreen but the I got a black screen in the upper left hand corner with a mouse and nothing. Tried cycling alt tab and did nothing. So then I saw that in order to get it to work sometimes you have to enable a virtual desktop. When I did that now I am getting an error about Webkit DLL not being found.
RE: Webkit DLL file not found
by Alex on Thursday March 5th 2015, 12:22
I just kept closing and re-opening the game and it eventually started to run without this error. Kinda a fluke.
Re: Won't start
by jre on Thursday March 5th 2015, 17:52
Alex wrote:
> I got a black screen in the upper left hand corner with a mouse
> and nothing.

That's what I also experience currently some/many/most times I start SimCity. So I just try again and sometimes it will work. I'm still investigating if this only happens with newer wine versions, since it worked flawlessly in the past. At least Wine versions 1.7.32 - 1.7.37 are affected.
I'm running Debian Jessie/amd64, Intel Core i7-3517U, 1,9 GHz, 8GB RAM, Intel HD 4000, i915 --> so it may be related to Intel i915 graphics.

IIRC I've also seen the webkit message, but this happened really seldom.
Ground?
by Alex on Friday February 27th 2015, 15:13
Is there a reason why the ground is not being shown? Is it possible for someone to write a patch or something to get it to come back?
RE: Ground?
by jre on Friday February 27th 2015, 16:51
Of course there is a reason, but nobody knows which it is ;)

So far this happens for some people only, AFAIK all had a NVIDIA card. Here it works. (Or at least did until ~1.7.32, currently it doesn't start anymore. I have to investigate that more.)

Nobody filed a bug so far or came up with a workaround or patch. So the best to do is to file a bug, see wiki.winehq.org/Bugs. If you have a NVIDIA card you should add this as a hint.
RE: Ground?
by Alex on Thursday March 5th 2015, 12:22
So i just finally got this working. Using wine 1.7.37 I first had problems with it running in fullscreen. So I went into winecfg and emulated desktop. Then I went into the game settings and unticked fullscreen then ticked borderless window. This results in a fullscreen game.
Then lo and behold I have ground. Water. Trees.
postimg.org/image/688e3yh7j/
My laptop is using the i915 driver BUT i am using a PPA.
launchpad.net/~oibaf/+archive/ubuntu/graphics-driveros
When I did the system upgrade, i noticed some packages were being held back. I forced an upgrade on those packages.
Unable to launch Simcity
by oipunx on Monday October 27th 2014, 17:59
I'm having problem starting Simcity. I followed the instructions here and was able to install Origin and the game just fine, but when I try to start the game from Origin using my origin account, it popups a message saying:

"We're sorry, an error has occurred
We are unable to connect to EA servers to activate Simcity on this computer using your account. Please try again later."

I have tried to installed samba and winbind but that didnt fix the problem. I also disabled iptables but it still says the same thing (I can log into Origin just fine). I can connect and play the game on my windows drive so I'm not really sure what the problem is. I can play other online games such as Starcraft 2 in wine. Any help would be appreciated.

Thanks!
RE: Unable to launch Simcity
by oipunx on Tuesday October 28th 2014, 12:16
I also enabled the insecure GTE CyberTrust Global Root certificate but that it still didnt work.
RE: Unable to launch Simcity
by jre on Wednesday October 29th 2014, 12:23
Works for me, see my recent test with wine 1.7.29 (but worked in the past with every other wine version, too.)

1.) Do you use a proxy?
2.) Is wine configured as WinXP?
3.) Verify with "iptables -L" that really everything is allowed ("deactivate iptables" sounds strange to me.)
RE: Unable to launch Simcity
by oipunx on Monday November 3rd 2014, 19:23
Hey thanks for looking into it. I got it working by reinstalling wine-development from debian. Before, I was using the old wine (1.6.x) so that might be why it didnt work; I dont know exactly what was wrong with 1.6 though because I followed the same procedures/instructions.

Currently it runs and I was able to play but the graphic texture is still buggy (see screenshot postimg.org/image/vamf3i48p/ ). The trees, roads, and cars are all discolored (they're a mix of purple/white/green). I have the latest nvidia driver for my GTX680 installed and I tried increase/decrease the graphic quality in the setting but that didnt help. I'm using Debian Wheezy with latest drivers and wine-dev.
RE: Unable to launch Simcity
by jre on Wednesday November 5th 2014, 9:29
It did work here with wine 1.6.2. I assume this was a temporary error out of your reach.

About the graphic texture: no idea, indeed probably NVIDIA related.
There have been some texture related changes in 1.7.30.
Please keep us posted about your findings.
RE: Unable to launch Simcity
by jre on Monday November 10th 2014, 15:45
Now I'm experiencing the same issue when installing with playonlinux, wine 1.7.30 (no matter if I do exactly the same there as in the HOWTO here; or if I add wininet, vcrun2010, vcrun2008 and vcrun2005).

At the same time doing a "regular" install in a terminal with wine 1.6.2 or 1.7.30 works.
Install patch works, almost loads but cant find a dll?
by Larry on Monday September 22nd 2014, 9:27
SimCity could not find the EA WebKit DLL
SimCity will now exit [4000]


Did the patch for the network, killed EAproxy to finish the install.

Web searches suggest using Wine 1.5.20 with PlayOnLinux, but using PlayOnLinux simply has the install problem again. Running Ubuntu 14.04 and Wine 1.7.26
RE: Install patch works, almost loads but cant find a dll?
by jre on Wednesday October 29th 2014, 15:57
Did you install SimCity manually in PlayOnLinux, or did you use the script from www.playonlinux.com/en/topic-10792-Script_SimCity_2013.html?
No ground
by HubertNNN on Saturday September 7th 2013, 7:27
I dont have ground textures, game looks like in this windows bug: orcz.com/SimCity:_Stuck_on_Grid_View_instead_of_Land_View
I tried reinstalling game 3 times like said there. I also installed game on windows, tested (ground was ok) and moved the folder to my wine directory, and nothing. Did anyone found a solution for that?
RE: No ground
by Tyrel on Sunday November 10th 2013, 16:10
I have the exact same issue here. I've reinstalled with no change. Everything appears to be working perfectly, except there's no ground, water, etc. This makes it rather difficult to use because I can't tell where hills are, water is, etc.
RE: No ground
by Alex on Thursday March 5th 2015, 12:26
See my post above. I don't know what GPU you have but I was having performance problems in my games until i added a PPA and upgraded the packages. Could also been resolved in the newer wine versions but i wouldn't know because I didn't test before upgrading my graphics packages.
Back