WineHQ

iTunes

Application Details:

Version: 11.x
License: Free to use
URL: http://iTunes.com
Votes: Marked as obsolete
Latest Rating: Garbage
Latest Wine Version Tested: 1.7.36

Maintainers: About Maintainership

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Installation finalises (however, there are popup messages saying that burn CD will not be enabled).

What does not

Once it runs, there are no visible or available buttons apart from the main menu. Clicking the main menu only allowes to exit the iTunes as the rest of the options are in grey and not clickable.

Workarounds

What was not tested

I couldn't test any functionality as the only function available was to exit the software.

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

I used playonLinux as front-end.

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowArch Linux x86_64Feb 08 20151.7.36Yes No GarbageHugo Osvaldo Barrera 
ShowUbuntu 14.04 "Trusty" i386 (+ variants like Kubuntu)Aug 15 20141.7.22Yes Yes SilverDaAwesomeP 
ShowFedora 20 x86_64Aug 12 20141.7.22Yes Yes Garbagean anonymous user 
ShowSlackware64 14.1May 21 20141.7.19Yes Yes BronzeGeremia 
ShowFedora 19 x86_64Apr 03 20141.7.15Yes Yes Goldan anonymous user 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

itunes 11
by Robby on Saturday December 14th 2013, 18:04
I tried installing this, it seemed to install ok. I tried to open it, I got the "did not install properly, if you want to burn cd's you will need to reinstall" error. I click ok, a blank itunes window opens up. And that is all, nothing just an empty window.

Does anyone have any ideas?
Error "iTunes needs vista to continue" even though I've set it to run as 7.
by Craig Wessel on Monday June 24th 2013, 11:47
Every time I try to run iTunes installer it returns with "Error iTunes needs vista to continue." I have set the installer to run as 7 in Wine Config. Any idea? Using Manjaro Linux.
cpu usage
by adamski on Thursday June 20th 2013, 16:42
hi,

so seems to work faily well except for itunes store...

i had to remove distnoted.exe and uninstall applemobiledevice crap as it kept spawning lots of instances of these.

also it consumes 100% of 1 cpu core, does everyone else get this too?

any workaround for this


cheers

adam
RE: cpu usage
by Dietmar Malli on Friday June 21st 2013, 8:34
Do you start it with that command:

env WINEPREFIX="~/.wine" taskset -c 1 wine C:\\Program\ Files\\iTunes\\iTunes.exe

"taskset -c 1" limits it to 1 core... This was done in order to fix issues with too fast playback...

NOTE: It seems that actual wine versions (about 1.5+) don't need that fix any more.. You can start it normally and run it on multiple cores... (At least for me this is working now)

Greetings
Dietmar Malli
RE: cpu usage
by adamski on Monday June 24th 2013, 13:43
hi,
yeah ive tried running it with that command and the usual one, both result in 100% cpu on 1core

i also get a huge (500ms - 1s) audio latency. Any way to get rid of this?

cheers

adam
RE: cpu usage
by Dietmar Malli on Monday June 24th 2013, 14:03
The 100% on one core are normal.. At least if you run it with that command... With the usual command one core is also more stressed than the other one...

The audio latency could occure, because of high latencys of underlieing streams.. Have you got a windows environment to test that with nearly the same circumstances? Or.. With other words.. I get high latencys too, if I try to stream music over Wifi :/

Also: Have you tried using the most recent wine version?
RE: cpu usage
by adamski on Tuesday June 25th 2013, 11:43
no the latency is definatelly due to wine, the lag is between itunes volume control and speaker, around 500ms, music on the local hard drive. never had this on windows.

not too big an issue anyway, i just wondered if it was a known problem or no.

cheers,

adam
RE: iTunes store
by Dr. Wes Snyder V on Tuesday July 16th 2013, 21:27
Hello,

I receive a crash error when trying to access iTunes store. This expected? I cannot play some songs as they are DRM (from long ago before Apple provided non-DRM). Any suggestions? Playing other songs works fine. I also cannot see my iPhone to transfer songs around, again the DRM ones. I can transfer the songs with Rhapsody that are not DRM.

by Antonio on Wednesday June 12th 2013, 12:41
iTunes will not recognize my iphone when I plug it into my computer via USB.
iTunes
by Antonio on Tuesday June 11th 2013, 18:32
The installation seemed to have been successful but when I open itunes i get an error saying "Itunes was not properly installed. If you wish to import or burn CD's you need to reinstall iTunes.
RE: iTunes
by Dietmar Malli on Tuesday June 25th 2013, 13:45
I get the same error message.. Just ignore it. It's working.. Just importing or burning CD's doesn't work... :/
Fix Graphics Bug
by Dietmar Malli on Saturday June 8th 2013, 14:11
With the old version 1.4.1 from standard Ubuntu, I had black areas around dialogues/menus. (eg. the one when you click on the arrow next to a song in a playlist.)
Upgrading to actual wine (1.5.31 in my case) helped. You can do so, by adding the wine repository. See:
www.winehq.org/download/ubuntu
AirPlay working?
by Andrew Salkeld on Saturday March 16th 2013, 5:31
Hi,
Have an Apple TV and an Ubuntu 12.10 box, wondering if the video streaming feature still works. Thanks!
This works
by Ian M. on Sunday February 3rd 2013, 14:42
I am using wine 1.5.22 with a 32bit bottle and latest itunes(32bit) downloaded directly from Apple. When opening It complains about needing to reinstall itunes if you want to burn discs, which I do not care about, but it still allows you to get into itunes. All buttons work, start, stop and volume slider as well as all menus. Music plays fairly well and distnoted.exe has a bug where it will open like 10-20 of itself and use like 40% each of my cpu, which causes audio to stutter, and the ui to lag, so I killed all of them but it comes back once you open itunes again. So that is one memory leak that will cause your computer to lag like heck. I also tried getting into the settings which caused itunes to freeze up and stop responding, so its not going to be perfect but I'm surprised at how well it works overall.

Pic:
dl.dropbox.com/u/38348368/Screenshot%20from%202013-02-03%2014%3A07%3A13.png
similar results
by Stephanie Daugherty on Monday January 28th 2013, 9:28
similar results with a 32bit install under Sabayon with wine 1.5.21, tried with and without WINE_ARCH as win32 to see if it might have just been the 64bit version, same problem.

No text or icons in the window, and if you manage to find and click on the menu button, all menu options are disabled. Clicking the X (if you can find it - it's roughly where it should be, but not shown on screen), will close the window.
Back