WineHQ

Grim Dawn

No Screenshot

Submit Screenshot
Full release, latest patch.

Application Details:

Version: 1.0.0.7
License: Retail
URL: http://www.grimdawn.com/â€...
Votes: 3
Latest Rating: Gold
Latest Wine Version Tested: 2.0

Maintainers: About Maintainership

Test Results

Old test results
The test results for this version are very old, and as such they may not represent the current state of Wine. Please consider submitting a new test report.
Selected Test Results

What works

Everything worked grea.

What does not

Nothing

Workarounds

What was not tested

Nothing

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

I'm on a Macbook Pro 15 2016 with Radeon Pro 455. This game detected my GPU as Radeon Pro 460, but it's ok. **Need editing some in the registry, without this step this game will launch and can reach the menu, doing some settings changes etc but cant load to game.** You must add these: [HKEY_CURRENT_USER\Software\Wine\DllOverrides] "*msvcp140"="native" "*msvcr140"="native" "*ucrtbase"="native" "*vcruntime140"="native" "*vcomp140"="native" "*api-ms-win-crt-conio-l1-1-0"="native" "*api-ms-win-crt-heap-l1-1-0"="native" "*api-ms-win-crt-locale-l1-1-0"="native" "*api-ms-win-crt-math-l1-1-0"="native" "*api-ms-win-crt-runtime-l1-1-0"="native" "*api-ms-win-crt-stdio-l1-1-0"="native" "*api-ms-win-crt-convert-l1-1-0"="native" "*api-ms-win-crt-environment-l1-1-0"="native" "*api-ms-win-crt-filesystem-l1-1-0"="native" "*api-ms-win-crt-multibyte-l1-1-0"="native" "*api-ms-win-crt-private-l1-1-0"="native" "*api-ms-win-crt-process-l1-1-0"="native" "*api-ms-win-crt-string-l1-1-0"="native" "*api-ms-win-crt-time-l1-1-0"="native" "*api-ms-win-crt-utility-l1-1-0"="native" And staging option for enabling "CSMT" will make graphics glitch.

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
CurrentmacOS 10.12 "Sierra"Jan 28 20172.0Yes Yes Goldfireedo 
ShowArch Linux x86_64Mar 30 20161.9.6Yes Yes GoldeNTi 
ShowArch Linux x86_64Mar 29 20161.9.6N/A No GarbageeNTi 
ShowArch Linux x86_64Mar 02 20161.9.4Yes Yes GoldGloriousEggroll 
ShowUbuntu 15.10 "Wily" i386 (+ variants like Kubuntu)Feb 25 20161.9.4Yes Yes GoldTyler Fru 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

HowTo / Notes

[OLD] Characters partially invisible

Sometimes wher you launch the game, all characters and some other objects are partially o fully invisible.

There is no permanent solution for this moment (03.04.2017).

But this behavior not hapening every time, so you need to restart game 3-6 times.

Enabling anisotropic-filtering in video settings also helps to incresing chance of successful launch.

Also in my opinion, this problem happening less often with wine-staging, but this need to be proofed.


Added (23.09.2017):

If u use wine>2.6, setting REG flag 

HKCU/Software/Wine/Direct3D/CheckFloatConstants

to "enabled" can solve this. For me it bring no changes, but maybe u will be more lucky.

Thx @Fincer for info.


Performance

Enabling CSMT in wine-staging incress FPS near 30%.

Also u can try this:

Settings within options.txt:

maxResourceThreads = 16 

I did set it to 16 which is the amount of aviable Cores on a R7 1700X, Intel-Users did set this to lower settings then their max. amount of Cores which had something to do with Hyperthreading. Settings this to max. on Intel caused lower performance, i didnt see any performance-differences on my CPU. It significantly improved raising this value is all i recognised, it didnt seem to change performance after a specific point. 

Furter Performance-Improvements can be to set your Refresh-Rate to 60Hz with VSync enabled to work as a FPS-Limiter, the CPU is heavily bottlenecking within this game and lowering the CPU-Load via lower Graphic-Settings can help reducing some of the Lag-Spikes. CSMT-Enabled within Wine-Staging gives you a significant performance-boost. With the command cpuset you can improve the performance of the game further by disabling the first cpu-core. cpuset -l 2-15 -p (pid of the game).

Thx @SF for info

Steam version install software-requirements on every launch

In some environments when u launch game throuth steam, it try to install "requested" software (directx, vcredist etc) each time.

For solving this:

1. Open your wine prefix

2. Navigate to 'drive_c/Program Files/Steam/steamapps/common/Grim Dawn/_CommonRedist'

3. This folder contains subfolders like 'DotNet', 'DirectX', etc. Open every folder and find file 'installscript.vdf'

4. Rename or delete this file.

Changing localization (for old versions).

Game allow to change language via settings. After you select lang, it try to download translation-package.

But in wine this operation never ended succesfuly. This problem fixed in 1.0.0.9.x minor patch, but not listed in changelog.

For solving this:

0. Try to change lang in settings (other lang > select > download).

1. Open this official sub-forum.

2. Find your lang and download translation-package.

3. Open your wine prefix and navigate to 'Grim Dawn/localization'.

4. This folder must contain *.zip file, but it broken. We need only name of this file.

5. Copy downloaded package here and rename it with name from previous step. Old file must be removed.

[OLD] How to install VCRedist 2015 (old wine versions)

If u have problems with launching, like "Microsoft Visual C++ Runtime Error" errors, try this.

After installing vcredist2015, create new '*.reg' file, that contains:

Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Wine\DllOverrides]
"*msvcp140"="native"
"*msvcr140"="native"
"*ucrtbase"="native"
"*vcruntime140"="native"
"*vcomp140"="native"
"*api-ms-win-crt-conio-l1-1-0"="native"
"*api-ms-win-crt-heap-l1-1-0"="native"
"*api-ms-win-crt-locale-l1-1-0"="native"
"*api-ms-win-crt-math-l1-1-0"="native"
"*api-ms-win-crt-runtime-l1-1-0"="native"
"*api-ms-win-crt-stdio-l1-1-0"="native"
"*api-ms-win-crt-convert-l1-1-0"="native"
"*api-ms-win-crt-environment-l1-1-0"="native"
"*api-ms-win-crt-filesystem-l1-1-0"="native"
"*api-ms-win-crt-multibyte-l1-1-0"="native"
"*api-ms-win-crt-private-l1-1-0"="native"
"*api-ms-win-crt-process-l1-1-0"="native"
"*api-ms-win-crt-string-l1-1-0"="native"
"*api-ms-win-crt-time-l1-1-0"="native"
"*api-ms-win-crt-utility-l1-1-0"="native"

and import this to registry of your wine prefix.

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

Mouse can't move
by Avenue on Monday May 20th 2019, 21:09
everything works fine but mouse can move very a little bit area, stuck in the central area of screen.
RE: Mouse can't move
by BYaka on Tuesday May 21st 2019, 12:54
looks like u enabled mouse-wrapping?
Mod tools?
by Jen on Friday April 29th 2016, 11:32
Has anyone gotten the mod tools to run yet?
RE: Mod tools? Got it!
by Jen on Friday April 29th 2016, 11:36
For anyone else wondering, it's the AssetManager.exe that needs to be started for the tools. This is in the Grim Dawn Modding Guide, which I hadn't read. ;)
RE: Mod tools?
by talchas on Wednesday June 29th 2016, 18:53
You need to manually set overrides for a bunch of api-ms-* (the ones in the 64-bit code for winetricks vcrun2015 are at least most of what you need, though my version has a typo that has an extra .dll on one of them).

For the DBREditor (resource popups) you also need to go download ObjectListView, but even then it won't work. That said, a text editor works just fine.
Cursor invisible after leaving the screen
by eNTi on Wednesday March 23rd 2016, 14:28
When leaving the game screen boundaries (to browse or whatever) the cursor becomes invisible upon re-entering the wine window. this can be 'fixed' by changing graphics settings like like fullscreen to borderless window (or vice versa) until you leave the screen again.
RE: Cursor invisible after leaving the screen
by eNTi on Wednesday March 23rd 2016, 15:07
ok i've found that it seems to be only a focus issue. just clicking on the window (right i know... i could have realized that sooner?) lets the cursor reappear.
Fix for invisible characters (CheckFloatConstants)
by Pekka Helenius on Tuesday March 8th 2016, 1:49
If you're struggling with invisible characters, do the following:

set HKCU/Software/Wine/Direct3D/CheckFloatConstants registry key to "enabled" (without quotations)

Registry key type: String Value (REG_SZ)

Requires Wine 1.9.5 or newer.

This is a known issue in multiple games:
bugs.winehq.org/show_bug.cgi?id=34052#c75
RE: Fix for invisible characters (CheckFloatConstants)
by BYaka on Tuesday March 8th 2016, 14:18
Thx, it works for me!

Also big thx to Matteo Bruni, author of this patch.
RE: Fix for invisible characters (CheckFloatConstants)
by Jen on Saturday March 19th 2016, 12:04
Awesome, thanks! Seems to have done the trick for me, too.
RE: Fix for invisible characters (CheckFloatConstants)
by eNTi on Wednesday March 30th 2016, 6:55
fixed it for me too! great find.

by GloriousEggroll on Wednesday March 2nd 2016, 12:54
Had some luck regarding getting invisible characters to show by turning off "Allow Flipping" under opengl settings in nvidia-settings worked 3-4 times in a row launching the game, needs more confirmation though

by GloriousEggroll on Sunday February 28th 2016, 4:48
edit - still invisible characters/character parts. changing graphical settings doesnt fix. you can set shaders to medium/low but some npcs will still show invis in game
RE:Partially Visible Character
by GloriousEggroll on Friday February 26th 2016, 3:40
Found a fix to this after a short check on win settings compared to my arch install:

If you have a partially invisible character, open

Documents/My Games/Grim Dawn/Settings.txt
and change
antialiasing=2

(or higher - 2,4,6,8,16) then restart the game. The game sets it to 1 by default which causes invisible character parts.
RE:Partially Visible Character
by GloriousEggroll on Friday February 26th 2016, 4:07
meant anisotripicfiltering not antialiasing
VCRUN2015
by Tyler Fru on Thursday February 25th 2016, 15:38
It should be noted that VCRUN2015 will *not* install with a prefix made for steam. So users with PLayonLinux or steam workarounds won't be able to install it if they aren't using a vanilla steam installation.

It throws this error:

err:ole:apartment_getclassobject DllGetClassObject returned error 0x80040111
err:ole:CoGetClassObject no class object {f5078f1b-c551-11d3-89b9-0000f81fe221} could be created for context 0x1
------------------------------------------------------
Note: command 'wine vc_redist.x86.exe' returned status 17. Aborting.
------------------------------------------------------
More testing
by Jen on Monday February 22nd 2016, 20:45
New pastebin here: pastebin.com/c14PQugi (This is with build 31.)

I don't think it's a bug with my WINEPREFIX, since pcsx2 (also depends on vcrun2015, see: github.com/Winetricks/winetricks/issues/575) runs fine.

Bug with WINE?
RE: More testing
by Jen on Monday February 22nd 2016, 20:53
Okay, edit, got called away while I was trying it once more, and when I came back it loaded. Seems to be working for now...Figures!
RE: More testing
by Nicholas Loomans on Wednesday February 24th 2016, 16:59
I'm glad it's resolved.
Stopped working 2/16?
by Jen on Wednesday February 17th 2016, 10:57
I last played Grim Dawn on 2/15. The next night I went to play (2/16), and it crashed, locking everything up. This morning, I deleted and rebuilt my WINEPREFIX, only installed Steam and Grim Dawn, and I'm still getting a crash. Nothing's changed on my computer between the last time I played Grim Dawn and today. Did they hotfix something in the game? (Got msxml3, vcrun2015, d3dx9 installed via winetricks, most recent version. WINE is 1.9.3.)

Here's my pastebin: pastebin.com/DSHCC2wM
RE: Stopped working 2/16?
by Jen on Wednesday February 17th 2016, 11:33
Even updated video card drivers. No dice. Saw that there was a crash related to Steam saves, so turned them off. Still crashes.
RE: Stopped working 2/16?
by Nicholas Loomans on Wednesday February 17th 2016, 15:44
They have updated the vcredist. You may need to go into a Windows 10 install and copy over the files from the notes again as they have probably changed.
RE: Stopped working 2/16?
by Jen on Wednesday February 17th 2016, 16:31
Like recently updated? It was working for me on Sunday/Monday. Tuesday it didn't. (I'm assuming that's when the update happened.)
RE: Stopped working 2/16?
by Nicholas Loomans on Wednesday February 17th 2016, 18:38
It was around 12/2.
RE: Stopped working 2/16?
by Jen on Wednesday February 17th 2016, 18:44
You mean December 2nd? I bought it on Feb. 8. I upgraded versions of WINE on the 11th. Feb. 15 was the last time it worked, then started crashing on Feb. 16.
Steam overlay causes crash
by pfftzo on Sunday November 23rd 2014, 18:34
Make sure you have Steam in-game overlay disabled for Grim Dawn, or ANY key you press after launching the game will immediately crash it.
This happens with some other Steam games too.

In other games, a workaround is to bring up the overlay once by mouse click. After this, the Steam overlay can be controlled with keyboard too and will no longer cause a crash when you press any key.
However, Grim Dawn does not provide a way to bring up the overlay with mouse click, so you have to disable it.
Not working after upgrade
by Bertus van Zyl on Wednesday March 19th 2014, 13:43
I upgraded to Ubuntu Saucy 13.10 64bit and nvidia drivers to 331.20 from x-swat and afterwards Grim Dawn stopped working.

The game launches and everything in the menus work but when starting a game it loads for a second then the game pauses. It does not freeze as the music keeps playing and the cursor moves but it just stops loading.

I've installed all dependancies with winetricks and even tried a clean prefix.
RE: Not working after upgrade
by Nicholas Loomans on Wednesday March 19th 2014, 14:50
Is the wine version 1.7.13? I run Arch w/ nvidia I will test my versions and see if I can duplicate.
RE: Not working after upgrade
by Bertus van Zyl on Thursday March 20th 2014, 1:19
I'm on 1.6.1 right now but i was using 1.7.13 when i encountered the bug the first time.

Sorry for double post.
RE: Not working after upgrade
by Nicholas Loomans on Sunday March 23rd 2014, 22:47
See my recently added test data, game not working for me also. I think it's the game update to v0.2.3.4 b17. Hopefully the next patch will address this.
Back