WineHQ

Rocksmith 2014

Application Details:

Version: Steam
License: Retail
URL: http://rocksmith.ubi.com/rocks...
Votes: 0
Latest Rating: Gold
Latest Wine Version Tested: 5.4

Maintainers: About Maintainership

Link Steam Store

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Everything. The sounds is clear, graphics work fine and run fast, and no registry entries need to be touched with the current Wine release . I was able to log into UPlay through the game fine, and could access my saved profile (from Steam cloud) and DLC. There are some other steps and considerations to get it running nicely however (see below).

What does not

Latency is higher than on Windows (maybe 200-300 ms, where there is no perceivable latency on the same hardware under Windows), even without PulseAudio running. Normal PulseAudio loopback playback doesn't have this delay, so it seems to be introduced by Wine. The game is still quite playable, but it's just enough latency to be annoying. Win32UltraLowLatencyMode also does not work. You need to disable this (by setting it to 0) in the Rocksmith.ini file. The cable won't be detected automatically by default if PulseAudio is running and has grabbed it.

Workarounds

What was not tested

Guitar Arcade and Session mode

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

Set `Win32UltraLowLatencyMode=0` in Rocksmith.ini. All other defaults in the file are fine. Also, release the Rocksmith USB device from PulseAudio if it's running. You can do this one of two ways: 1. pavucontrol -> Configuration -> set the Profile to off from the drop-down next to the device. 2. Stop PulseAudio completely. eg. $ echo "autospawn = no" > ${HOME}/.config/pulse/client.conf $ pulseaudio --kill (and do something about ${HOME}/.asoundrc if that's pointing to pulse by default). pasuspender may also do the job, but I did not test that. Failure to do one of these two steps will result in the cable not being detected. You also need winecfg set to Windows 7 (Vista should work). Failure to do this will result in the cable being detected, but nothing can be recorded. The game lists Vista in the minimum requirements. System: i7-3630QM Nvidia GTX660M (340.65) 32 GiB RAM

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowArch Linux x86_64Mar 28 20205.4Yes Yes YesGoldMatthew A Flower 
ShowUbuntu 17.04 "Zesty" amd64 (+ variants like Kubuntu)May 10 20172.7Yes Yes PlatinumTopi 
ShowUbuntu 16.10 "Yakkety" amd64 (+ variants like Kubuntu)Apr 26 20172.3Yes Yes GoldDNI 
ShowMac OS X 10.11 "El Capitan"Sep 25 20161.9.19N/A Yes Bronzean anonymous user 
ShowUbuntu 14.04 "Trusty" i386 (+ variants like Kubuntu)Oct 16 20161.8.4Yes Yes GoldSilvio Kozasa 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

Comments

Back