WineHQ

Rocksmith 2014

Application Details:

Version: Steam
License: Retail
URL: http://rocksmith.ubi.com/rocks...
Votes: 0
Latest Rating: Platinum
Latest Wine Version Tested: 2.7

Maintainers: About Maintainership

Link Steam Store

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Running the game.

What does not

Cable detection is flaky, no sound from cable through speakers.

Workarounds

What was not tested

Most of it.

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

I have set up the exe to run under Windows 7 emulation. With PulseAudio running: On initially starting, I get no sound. Switch ExclusiveMode=0 and you get sound. I get a message telling me that the cable isn't configured properly and to look in the manual. I also get 2 devices added to the recording tab in pavucontrol for some reason. Also, I have turned the cable record volume all the way up in AlsaMixer as it wsa lower than halfway. I still get no audio coming through the speakers. With ExclusiveMode=1 and Win32UltraLowLatencyMode=0 calibration detects noise from the cable, but I hear nothing from the speakers. It's also very slow detection. 00000000: : INIT ExclusiveMode 1 00000000: : INIT LatencyBuffer 4 00000000: : INIT ForceWDM 0 00000000: : INIT ForceDirectXSink 0 00000049: : WASAPI::OpenStream(output): framesPerUser[ 256 ] framesPerHost[ 513 ] latency[ 10.69ms ] exclusive[ YES ] wow64_fix[ NO ] mode[ POLL ] 00000050: : pSinkPortAudio->Init() == AK_Success00000050: : AkCreateThread EventMgrThread 0x1c4 ID = 15353920 00000050: : ************* NSoundInputMgr_Win32::SETUP mUsePortAudio 1 mUseNWin32 0 mUseWaveIn 0 mForceDirectXSink 0 mForceWDM 0 00026790: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio WASAPI Id 0 API 0 : Monitor of Built-in Audio Analog Stereo[0 0] 00026790: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio WASAPI Id 1 API 0 : Pulseaudio[0 0] 00026790: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio WASAPI Id 2 API 0 : Built-in Audio Analog Stereo[0 0] 00026790: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio WASAPI Id 3 API 0 : Rocksmith Guitar Adapter Analog Mono[ff 12ba] 00026790: : ** NSoundInputMgr_Win32::DetectInputDevices_PortAudio Id 3 API 0 : Rocksmith Guitar Adapter Analog Mono[ff 12ba] 00026790: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio FOUND! 0 : Rocksmith Guitar Adapter Analog Mono[{0.0.1.00000000}.{CB757E47-9468-45F8-B46E-25B9BCC13A56}] 00026791: : WASAPI::OpenStream(input): framesPerUser[ 256 ] framesPerHost[ 9600 ] latency[ 200.00ms ] exclusive[ YES ] wow64_fix[ NO ] mode[ POLL ] 00026792: : ** NSoundInputMgr_Win32::DetectInputDevices_PortAudio Id 3 API 0 : Rocksmith Guitar Adapter Analog Mono INPUT ON Slot 0 00026792: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio WASAPI Id 0 API 0 : Monitor of Built-in Audio Analog Stereo[0 0] 00026792: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio WASAPI Id 1 API 0 : Pulseaudio[0 0] 00026792: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio WASAPI Id 2 API 0 : Built-in Audio Analog Stereo[0 0] 00026792: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio WASAPI Id 3 API 0 : Rocksmith Guitar Adapter Analog Mono[ff 12ba] 00026792: : ** NSoundInputMgr_Win32::DetectInputDevices_PortAudio Id 3 API 0 : Rocksmith Guitar Adapter Analog Mono[ff 12ba] 00026792: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio WASAPI Id 1 API 0 : Pulseaudio[0 0] 00026792: : ** NSoundInputMgr_Win32::DetectInputDevices_PortAudio Id 1 API 0 : Pulseaudio[0 0] 00026792: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio FOUND! 0 : Pulseaudio[{0.0.1.00000000}.{25DA76D0-033C-4235-9002-19F48894AC6F}] 00026792: : WASAPI::OpenStream(input): framesPerUser[ 256 ] framesPerHost[ 9600 ] latency[ 200.00ms ] exclusive[ YES ] wow64_fix[ NO ] mode[ POLL ] 00026793: : ** NSoundInputMgr_Win32::DetectInputDevices_PortAudio Id 1 API 0 : Pulseaudio INPUT ON Slot 1 00098561: : AK::ReleaseAudioSink WMFocusCallback00101824: : AK::RestoreAudioSink WMFocusCallback00101825: : WASAPI::OpenStream(output): framesPerUser[ 256 ] framesPerHost[ 513 ] latency[ 10.69ms ] exclusive[ YES ] wow64_fix[ NO ] mode[ POLL ] 00101825: : pSinkPortAudio->Init() == AK_Success00104213: : AK::ReleaseAudioSink WMFocusCallback Without Pulse: ExclusiveMode=1 and Win32UltraLowLatencyMode=1 = Crash straight away. Tried again, ran, Went to tuner, still nothign coming through, cable also not detected. Went to calibrate, still no detection, but indicator did move when I strummed. 00000000: : INIT ExclusiveMode 1 00000000: : INIT LatencyBuffer 4 00000000: : INIT ForceWDM 0 00000000: : INIT ForceDirectXSink 0 00000150: : WASAPI::OpenStream(output): framesPerUser[ 128 ] framesPerHost[ 1440 ] latency[ 30.00ms ] exclusive[ NO ] wow64_fix[ NO ] mode[ POLL ] 00000150: : pSinkPortAudio->Init() == AK_Success00000150: : AkCreateThread EventMgrThread 0x1bc ID = 15353920 00000151: : ************* NSoundInputMgr_Win32::SETUP mUsePortAudio 1 mUseNWin32 0 mUseWaveIn 0 mForceDirectXSink 0 mForceWDM 0 00026896: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio WASAPI Id 0 API 0 : In: E-mu 1010 [MAEM8810] - Multichannel Capture/PT Playback[0 0] 00026896: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio WASAPI Id 1 API 0 : In: E-mu 1010 [MAEM8810] - Mic Capture[0 0] 00026896: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio WASAPI Id 2 API 0 : In: USB Audio CODEC - USB Audio[2902 8bb] 00026896: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio WASAPI Id 3 API 0 : In: E-mu 1010 [MAEM8810] - ADC Capture/Standard PCM Playback[0 0] 00026896: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio WASAPI Id 4 API 0 : In: Rocksmith USB Guitar Adapter - USB Audio[ff 12ba] 00026896: : ** NSoundInputMgr_Win32::DetectInputDevices_PortAudio Id 4 API 0 : In: Rocksmith USB Guitar Adapter - USB Audio[ff 12ba] 00026896: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio WASAPI Id 5 API 0 : In: HDA ATI SB - ALC892 Alt Analog[0 0] 00026896: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio WASAPI Id 6 API 0 : In: default[0 0] 00026896: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio WASAPI Id 7 API 0 : In: HDA ATI SB - ALC892 Analog[0 0] 00026896: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio FOUND! 0 : In: Rocksmith USB Guitar Adapter - USB Audio[{0.0.1.00000000}.{8147D7D5-5BBD-49BD-A01C-6D7F77C6EA84}] 00026898: : **!!!! NSoundInputMgr_Win32::DetectInputDevices_PortAudio Id 4 API 0 : In: Rocksmith USB Guitar Adapter - USB Audio FAILED TO TURN ON INPUT FOR DEVICE 00026898: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio WASAPI Id 6 API 0 : In: default[0 0] 00026899: : ** NSoundInputMgr_Win32::DetectInputDevices_PortAudio Id 6 API 0 : In: default[0 0] 00026899: : ************* NSoundInputMgr_Win32::DetectInputDevices_PortAudio FOUND! 0 : In: default[{0.0.1.00000000}.{E9D9FC27-6B37-406E-AB03-7E642562E118}] 00026901: : **!!!! NSoundInputMgr_Win32::DetectInputDevices_PortAudio Id 6 API 0 : In: default FAILED TO TURN ON INPUT FOR DEVICE 00078311: : AK::ReleaseAudioSink WMFocusCallback

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowUbuntu 17.04 "Zesty" amd64 (+ variants like Kubuntu)May 10 20172.7Yes Yes PlatinumTopi 
ShowUbuntu 16.10 "Yakkety" amd64 (+ variants like Kubuntu)Apr 26 20172.3Yes Yes GoldDNI 
ShowMac OS X 10.11 "El Capitan"Sep 25 20161.9.19N/A Yes Bronzean anonymous user 
ShowUbuntu 14.04 "Trusty" i386 (+ variants like Kubuntu)Oct 16 20161.8.4Yes Yes GoldSilvio Kozasa 
ShowUbuntu 14.04 "Trusty" i386 (+ variants like Kubuntu)Jul 25 20161.9.15Yes Yes Bronzean anonymous user 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

Comments

Back