WineHQ
Category: Main Games Online (MMORPG) Games EverQuest EverQuest (Live)

EverQuest

EverQuest Classic and All Expansions

Everquest, next to Ultima Online, is one of the original MMORPG's that gave inspiration to games like Everquest 2 and World of Warcraft. Fight powerful dragons, strange creatures and even the Gods themselves in one of the games that started the MMORPG craze! Originally developed by Verant, Sony Online Entertainment (SOE) has since taken over the project. Everquest is one of, if not THE, longest running MMO to date since it first opened its doors in 1999.

Currently, Everquest has 20 expansions (in order of release): Ruins of Kunark, Scars of Velious, Shadows of Luclin, Planes of Power, Legacy of Ykesha, Lost Dungeons of Norrath, Gates of Discord, Omens of War, Dragons of Norrath, Depths of Darkhollow, Prophecy of Ro, The Serpent's Spine, The Buried Sea, Secrets of Faydwer, Seeds of Destruction, Underfoot, House of Thule, Veil of Alaris, Rain of Fear and Call of the Forsaken.

Application Details:

Version: EverQuest (Live)
License: Retail
URL: http://www.everquest.com
Votes: 18
Latest Rating: Platinum
Latest Wine Version Tested: 2.1

Maintainers: About Maintainership

Link http://everquest.station.sony.com Free Download Free Trial

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Everything.

What does not

No issues with any features.

What was not tested

LoN card game application inside EQ.

Additional Comments

Needs the full winetricks directx9 package, after that installation and run went flawlessly.

If armor or characters are missing/invisible this can be resolved by setting the option VertexShaders in eqclient.ini from TRUE to FALSE.
selected in Test Results table below
DistributionTest dateWine versionInstalls?Runs?RatingSubmitter
ShowGentoo Linux x86_64Apr 06 20172.1Yes Yes Platinumsteve 
ShowUbuntu 14.04 "Trusty" amd64 (+ variants like Kubuntu)Mar 16 20161.9.1No, but has workaround Yes Goldan anonymous user 
ShowMac OS X 10.9 "Mavericks"May 05 20141.7.18Yes Yes GoldMike 
ShowPC-BSD 10.0 (64-Bit)Feb 28 20151.6.2Yes Yes Goldan anonymous user 
ShowGentoo Linux x86_64Aug 27 20131.7.0No, but has workaround Yes GoldSaellaven 

Known Bugs

Bug # Description Status Resolution Other apps affected
32342 Multiple applications and games using 'Webkit' or 'Blink' web browser engine crash on startup ('Arial' and 'Times New Roman' font face name validation) STAGED View

Show all bugs

HowTo / Notes

FAQ

Solutions to common issues


Permissions 

EQ is a constantly updating game. The user running the application needs read, write and execute to the entire directory where it is installed. Be careful when copying installations over from Windows. You might need to

chown -R username path_to_EQ_directory
and
chmod 0755 -R path_to_EQ_directory.


Patcher 

The new patcher system is sensitive to file locations. If you have problems getting the patcher to run:

- move your EQ directory to a backup location
- download the free trial and install it into the default location (C:\Program Files\Sony\EverQuest)
- run the patcher and make sure it works, but don't go through the agonizingly long download
- move your EQ files to C:\Program Files\Sony\EverQuest (probably /home/user/.wine/drive_c/Program Files/Sony/EverQuest)
- whenever you run EQ, you must "cd path_to_EQ" and then "wine EverQuest.exe"

You can skip the patcher by running "wine eqgame.exe patchme" but this will crash if there has been an update to critical EQ files.

Another way around the patch issue is to mount your Linux drive under a Windows machine and run the patcher from there. I did this over a network with samba.


In Game Options

You must change some options in eqclient.ini in order to run the game properly. If a setting is missing, like TextureCache, just enter it into the appropriate section. If you use the default file, VertexShaders are already TRUE, but so is TextureCache which needs to be FALSE.

- You can log into any zone you have previously zoned into and also any small zone like the guild lobby. If you log into one that you have never been in before, you get fixme:d3d:IWineD3DDeviceImpl_CreateVertexBuffer Out of memory! (TextureCache)

- If your first toon on char select is a Drakkin, the animation is broken except for the primary and secondary weapons/shield move. If you select any other character at char select, the game crashes. (TextureCache)

- Game crashes at char select. (VertexShaders)

[Defaults]

VertexShaders=TRUE
TextureCache=FALSE


Broken Animation

by Joni Larsen-Haikarainen

Problem with the character models not animating correctly. They will animate choppy a few frames and then just freeze up totally.
It has to do with the multicore nature of the AMD64. I remembered having this problem with an old native Linux game (UT) because of this as well and the solution there was to force the game to just run on the first core, so i tested it with EQ as well and it works perfectly!

To run EQ directly without the patcher on just the first core, open a terminal and cd to the install directory of EQ and type the following:

taskset -c 0 wine eqgame.exe patchme

If your running the game through the patcher is:

taskset -c 0 wine EverQuest.exe

Its the "taskset -c 0" prefix that binds the process to the first CPU/Core.


Wine Version Updates

If you update your wine version, it may be necessary to delete ~/.wine and then run winecfg to regenerate the directory. Make sure you move "~/.wine/drive_c/Program Files/Sony" to a backup location and then move it back so you don't have to download everything again.


Mouse Cursor Stuck

This happens only at server select. You may need to switch to windowed mode to choose a server for the first time or to change servers from the last one you picked. If you're using the same server, you can just use the tab and enter keys on the keyboard to get around. When you get to character select, this problem goes away.


Account Pages and User Agreement not shown


HTML rendering does not work correctly. Occasionally, I will see the user agreement show up and the news, but it is rare. You will have to set up a new account with a Windows box most likely and then sign into it with wine. It does not have much effect in game.


Running 2 Instances of EQ

by Joni Larsen-Haikarainen

This is for 2 or more instances of EQ on the same machine with different ini files. If you just use the same ini file, it is not necessary to do this.
If you use diffrent WINEPREFIX for the diffrent installs it should work fine.
cp -R ~/.wine ~/.wine.eq-box2
cp -R ~/.wine ~/.wine.eq-box3
cp -R ~/.wine ~/.wine.eq-box4
and so on.
and then use: WINEPREFIX="~/.wine.eq-box#" wine eqgame.exe patchme
for example
note though you will need to patch each one separatly.

An even easier method would be to buy CrossOver Games 7 (and thus supporting WINE economically) that has a graphical front-end to do this easy called bottles.


Extremely Poor Frame Rate or Driver Warning

I always get the following message on the way to the Character selection window:
You have a Direct3D HAL video card (version 175.65...)...
...you should download driver 8185...
There's a link that sends me to NVidia website (I have a NVidia FX5200 video card) but the so said driver is impossible to find...
When I try to play, ignoring the driver update, I get the problem of half of the textures are not showing at the selection window and in the game.I only see some kind of grey frame or building.

You must use proprietary drivers for wine 3D games to work. For Nvidia users, try www.nvidia.com/object/unix.html in one of your Linux browsers (like Firefox, not running through wine) and follow the install instructions on the driver download page. If you need help, see  www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

ATI cards
CONFIRMED: ATI cards do not work well with the modified dll. We've had a few people report issues with character faces being drawn improperly with the eyes and ears off-center or duplicated. Small graphics glitches. The people who have reported it are using ATI cards. It only happens with these cards.
HOWTO run EQ with wine

AUTHOR: Julio Fernandez

After speaking with wine devs, it seems it's not feasible/could make some other applications to stop to work, if we 'hack' wine to return 4 instead 0.

For those not willing/able to build wine from source (quite uncomfortable too, considering wine release cycle), theres another way to apply the workaround, without having to touch wine at all: File d3dx9_30.dll is part of DirectX dll's, typically you have already put a copy of it in your Linux EQ game directory, if not make a copy from your windows install partition (usually found at /system32 folder with all other DX files) on your Linux game directory and modify the copy.

To patch the file you can use any binary editor (ghex as example -be careful, the program itself is called ghex2 instead-)

patch the file d3dx9_30.dll at offsets:

4c6f9, where there is a '83' replace it for '6a'
4c6fa, where there is a 'fe' replace it for '04'
4c6fb, where there is a '02' replace it for '5e'

save it and it's done.

As a reference the offset list from 4c6f0 before the change should read:
00 00 00 f6 45 f8 50 74 0f 83 fe 02 73 56 b8 57

And the offset list from 4c6f0 after the change should read:
00 00 00 f6 45 f8 50 74 0f 6a 04 5e 73 56 b8 57

Changing d3dx9_30.dll linux EQ local copy won't affect any other application and keeps you from 'patching' wine sorce after each release you want to upgrade to.


You can get a modified version of the dll and Angeliqe's working ini file at http://www.angeliqe.com  Just click on the EQ button on the left. If you use the ini file, make sure to modify the resolution settings to match your X setup. 

** NOTE** Make sure you put d3dx9_30.dll wherever you have Everquest.exe located. Usually in $WINPREFIX/drive_c/windows/Program Files/Sony/EverQuest


WARNING! Only, use this if the first method does NOT work for you. If you are running an older version of EQ with a non-official server that does not use the exact dll above, then you will have to use this method.

Add this line:
pCaps->MaxVertexBlendMatrices=0x4;
In file:
(your wine source directory)/dlls/d3d9/directx.c
At function:
IDirect3DDevice9Impl_GetDeviceCaps(LPDIRECT3DDEVICE9 iface, D3DCAPS9* pCaps)
Before returning (return hrc;), line 176 (as of 0.9.55)
Build wine as usual and happy Everquestin

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

Everquest
by steve on Thursday April 6th 2017, 17:07
installs and works fine in Wine 2.0+

winetricks wmi d3dx9_43 corefonts

even running MQ2 with it

no problems yet
Modern Versions of Wine Wont Connect Patcher
by e8hffff on Sunday February 19th 2017, 9:13
Modern versions of Wine refuse to allow the patcher to connect and patch. The last version that worked was Wine 1.9.24. The error = "LaunchPad was unable to connect. Please check the network connection or try again later. If the problem persists, please visit help.daybreakgames.com for assistance.(4-503)"

I believe the problem is to do with certificates and he webkit used in the updater.
Invisible Text
by Nick Hathaway on Wednesday November 2nd 2016, 23:46
I am running Ubuntu 16.04 and edited eqclient to turn off vertex shaders and everything seems to work fine except there that almost all text is invisible. Anyone know of a fix for this??
Crashes During Movement (Intel HD)
by e8hffff on Friday March 18th 2016, 1:57
I get random crashes when moving in game. I've tried most settings combinations to see if something is buggy, even with lowest options. No unique errors in command-line execution.

I'm using a Nuc5i5RHY with Intel Graphics.
Missing Character
by Takahiro Hirano on Tuesday May 5th 2015, 2:28
If you met the character disappearing, please try the following:
VertexShaders=0

Bug with VertexShaders enabled
forums.station.sony.com/eq/index.php?threads/bug-with-vertexshaders-enabled.1748/
Keyboard issues
by Nilshar on Friday August 29th 2014, 6:52
Hello,

yesterday I installed EQ again on my debian Jessie (wine 1.6.2-8).
after the usual tricks (dx9, corefonts, glsl), all went ok and I'm able to play without problem... but not really : I got some keyboard issues :(
some keys just doesn't work, the 4 key (not numpad, I'm on laptop, XPS 13), and a few others..
That's really annoying, and that's the only think left to have a perfect EQ experience on Linux.
So if anyone have a clue on that... please let met know!
Thanks.
Spells
by Dr. Wes Snyder V on Sunday September 1st 2013, 21:13
Hello,

I noticed the spells do not give me details when I hover over them or select them. Anyone else have this condition? I recall some information should display about the spell so one can tell which to select.
  • RE: Spells by Joni Larsen-Haikarainen on Monday September 2nd 2013, 6:53
    • RE: Spells by Dr. Wes Snyder V on Monday September 2nd 2013, 10:15
Wine 1.6 on Mac 10.8
by sylveni on Sunday August 25th 2013, 5:52
Works fine using Wine 1.6 on Mac 10.8 with an Intel CPU and ATI Radeon 6750M. The straightforward install of d3dx9 using winetricks worked fine for directx. Had the issue of models not appearing, but using winetricks to disable glsl fixed this issue.
Wine1.5.24 works
by Dr. Wes Snyder V on Saturday August 10th 2013, 16:27
I am doing regression testing and found Wine1.5.5, 1.5.24, 1.5.25, 1.5.28, 1.5.30, and 1.5.31 work. These are all the 32bit PREFIX.

I tested 1.5.25 64bit and it did not work.
the dll file doesn't have those numbers?
by jstx on Tuesday February 26th 2013, 12:28
Hi, thanks for the instructions.

Admittedly, this is the first time I've ever done hex editing, but those links to the pre-modified .dll file is dead, and the one available for download via "The Internet" does not seem to have those digits - 4c6f9, etc. I only see 4c6f0. email me at justxjs@mail.com
Everquest expansion Rain of Fear problem
by Tomas Andershem on Friday December 7th 2012, 13:43
Hi after the launch of the expansion Rain of Fear i can't get the game to work in the new expansion Rain of Fear or in the previous Veil of Alaris.

The game work greate in older expansions but as soon as i zone in to a VoA or RoF zone the game crashes about half way in loading the zone.

Funny thing is that VoA worked flawless before launch of ROF.

Last wine messages in console:
fixme:d3d:resource_check_usage Unhandled usage flags 0x10.
fixme:d3d:resource_check_usage Unhandled usage flags 0x10.
fixme:d3d:resource_check_usage Unhandled usage flags 0x10.
fixme:dbghelp:elf_search_auxv can't find symbol in module
fixme:d3d:wined3d_swapchain_set_gamma_ramp Ignoring flags 0x1.

Using wine version 1.5.17 on Fedora 17 64bit
using Nividia 570 with nvidia drivers from rpmfusion:
kmod-nvidia-3.6.8-2.fc17.x86_64-304.64-1.fc17.x86_64

Anyone have any idea or can help about the problem?
Greyed out areas
by MisterBubbles on Wednesday October 10th 2012, 10:17
Depending on the area I am in, the game either works 100% or doesn't work at all.

See, in the Planes of Knowledge it works fine: i.imgur.com/ci9fV.jpg

But then in Blightfire Moor I get: i.imgur.com/s9MGr.jpg

Any ideas on how I can fix this? I have winetricks directx9 and otherwise a clean wine prefix, have changed the Vertex Shaders.

Also on a side note, anyone know why the patcher gets a fatal error repeatedly from time to time?
Nvidia GTX660 Problems?
by e8hffff call on Monday September 3rd 2012, 18:45
I've just upgraded to a Nvidia GTX 660Ti, from a AMD Radeon HD3870 which was running Everquest pretty much flawless except I had to turn down some of the visuals and run the modified DX dll and some graphics in game weren't drawing. The problem is the Nvidia just wont launch the game from the Updater dialogue window.

I've removed the AMD DX dll fix. Here are the errors return in a cli. Duplicates removed1

fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
fixme:time:GetSystemTimes (0x33f4bc,0x33f4ac,0x33f4b4): Stub!
fixme:time:GetSystemTimes (0x33f144,0x33f134,0x33f13c): Stub!
fixme:browseui:ProgressDialog_SetAnimation (0x1673b0, 0xf7250000, 161) - stub
fixme:browseui:ProgressDialog_StartProgressDialog Flags PROGDLG_AUTOTIME not supported
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:iphlpapi:NotifyAddrChange (Handle 0x4ffe7cc, overlapped 0x495e9a0): stub
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
fixme:gdi:GdiInitializeLanguagePack stub
fixme:secur32:schan_imp_create_session Using hardcoded "NORMAL" priority
fixme:win:EnumDisplayDevicesW ((null),0,0x6e7a2d8,0x00000000), stub!
fixme:file:ReplaceFileW Ignoring flags 2
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
fixme:time:GetSystemTimes (0x168fd10,0x168fd00,0x168fd08): Stub!
fixme:advapi:SetSecurityInfo stub
fixme:time:GetSystemTimes (0x168fa9c,0x168fa8c,0x168fa94): Stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x168eb50,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x168eeb4,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x168ee94,0x00000000), stub!
fixme:d3d:wined3d_swapchain_set_gamma_ramp Ignoring flags 0x1.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
[ERROR] - Mouse Wheel supported = TRUE
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:wined3d_buffer_preload Too many declaration changes or converting dynamic buffer, stopping converting
fixme:file:ReplaceFileW Ignoring flags 2
fixme:iphlpapi:CancelIPChangeNotify (overlapped 0x495e9a0): stub
No Animations
by Thom on Saturday March 17th 2012, 1:19
I recently installed Everquest on Gentoo and wine 1.4

I don't remember everything I did unfortunately but I recall having to build wine with 'gnutls' USE flag, and of course had to have gnutls package installed. Else the newest Launcher was giving me an Error page, like a 404, but specifically told me the problem was on their end!

There was a second error in the console as I was troubleshooting that problem, it may have been safe to ignore but in case it's not I also had to build samba with the winbind USE flag and ultimately I added samba to the USE flags for wine and recompiled wine again.

I know I also used 'winetricks d3d9x' on the eq prefix I created

Lastly after whatever else I did I was able to play the game and it ran great the little bit I goofed around but I had no animations - character creation was blank, in the world characters were just floating names etc. which is apparently a bug around for ages. After a lot of searching and no success I finally went into eqclient.ini and set VertexShaders=False and started the game again. I have animations!
Degraded to Garbage?
by Evil on Friday March 16th 2012, 9:13
I could not get it working at all in it's current state. I followed the Launchpad 3 instructions in an attempt to get around the patcher.

I installed IE6 and Flash without issue (though the location has changed from the instructions linked in the messages below).

My issue was that, IE 6 kept complaining that it couldn't run ActiveX controls on the page even though I adjusted all the security settings to make it totally insecure and even added the SOE site to the trusted list. I verified that all of these settings were retained and even restarted IE6 many times.

My attempt with IE8 was even worse, as it explodes after loading the page. :(
Little issue
by Barrett on Tuesday December 13th 2011, 16:07
I've gotten EQ completely installed and running. Well, it crashes on it's own but I can run it just fine using WinEQ 2.0. The only issue I'm having, some of my keys don't work or work correctly. Any ideas on this? My "I" button doesn't open my inventory, instead it moves my mouse cursor to the middle of my screen. My 9 and 3 on my numpad don't work for looking up and down either. These are the only issues I seem to be having so far. Thanks!
I'm having trouble logging in.
by Magnus on Sunday July 24th 2011, 21:36
When I try to log in to a private sever the operation times out after a few seconds. I'm not sure what's causing this, none of the posts I've read so far seem to have this problem. I know it's not a lot to work with but if anyone has a vague idea of what's going on I could really use the help.
Back