WineHQ

Space Engineers

Version available to download on Steam.

Application Details:

Version: Steam
License: Retail
URL: http://www.spaceengineersgame....
Votes: 4
Latest Rating: Garbage
Latest Wine Version Tested: 4.9

Maintainers: About Maintainership

Link Main Website Link Space Engineers on Steam

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Nothing.

What does not

Shows up a window named "Program Error": "Program SpaceEngineers.exe found a serious problem and need to be closed. We sorry... ".


Then it close. Don't run. No single window opens.

Workarounds

What was not tested

Unable to test anything in-game.

Hardware tested

Graphics:

  • GPU: Nvidia
  • Driver: proprietary

Additional Comments

  • NVidia GeForce GTX 970
  • Driver NVidia proprietary 390.25
  • CPU Intel Core i3-4160

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowUbuntu 18.04 "Bionic" amd64 (+variants like Kubuntu)May 29 20194.9Yes No NoGarbageAaron Franke 
ShowArch Linux x86_64Dec 07 20183.21-stagingYes Yes YesGarbageBabble Bones 
ShowArch LinuxJun 17 20183.10-stagingYes No YesGarbageBabble Bones 
CurrentDebian GNU/Linux 9.x "Stretch" x86_64Mar 16 20183.3Yes No NoGarbageDaniel 
ShowLinux Mint 18.1 "Serena" x86_64Sep 17 20172.16-stagingYes No NoGarbageJames Edmonds 

Known Bugs

Bug # Description Status Resolution Other apps affected
38200 Space Engineers 01.072: Save crashes game with err:d3d:resource_init Failed to allocate system memory. UNCONFIRMED View
40356 Space Engineers: Scenario load fail due to GL_INVALID_FRAMEBUFFER_OPERATION UNCONFIRMED View

Show all bugs

HowTo / Notes

Game crashes at startup
If you experience crashes when starting the game try disabling the sound by running 'winetricks sound=disabled'.
After all, it even adds some realism to the game since there are no sounds in space.
If you still want to play with sound try launching the game again and again. Eventually it should start.
Crash for version 1.43
If the game crashes and the log has similar lines:

2014-08-14 12:08:28.174 - Thread: 8 -> Exception occured:
System.Security.Cryptography.CryptographicException: Unknown error "-2146893812". at System.Security.Cryptography.CapiHashAlgorithm.HashCore(Byte[] array, Int32 ibStart, Int32 cbSize)
at System.Security.Cryptography.SHA256CryptoServiceProvider.HashCore(Byte[] array, Int32 ibStart, Int32 cbSize)
at System.Security.Cryptography.HashAlgorithm.TransformFinalBlock(Byte[] inputBuffer, Int32 inputOffset, Int32 inputCount)
...

Try removing 'checksum.xml' from '\Steam\SteamApps\common\SpaceEngineers\Content' folder.
Bug report and more discussion here: http://forums.keenswh.com/post/7038684
Fixing black transparent textures

In order to fix the issue with transparent textures rendering as black boxes you need to edit the TransparentMaterials.sbc file located in 'Steam/SteamApps/common/SpaceEngineers/Content/Data' and add "<AlphaSaturation>1</AlphaSaturation>" to every entry that does not already have an AlphaSaturation tag.

This can be done manually, or use the file from here http://pastebin.com/tXsSAkCF

If you are crashing when pressing any key.
Disable the steam overlay.
Drilling crash

2015-09-10 Admin note: the following info is based on user comments posted over a year ago, and may not be relevant to current Wine.


Try winetricks vb6run.

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.


by Magic_RB on Sunday July 15th 2018, 7:08
Also, if i set oleaut32 to native, then SE crashes way earlier then if i leave to builtin
Got further, or at least i think.
by Magic_RB on Sunday July 15th 2018, 7:02
After creating a new wine prefix and installing dotnet4 and dotnet47 i got to a crash:

0071:fixme:olepicture:OLEPictureImpl_QueryInterface () : asking for unsupported interface {c3fcc19e-a970-11d2-8b5a-00a0c9b7c9c4}
0071:fixme:olepicture:OLEPictureImpl_QueryInterface () : asking for unsupported interface {b196b283-bab4-101a-b69c-00aa00341d07}
0071:fixme:olepicture:OLEPictureImpl_QueryInterface () : asking for unsupported interface {af86e2e0-b12d-4c6a-9c5a-d7aa65101e90}
0071:fixme:olepicture:OLEPictureImpl_QueryInterface () : asking for unsupported interface {ecc8691b-c1db-4dc0-855e-65f6c551af49}
0071:fixme:olepicture:OLEPictureImpl_QueryInterface () : asking for unsupported interface {94ea2b94-e9cc-49e0-c0ff-ee64ca8f5b90}
0071:fixme:olepicture:OLEPictureImpl_QueryInterface () : asking for unsupported interface {00000003-0000-0000-c000-000000000046}
0071:fixme:olepicture:OLEPictureImpl_QueryInterface () : asking for unsupported interface {00000144-0000-0000-c000-000000000046}
0075:fixme:exec:SHELL_execute flags ignored: 0x00000100
0071:fixme:ver:GetCurrentPackageId (0x539790 (nil)): stub
0071:fixme:richedit:ME_HandleMessage EM_GETLANGOPTIONS: stub
0071:fixme:richedit:ME_HandleMessage EM_GETLANGOPTIONS: stub
0071:fixme:richedit:ME_HandleMessage EM_SETLANGOPTIONS: stub
0071:fixme:ras:RasEnumConnectionsW (0x1d9fffa0,0x53e900,0x53e908),stub!
0071:fixme:ras:RasEnumConnectionsW RAS support is not implemented! Configure program to use LAN connection/winsock instead!
0071:err:winsock:WSAIoctl -> SIO_ADDRESS_LIST_CHANGE request failed with status 0x2733
0071:err:winsock:WSAIoctl -> SIO_ADDRESS_LIST_CHANGE request failed with status 0x2733
0071:fixme:ras:RasConnectionNotificationW (0xffffffffffffffff,0x300,0x00000003),stub!
0071:fixme:combase:RoGetParameterizedTypeInstanceIID stub: 2 0x1d9ff670 0x53b220 0x53bc10 (nil)
0071:fixme:combase:RoGetParameterizedTypeInstanceIID stub: 2 0x1d9ff670 0x53b5a0 0x53bf90 (nil)
0071:fixme:combase:RoGetParameterizedTypeInstanceIID stub: 2 0x1d9ff670 0x53b5a0 0x53bf90 (nil)
0071:fixme:ntdll:EtwEventRegister ({38ed3633-5e3f-5989-bf25-f0b1b3318c9b}, 0x1c092c1c, (nil), 0x1be2e68) stub.
0071:fixme:ntdll:EtwEventSetInformation (deadbeef, 2, 0x1be2e10, 53) stub
0071:fixme:combase:RoGetParameterizedTypeInstanceIID stub: 2 0x1d9f9db8 0x53ae70 0x53b860 (nil)
0071:fixme:combase:RoGetParameterizedTypeInstanceIID stub: 2 0x1da066e8 0x539cc0 0x53a6b0 (nil)
0071:fixme:combase:RoGetParameterizedTypeInstanceIID stub: 2 0x1da066e8 0x539cc0 0x53a6b0 (nil)
0071:fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
0071:fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
0071:fixme:winsock:convert_aiflag_w2u Unhandled windows AI_xxx flags 0x20000
0071:err:winsock:WSAIoctl -> SIO_ADDRESS_LIST_CHANGE request failed with status 0x2733
0071:err:winsock:WSAIoctl -> SIO_ADDRESS_LIST_CHANGE request failed with status 0x2733
0073:fixme:ntdll:EtwEventUnregister (deadbeef) stub.
0073:fixme:ntdll:EtwEventUnregister (deadbeef) stub.
0071:fixme:process:FlushProcessWriteBuffers : stub
0071:fixme:ntdll:EtwEventUnregister (deadbeef) stub.
0071:fixme:ntdll:EtwEventUnregister (deadbeef) stub.
0071:fixme:ntdll:EtwEventUnregister (deadbeef) stub.
0014:fixme:ntdll:EtwEventUnregister (deadbeef) stub.
001c:fixme:ntdll:EtwEventUnregister (deadbeef) stub.

this is the output that wine gave me.

System.ComponentModel.Win32Exception (0x80004005): No associated application
at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
at Sandbox.MyMessageBoxCrashForm.linklblLog_LinkClicked(Object sender, LinkLabelLinkClickedEventArgs e)
at System.Windows.Forms.LinkLabel.OnLinkClicked(LinkLabelLinkClickedEventArgs e)
at System.Windows.Forms.LinkLabel.OnMouseUp(MouseEventArgs e)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.Label.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

this is a stacktrace that SE gave me after crashing.
mscoree-related error
by Jonasz on Monday April 16th 2018, 7:05
I have installed all deps this game needs (dotnet and vcrun2017 via winetricks) but it crashes with this error:
err:module:fixup_imports_ilonly mscoree.dll not found, IL-only binary L"SpaceEngineers.exe" cannot be loaded
err:module:attach_dlls Importing dlls for L"C:\\Program Files (x86)\\Steam\\steamapps\\common\\SpaceEngineers\\Bin64\\SpaceEngineers.exe" failed, status c0000135

Ran on a clean x64 wineprefix with wine 3.6
Still doesn't work
by Daniel on Sunday March 18th 2018, 11:45
I have tested with 3.3. It installs but do not run.
DirectX9 Support Dropped
by Alzarath on Tuesday April 5th 2016, 17:48
Space Engineers has dropped DX9 and 32-bit support, meaning the game isn't playable.

There is a beta branch for the older DX9/32-bit supporting build that won't get updated. I wasn't able to get it to work, but maybe someone with more interest can put some effort into it.
RE: DirectX9 Support Dropped
by Aaron Franke on Thursday November 17th 2016, 21:43
Even on Windows, this branch is completely broken. The DX9 renderer definitely doesn't work properly.
RE: DirectX9 Support Dropped
by Jack on Sunday March 11th 2018, 3:38
Since wine 3.0 has released, other dx 11 games like fallout 4 have started to work successfully. Potentially its worth retrying to get space engineers on wine now?
RE: DirectX9 Support Dropped
by Aaron Franke on Sunday March 11th 2018, 3:42
It still does not work, at all.

You may be surprised to hear this, but Wine actually has pretty bad DX11 support. The games that do work are outliers. I can't speak for Fallout 4, but The Witcher 3 works well because the main guy working on DX11 tests against The Witcher 3, and Overwatch only works well because it actually uses 99% DX10 calls, not DX11 ones, and Wine has good DX10 support.
RE: DirectX9 Support Dropped
by Jack on Sunday March 11th 2018, 21:45
Fallout 4 works well now from the wine 3.0 update and a dsound patch, i'm not sure what percentage of dx11 vs dx10 it is but I would guess its predominately dx10. Although I'm not to surprised on the lack of dx11 support, seeing how difficult it appears to implement.

Either way cheers for the update.
Game won't run past the opening splash screen
by Steven Wilson on Friday December 25th 2015, 1:21
I have to change the rating on this game from silver to garbage as nothing posted here will get it to run! wine 1.8rc-4.
RE: Game won't run past the opening splash screen
by Sir Pickles on Friday December 25th 2015, 9:53
Just got it today. I am unable to run it following the steps on the latest test results using wine-staging (1.8) on Arch Linux. It crashes after the load screen which is outside of the game, before it even launches. It throws SharpDX errors.
RE: Game won't run past the opening splash screen
by noxilie on Sunday December 27th 2015, 22:18
Did you change default GraphicsRenderer to DirectX 9? Because it will not work under dx11, because there is no dx11 under wine yet :)

You will need config file, because the game will not generate it until certain step of loading procedure (someone should really fix this, generating the default cfg should be the first step of loading order, if there is no config found).

You can take my:
pastebin.com/raw/QmhuL64h

Place it as %AppData%/SpaceEngineers/SpaceEngineers.cfg
like: ~/.wine32/drive_c/users/noxilie/Application%20Data/SpaceEngineers/SpaceEngineers.cfg
Copy-Paste not working
by Frozen_byte on Wednesday June 10th 2015, 7:41
Please confirg, SE crashes on Copypaste (i.E. the GPS Coords) with following Message:

2015-06-10 14:37:53.672 - Thread: 10 -> Exception occured: System.Runtime.InteropServices.ExternalException (0x80004005): Requested Clipboard operation did not succeed.
at System.Windows.Forms.Clipboard.ThrowIfFailed(Int32 hr)
at System.Windows.Forms.Clipboard.SetDataObject(Object data, Boolean copy, Int32 retryTimes, Int32 retryDelay)
at System.Windows.Forms.Clipboard.SetText(String text, TextDataFormat format)
at System.Windows.Forms.Clipboard.SetText(String text)
at Sandbox.Game.Screens.Helpers.MyGps.b__0()
at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart()
Black boxes around light sources have been fixed
by Aaron Franke on Wednesday June 10th 2015, 2:39
github.com/KeenSoftwareHouse/SpaceEngineers/commit/0a54ff9af701b5ac70094424b27f7b71c1390e8b

Since Space Engineers is now on GitHub, I patched in the community fix for black boxes around light sources using the TransparentMaterials.sbc edit. This bug is fixed as of Alpha 1.085.
GL Out of Memory error?
by Dave B on Wednesday November 26th 2014, 19:42
Running into the following errors recently

err:d3d:buffer_create_buffer_object Failed to create a vertex buffer object. Continuing, but performance issues may occur
err:d3d:wined3d_debug_callback 0x14f8e368: "GL_OUT_OF_MEMORY error generated. Failed to allocate memory for buffer object.".
err:d3d:wined3d_debug_callback 0x14f8e368: "GL_OUT_OF_MEMORY error generated. Failed to allocate memory for buffer object.".
err:d3d:buffer_create_buffer_object Failed to bind the VBO with error GL_OUT_OF_MEMORY (0x505)
err:d3d:buffer_create_buffer_object Failed to create a vertex buffer object. Continuing, but performance issues may occur
err:d3d:wined3d_debug_callback 0x14f8e368: "GL_OUT_OF_MEMORY error generated. Failed to allocate memory for display list.".
err:d3d_draw:drawStridedFast >>>>>>>>>>>>>>>>> GL_OUT_OF_MEMORY (0x505) from glDrawElementsBaseVertex @ ../../../wine/dlls/wined3d/drawprim.c / 73
err:d3d:wined3d_debug_callback 0x14f8e368: "GL_OUT_OF_MEMORY error generated. Failed to allocate memory for buffer object.".
err:d3d:wined3d_debug_callback 0x14f8e368: "GL_OUT_OF_MEMORY error generated. Failed to allocate memory for buffer object.".
err:d3d:buffer_create_buffer_object Failed to bind the VBO with error GL_OUT_OF_MEMORY (0x505)
err:d3d:buffer_create_buffer_object Failed to create a vertex buffer object. Continuing, but performance issues may occur

Only happens when joining multiplayer servers, but not when doing local games - which is quite confusing. Any thoughts?
RE: GL Out of Memory error?
by Nebbie Zebbie on Saturday November 29th 2014, 23:03
Space Engineers is very memory demanding, and is a bit limited with using 32-bit. It's somewhat common to see "not enough memory to add new objects" while on a server, or even in singleplayer (it used to have memory leaks, which could cause a near empty world to take up all the available memory).
Mouse isn't captured
by Josh on Tuesday October 21st 2014, 13:55
I can't get this windows game to run in windows but I got it to run with all transparent textures and anything.... but when in fullscreen and fullscreen window, My mouse is caught by the game menu or desktop, because I can't go 360 with mouse unless windowed. it collides with the sides of the screen, I've tried every winecfg like cirtual desktop, decorate windows, capture mouse in fullscreen, all that and more.
RE: Mouse isn't captured
by Nebbie Zebbie on Saturday October 25th 2014, 22:28
This has been an issue for a while (a few WINE versions before the ore issue was fixed, I think). Window mode with WINE set to emulate a virtual desktop is the only way currently to get the mouse warp right.
RE: Mouse isn't captured
by Josh on Thursday October 30th 2014, 0:18
Like I said, I tried everything, virtual desktop included.
RE: Mouse isn't captured
by Josh on Thursday October 30th 2014, 13:51
Edit: the latest update of space engineers now runs on my windows partition again! Yay Keen!
RE: Mouse isn't captured
by Andrey Luiz on Monday February 22nd 2016, 19:34
I still can't get the mouse captured properly. Wine 1.7.49 x86, tried wmo=force|enabled|disabled|default. With default, enabled and disabled, the mouse works in the title screen and menus but I can't move 360º in game. With wmo=force, I can move 360º in game but cannot move the mouse in the title screen and menus. I tried with virtual desktop and capture in fullscreen. No success. I have the latest version of Space Engineers. Space Engineers installed through Steam. Any tips?
Sound Temporary Fix
by Rafal on Wednesday October 15th 2014, 13:31
It`s look like a sound files is broken or developers make some mistake in Sandbox.Audio.dll or SharpDX.XAudio2.dll. (Buffer overflow???)

If you change folder name /SteamApps/common/SpaceEngineers/Content/Audio/MUS to /SteamApps/common/SpaceEngineers/Content/Audio/MUS_
game start with sound.
RE: Sound Temporary Fix
by NolanSyKinsley on Thursday October 16th 2014, 1:58
Interesting, I cannot confirm this but that is because of my setup that leads to it's own issues, but this does seem like it works. If anyone else with a standard sound card setup can confirm I will add it to the main report/instructions section.
RE: Sound Temporary Fix
by Rafal on Friday October 17th 2014, 14:00
EDIT 10/17/14:
Update 01.052.023
- fixed small landing gear collision model
- fixed issue: loading world with many asteroids
- fixed crash with meteors in world
- fixed crash caused by turret
- fixed crash in multiplayer when joining/spawning
- fixed crash in factions
- fixed crash in character mods
- fixed crash caused by floating objects
- fixed crash when loading invalid audio file
RE: Sound Temporary Fix
by NolanSyKinsley on Friday October 17th 2014, 17:09
I know, but mind you that is windows, this bug has been present for a long time and I believe the fix stated above was for a recently introduced bug.

I have a USB sound card and from the beginning when I start SE it will kick my card off but I just un plug it and plug it back in and it works, this has never changed for me, even with your fix, so I cannot tell if either today's hotpatch or your fix work because of my non standard setup. Gotta wait for some people to verify the fixes.
RE: Sound Temporary Fix
by Nebbie Zebbie on Saturday October 25th 2014, 22:30
I tried this and it seemed to work, but then upon accidentally restoring the MUS folder, I found that sound actually just works now.
Back