WineHQ

The Settlers IV

Version from gog.com

Includes the original The Settlers® IV and its two expansions: The Settlers® IV: The Trojans and the Elixir of Power and The Settlers® IV Mission CD along with a random map generator.

Application Details:

Version: Gold Edition (GOG)
License:
URL: https://www.gog.com/game/the_s...
Votes: 0
Latest Rating: Silver
Latest Wine Version Tested: 6.0

Maintainers: About Maintainership

Link GOG page Link Widescreen hack (Dropbox mirror) Link Widescreen hack (Mediafire mirror)

Test Results

Selected Test Results

What works

  • Starting the game
  • Closing the game Playing 
  • Singleplayer works fine
  • Texts are on their places

What does not

  • It seems you can't change resolution from 800x600

Workarounds

What was not tested

  • sound 
  • Multiplayer
  • extended gameplay


Hardware tested

Graphics:

  • GPU: Nvidia
  • Driver: unknown

Additional Comments

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
CurrentUbuntu 20.04Jan 16 20216.0Yes Yes NoSilverMarek 
ShowArch Linux x86_64Apr 01 20183.3Yes Yes NoBronzeStefan Naumann 
ShowUbuntu 16.04 "Xenial" amd64 (+ variants like Kubuntu)Jul 27 20172.13Yes Yes GoldAaron Franke 
ShowMac OS X 10.11 "El Capitan"Mar 01 20161.8.1Yes Yes Goldan anonymous user 
ShowFedora 22 x86_64Jun 26 20151.7.44Yes Yes Platinuman anonymous user 

Known Bugs

Bug # Description Status Resolution Other apps affected
42270 Settlers 4 Gold - Hardware Rendering mode not working UNCONFIRMED View

Show all bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

not working under actual wine
by Hirntot on Monday April 24th 2017, 2:26
be aware that you might have to downgrade wine.
It didn't work with the actual wine (04/2017) but with an old version (in my case to 1.7.17, just out of a mood) it worked fluently.
RE: not working under actual wine
by Aaron Franke on Monday April 24th 2017, 16:48
Have you tested multiple wineprefixes? I haven't experienced any issues myself. If you believe there is a regression, please look into it and report it!
RE: not working under actual wine
by Hirntot on Tuesday April 25th 2017, 6:20
well, I would have deleted my previous post right after posting, but I couldn't find a button for that.

No, I didn't use any wineprefix.
I installed it via PoL (yeah, that was one of the reasons why I wanned to delete my poste on winehq), trying scripted and non-scripted ways, and the best I got was a black screen but with game sound and mouse klick feedback and everything (but sometimes it also crashed while installation). So I searched for solutions for hours and days. and then somehow, based on some recommendations from Anno1604 (wasn't it called like that? anyway), I came to the idea to try other wine versions. I chose 1.7.17 and it worked just fine. If I just had tried that while installing, I would have finished quite a few missions more by now!

Since you do have the only "support" for the gog version (my original Gold Edition ist recently out of reach), I thought I might be doing well in posting my experience here, assuming that it should be the same with direct wine installation.

What do you mean about the regression? how should I look into that and report it? Since it is an old game and not supportet under win10 either I shouldn't be surprised that some DLLs from actual wine versions might be different.
RE: not working under actual wine
by Aaron Franke on Tuesday April 25th 2017, 10:18
PlayOnLinux is not officially supported. Please don't post unless you have tested with vanilla Wine as well.

And, FYI, PlayOnLinux's "virtual drives" are just another word for wineprefixes.
Back