WineHQ

Adobe Digital Editions

No Screenshot

Submit Screenshot
Version 4.5

Application Details:

Version: 4.5
License: Free to use
URL: http://www.adobe.com/products/...
Votes: 0
Latest Rating: Gold
Latest Wine Version Tested: 2.0.3

Maintainers: About Maintainership

Free Download Official Adobe Digital Editions Download Page

Test Results

Selected Test Results

What works

ADE 4.5 must be installed under a 32bit wine prefix, I first tried to install it as 64bit but failed.

System: openSUSE Leap 42.2

Wine:1.8.6-15.1 from openSUSE-Leap-42.2-Update

Setup: WINEPREFIX="$HOME/prefix32" WINEARCH=win32 wine wineboot

Install: winetricks adobe_diged4


Could connect to Adobe server, introduce my Adobe ID, and lend books from www.leo-sued.de

It is also possible to read ebooks on the Linux PC.

What does not

When connecting my "tolino" eBook reader, it does not show up in the sidebar of ADE, making it impossible to transfer any ebook from the Linux PC to the ebook reader.

When connecting a USB mass storage device, e.g. a USB stick or "tolino" ebook reader, this device automatically gets a drive letter and a symlink under dosdevices, e.g. h: -> /run/media/user/tolino

However the type of this device is "Autodetect" which does not work with ADE 4.5 since it requires type "Floppy disk"

Workarounds

Setup wine for 32bit, e.g. export WINEPREFIX="$HOME/prefix32" WINEARCH=win32

Connect your ebook reader via USB with the Linux PC.

Start winecfg and select tab "Drives" and enable "Show Advanced"

Select the appropriate drive letter of the ebook reader, e.g. h:

Its type usually is "Autodetect"

Copy the "Path" of the device, e.g. /run/media/user/tolino, the REMOVE this drive! (On my system I first tried several times to change the drive type from "Autodetect" to "Floppy disk" but it always returned to "Autodetect" whenever wine was restarted)

ADD a new drive, e.g. with drive letter "g:" and paste the device path into "Path"

Select type "Floppy disk"

Leave winecfg with OK

When starting ADE 4.5 the next time, your ebook reader should show up at the left side, above the library entries.


What was not tested

N/A

Hardware tested

Graphics:

  • GPU: Unknown
  • Driver: open source

Additional Comments

Sorry for choosing the wrong wine version, but the web page did not allow to choose 1.8.6, so 2.0.3 was the nearest. Since SuSE Leap 42.2 does not provide a newer version, this should still be selectable!

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
CurrentopenSUSE Leap 42.2 x86_64Dec 28 20172.0.3Yes Yes YesGoldPlexar 
ShowUbuntu 7.10 "Gutsy" amd64 (+ variants like Kubuntu)Oct 30 20172.19-stagingYes Yes YesGoldAndrew Fister 
ShowSlackware64 14.2 multilibApr 01 20172.5Yes Yes GoldZootal 
ShowLinux Mint 18 "Sarah" x86_64Oct 01 20161.9.20Yes No GarbageJonas Abrahamsson 
ShowLinux Mint 17.3 "Rosa" x86_64Jul 23 20161.8.3Yes Yes SilverKimme Utsi 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

Adobe Digital Editions 4.5 is already running
by Yingtong Li on Monday August 14th 2017, 8:47
Had the same issue as other posters with the "Adobe Digital Editions 4.5 is already running" error on install. This was an issue with the Adobe Digital Editions 4.5.6 installer from the Adobe website. I was able to avoid the problem by downgrading to the 4.5.0 installer from filehippo.com/download_adobe_digital_editions/comments/63548/ which did not suffer from this issue.
Adobe Digital Editions 4.5 is already running
by Charles on Thursday July 13th 2017, 1:13
Same problem. Diagnostic info:
System information:
Wine build: wine-2.0.1
Platform: i386 (WOW64)
Version: Windows 7
Host system: Linux
Host version: 4.4.0-83-generic

Have not filed a full bug report ~ should I? this seems to be a common problem

Cheers
Charles
RE: Adobe Digital Editions 4.5 is already running
by Geremia on Tuesday July 25th 2017, 12:31
Yes, report it. I get this issue, too, on Wine 2.13, when installing ADE with "winetricks adobe_diged4" on a clean wine prefix.

I also noticed that at least Wine 2.12 and 2.13, ADE 4.5 said that it was not connected to the internet. It was working on previous versions of Wine.
RE: Adobe Digital Editions 4.5 is already running
by Charles on Thursday November 9th 2017, 23:12
Ok, after much messing around, I fully removed any and all WINE related from PC.
Reinstalled wine from wiki.winehq.org/Ubuntu (NB enable 32 bit architecture ~ I done this previously)
Reinstalled Winetricks from Software Centre
When Winetricks has finished installing it comes up with an options page ~ select install an app
Select Adobe Digital editions
Click OK .....
..... and it just worked fine :)
So I have no idea what I did wrong previously, or specifically what I did right this time to fix it.
RE: Adobe Digital Editions 4.5 is already running
by Charles on Friday November 10th 2017, 22:31
Ooops - I spoke too soon. Yes it install ADE, but version 1.x which is incompatible with my library source which requires at least V3.x

Any ideas?
Adobe Digital Editions 4.5 is already running.
by Jay Fault on Thursday July 6th 2017, 16:22
Corefonts is installed, dotnet40 is installed, 32 bit wineprefix on 64 bit host

I get the error when installing saying "Adobe Digital Editions 4.5 is already running. Please close Adobe Digital Editions 4.5 and try again"
RE: Adobe Digital Editions 4.5 is already running.
by Dave Updegraff on Tuesday July 11th 2017, 10:13
Same here; wine 2.11, Fedora 25 as well as Fedora 26. This results when attempting just 'wine ADE_4.5_Installer.exe'.

If instead, use the suggested ' winetricks adobe_diged4' blows up with a box titled "Microsoft .NET Framework 4 Setup" saying that "..Same or higher version of .NET Framework has already been installed you your computer", hence installation will not occur. That in turn ends the session, with wine spitting out the epitaph :
--snip----
Executing winetricks_early_wine regedit C:\windows\Temp\_dotnet40\set-winver.reg
------------------------------------------------------
dotnet40 install completed, but installed file /home/dave/.wine/dosdevices/c:/windows/Microsoft.NET/Framework/v4.0.30319/ngen.exe not found
------------------------------------------------------
--snip--

which is a bit odd, cuz....

$ ls -la /home/dave/.wine/drive_c/windows/Microsoft.NET/Framework/v4.0.30319/ngen.exe
-rwxrwxr-x. 1 dave dave 1032 Jul 8 06:40 /home/dave/.wine/drive_c/windows/Microsoft.NET/Framework/v4.0.30319/ngen.exe

In both cases, the suggested workaround of using winecfg to set 'Emulate a virtual desktop' is in force.

So either way, never get out of the starting blocks at all.
Black screen unless you run it in emulated virtual desktop.
by Zootal on Sunday April 2nd 2017, 0:43
If you do not run this in an emulated virtual desktop, you might get a black screen and be unable to use the application. You must run winecfg and set it to Emulate a virtual desktop, found on the graphics tab. I selected 1440x900, and it works fine.
Ade 4.5 does work in Mint 18.1 with some fine tuning
by Peter Domjan on Tuesday January 31st 2017, 21:06
Using notes supplied by Kimme Utsi for Mint 17 as a basis and also from techmint.com installed wine version 1.8.6 from ppa:jonathanf/wine and wintricks version 20170101 and finally wine32
Created a clean 32bit environment and installed ADE_4.5 as downloaded from adobe.com web site. I declined the offer of Norton anti virus . Started ade from icon and authorized as usual then happily dowloaded epub books from local library
All this was done after a clean install of Linux Mint 18.1
Loading
by Lee Kierstead on Saturday June 25th 2016, 13:47
If my device is mounted beforehand it can take over 20 seconds for ADE to load. Your mileage may vary.
Back