WineHQ
Category: Main Games Thumper Steam

Thumper

Application Details:

Version: Steam
License:
URL:  
Votes: 0
Latest Rating: Bronze
Latest Wine Version Tested: 3.6-staging

Maintainers: About Maintainership

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Gameplay seems to be working perfectly and I'm getting a stable framerate.

What does not

Visuals glitch out, not a problem for playing the game but it's less eye candy and can be annoying to some

Workarounds

What was not tested

Anything after Level 4.

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

Missing character + background + possibly more effects - boss transition is not rendering at all http://i.imgur.com/AA5LeXT.png

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowopenSUSE Tumbleweed (rolling release)Apr 20 20183.6-stagingYes Yes NoBronzeConnor Fernandez 
ShowUbuntu 17.10 "Artful" amd64 (+variants like Kubuntu)Mar 29 20183.0N/A Yes YesSilverTristan 
ShowArch Linux x86_64Sep 26 20172.17N/A Yes YesSilverambidot 
ShowManjaro LinuxMar 28 20172.4Yes Yes GoldJeff V 
ShowUbuntu 16.10 "Yakkety" amd64 (+ variants like Kubuntu)Feb 20 20172.2Yes Yes SilverTristan 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

DX11 works with DXVK 0.54
by Ulath on Friday June 15th 2018, 6:24
When using wine 3.9 with DXVK 0.54 ( github.com/doitsujin/dxvk/releases ) the DX11 version of the game works flawlessly (without graphics glitches) here (gentoo linux, 4.16.11 kernel, nvidia proprietery driver).
Level 3-1 works
by Ulath on Thursday June 14th 2018, 16:22
It works, you just need to get the new game element (pressing down on a pad, see steamcommunity.com/app/356400/discussions/0/154645299388678993/)

by Maxim Lebedev on Monday February 20th 2017, 7:19
Same problems under wine 2.2. Strange.
RE:
by Tristan on Monday February 20th 2017, 17:20
I'm thinking it may be a problem with differing graphics hardware. I just tested on a laptop using Intel HD Graphics. On this laptop, the game will not launch normally, and will say it failed to initialize shaders. Using the DirecX 9 legacy version of the game, I have the same problems with the missing beetle and track.

Meanwhile on my main gaming PC with an Nvidia GTX 760, everything works fine. I don't have any AMD hardware to test on, so unless you have AMD graphics, I don't know if they work or not with this game.
RE:
by Maxim Lebedev on Tuesday February 21st 2017, 5:22
I have a card Geforce GTX650 and I set antialiasing on the x2 and above (otherwise the bumper corners and other game objects become transparent, and the part of the route loaded only when the beetle is on them).
RE:
by Tristan on Tuesday February 21st 2017, 11:27
Interesting... Are you using the Nvidia drivers? If so, what version? I'm on 367.57 from the Ubuntu repository.
RE:
by Maxim Lebedev on Tuesday February 21st 2017, 14:15
Yeah, I use nvidia-378.13-0ubuntu0~gpu16.04.3 driver.

P.S.: I forgot attach a record to the previous comment regarding the glitches and visibility of objects when antialiasing is zero. Here it is: www.youtube.com/watch?v=I_c2AX4BqOY

by Maxim Lebedev on Thursday February 16th 2017, 15:31
Perhaps there is a dependence from distro, since I launched the game on a completely new and clean prefix. Quick proof: imgur.com/a/aPueR
Between normal version of the game and experimental is no difference.
Back