WineHQ

Sid Meier's Civilization VI

No Screenshot

Submit Screenshot

All versions, including Steam, with any DLC

Application Details:

Version: All
License: Retail
URL: https://www.civilization.com
Votes: 4
Latest Rating: Garbage
Latest Wine Version Tested: 5.10-staging

Maintainers: About Maintainership

Link Steam store page

Test Results

Selected Test Results

What works

This is the free game from Epic Games.

Launcher starts, choose DX11, splashscreen, then blank

What does not

Blank screen after starting game.

Workarounds

Found debug logging in ~/My Games/Sid Meier's Civilization VI (Epic)/Logs

There where alot of problems with LUA and database. Copied all the lua script to expected locations (as  reported by logging).

For some reason the include function doesnt work resulting in many errors such as:

Runtime Error: Z:\mnt\Epic\SidMeiersCivilizationVI\Base\Binaries\Win64EOS\Options.lua:42: attempt to index a nil value
stack traceback:
Z:\mnt\Epic\SidMeiersCivilizationVI\Base\Binaries\Win64EOS\Options.lua:42: in function '(main chunk)'
[C]: in function '(anonymous)'
Lua callstack:
Error loading file where=, file=Z:\mnt\Epic\SidMeiersCivilizationVI\Base\Binaries\Win64EOS\Options.lua
Runtime Error: Z:\mnt\Epic\SidMeiersCivilizationVI\Base\Binaries\Win64EOS\CreditsScreen.lua:17: attempt to index a nil value
stack traceback:
Z:\mnt\Epic\SidMeiersCivilizationVI\Base\Binaries\Win64EOS\CreditsScreen.lua:17: in function '(main chunk)'
[C]: in function '(anonymous)'


Lua callstack:
Error loading file where=, file=Z:\mnt\Epic\SidMeiersCivilizationVI\Base\Binaries\Win64EOS\CreditsScreen.lua
Runtime Error: Z:\mnt\Epic\SidMeiersCivilizationVI\Base\Binaries\Win64EOS\My2K.lua:33: attempt to index a nil value
stack traceback:
Z:\mnt\Epic\SidMeiersCivilizationVI\Base\Binaries\Win64EOS\My2K.lua:33: in function '(main chunk)'
[C]: in function '(anonymous)'


What was not tested

playing

Hardware tested

Graphics:

  • GPU: Nvidia
  • Driver: proprietary

Additional Comments

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowDebian GNU/Linux 10.x "Buster" x86_64Jun 19 20205.10-stagingYes No NoGarbagepioruns 
CurrentUbuntu 20.10 "Groovy" (+ variants like Kubuntu)Jun 17 20205.0.1Yes No YesGarbageTed Porandy 
ShowUbuntu 18.04 "Bionic" amd64 (+variants like Kubuntu)May 24 20205.9Yes No NoGarbagePablo Navarro 
ShowArch Linux x86_64May 14 20205.8Yes Yes NoGarbagePaul Black 
ShowUbuntu 19.10 "Eoan" (+ variants like Kubuntu)Feb 10 20205.1Yes No NoGarbageCharles 

Known Bugs

Bug # Description Status Resolution Other apps affected
48621 Civilization 6 crashes on startup. UNCONFIRMED View
49315 Sid Meier’s Civilization® VI remains stuck on a grey screen after the introduction video. UNCONFIRMED View

Show all bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

Installs but won't run
by Reed on Tuesday June 11th 2019, 9:40
I downloaded a Civ 6 .iso and ran `wine setup.exe` successfully only AFTER running `winecfg` and changing the windows version to Windows XP. I run LaunchPad.exe in WINE & it will load one screen but crashes before continuing into game. Done troubleshooting for now.

Getting these errors:


Setting breakpad minidump AppID = 265930
Steam_SetMinidumpSteamID: Caching Steam ID: 4294967296 [API loaded no]
[376:377:0611/093751.172:ERROR:network_change_notifier_win.cc(157)] WSALookupServiceBegin failed with: 8
[376:377:0611/093751.376:ERROR:gpu_process_transport_factory.cc(1019)] Lost UI shared context.


01c8:err:winediag:MIDIMAP_drvOpen No software synthesizer midi port found, Midi sound output probably won't work.
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 10 (X_UnmapWindow)
Resource id in failed request: 0x2e00003
Serial number of failed request: 674
Current serial number in output stream: 686
Back