WineHQ

Star Wars: The Old Republic



Knights of the Eternal Throne expansion first week release.

Application Details:

Version: 5.0a
License: Retail
URL: http://www.swtor.com
Votes: Marked as obsolete
Latest Rating: Gold
Latest Wine Version Tested: 2.0-rc4

Maintainers: About Maintainership

Free Download Star Wars - The Old Republic homepage

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Everything so far.

Performance is very good.

What does not

Workarounds

What was not tested

The actual endgame content.

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

I've installed the game with the PlayOnLinux installer, it works perfectly. SWTOR_fix is still needed to run, but also integrated in the POL installer. First I ran into some trouble with the game loadup times it took about 30min to get in character creation. But I found a fix for this: The trick is to change the PlayOnLinux working drive to your secondary diskdrive. Follow this guide: http://wiki.playonlinux.com/index.php/How_to_move_PlayOnLinux_virtual_drives_to_another_disk My guess is that there are problems with permissions on the primary drive.

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowmacOS 10.12 "Sierra"Jan 10 20172.0-rc4Yes Yes GoldSean McNamara 
CurrentUbuntu 16.10 "Yakkety" amd64 (+ variants like Kubuntu)Jan 14 20172.0-rc3Yes Yes Goldbckmschng 
ShowAntergos x86_64Dec 28 20162.0-rc2Yes Yes GoldDarren Lachambre 
ShowUbuntu 16.04 "Xenial" amd64 (+ variants like Kubuntu)Dec 04 20161.9.23Yes Yes GoldSean McNamara 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

If your characters look stretched and "hobbit-like"
by Irvin McWhorter on Saturday January 21st 2017, 18:56
If the aspect ratio is messed up making all your characters look fat and stubby but your UI is normal, you can fix it by turning on virtual desktop to match with your screen resolution you have set.

To set the screen resolution, you edit the "client_settings.ini" file by editing the "Width" and "Height" settings. For example: "Width=1024" "Height=768". You can find the file located at: /home/*YOUR USERNAME*/PlayOnLinux's virtual drives/SWTOR/drive_c/users/*YOUR USERNAME*/Local Settings/Application Data/SWTOR/swtor/settings.

Oh yeah, it's a lot easier if you use PlayOnLinux.

by bckmschng on Saturday January 7th 2017, 8:04
Has anyone get this to work?
I'm new to Wine and could need some help to get this to run :(
RE:
by Sean McNamara on Tuesday January 10th 2017, 1:48
Hi,

Can you be a little more specific? Several of us are running it successfully, yes. On the proper hardware, and assuming you have correctly functioning graphics drivers, it runs with performance similar to Windows. You might have to tweak the config file "client_settings.ini" to reduce graphics settings to get it to run, though.

What OS are you running? What version of wine (wine --version)? How far do you get before it doesn't work as you expected?
RE:
by bckmschng on Friday January 13th 2017, 10:20
Sorry, forgot to post my specs.

OS: Kubuntu 16.10 64bit
2x SSDs with 258 gb
RAM: 16gb
GPU: Radeon R9 390 with latest Mesa drivers
Wine versions: 2.0.0 RC 3 - staging and tried others like 1.9.24

I'm basically at the point where swtorfix.exe works as intended, press the "play" button but than it doesn't load up and sometimes in 30 minutes at least.
RE:
by bckmschng on Thursday January 12th 2017, 10:41
I'm stuck at the part but even with swtor.fix it does not load up.
the last time it needed about 30 minutes to load up.

swtor-fix console shows:
Waiting for swtor... Found, PID: 164 Waiting for threads to end..
Found, PID: 164 Waiting for threads to end..
Waiting for threads to end..
waiting for threads to end swtor fix


The ssd is working all the time and nothing happens. What could be the problem? :(
RE: FIX
by bckmschng on Friday January 13th 2017, 17:30
EDIT: I have fixed the issue. The trick is to change the PlayOnLinux working drive to your secondary diskdrive.
Follow this guide:
wiki.playonlinux.com/index.php/How_to_move_PlayOnLinux_virtual_drives_to_another_disk
Than install the game with the normal POL installer
The game will launch exactly as it should

My guess is that there are problems with permissions on the primary drive.
minimap bug?
by Jen on Saturday December 10th 2016, 20:15
Did they fix the bug, where it crashes if you click on the minimap?
RE: minimap bug?
by Darren Lachambre on Wednesday December 28th 2016, 20:52
I can click on the minimap, no problem.
RE: minimap bug?
by Geriain on Saturday December 31st 2016, 2:58
I can confirm that at least with wine 2.0-rc3 the minimap bug is gone. And I have to admit that the performance is very good compared to former versions.
Back