WineHQ

WISO (Steuer) Sparbuch

Application for filling out tax return for year 2017

Application Details:

Version: 2018
License: Retail
URL: http://www.buhl.de
Votes: 0
Latest Rating: Gold
Latest Wine Version Tested: 3.0.3

Maintainers: About Maintainership

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

everything except the internal update feature

Automatic tax data retrieval

What does not

installing updates from within the application.


Workarounds

Updates must be downloaded and installed manually

WISO Web

What was not tested

#Data acqusition from 2017

Hardware tested

Graphics:

  • GPU: Nvidia
  • Driver: open source

Additional Comments

Installed in clean win32 prefix with no extra dlls, etc.

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowUbuntu 18.04 "Bionic" amd64 (+variants like Kubuntu)Sep 22 20183.0.3Yes Yes YesGoldUwe 
ShowManjaro Linux 17.0.2Mar 26 20183.4Yes Yes YesGoldsunito 
ShowUbuntu 16.04 "Xenial" i386 (+ variants like Kubuntu)Feb 28 20183.2Yes Yes NoBronzePatrick Neise 
ShowDebian GNU/Linux 9.x "Stretch" x86_64Feb 03 20183.0Yes Yes YesGoldMarkus 
ShowUbuntu 17.10 "Artful" amd64 (+variants like Kubuntu)Jan 20 20183.0Yes Yes YesGoldOliver 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

HowTo / Notes

Elster working

For a working Elster Interface you have to install lib32-libldap as Florian B. wrote in his comment about his Ubuntu instlallation, https://appdb.winehq.org/objec...

May be this is enough 
pacman -S lib32-libldap


Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

Use an emulated desktop if you don't see anything
by Martin Kunz on Saturday April 27th 2019, 13:36
Actually a comment for WISO steuer:Start2019 (which seems to be technically identical to steuer:Sparbuch2019): If you don't see any output, run winecfg and enable a virtual desktop under "Graphics". Took me hours to find this simple solution.
Sendebericht / Transmission report
by albert on Wednesday August 1st 2018, 1:05
Does anybody know how to get a transmission report, especially for all the VAT related transmissions?
had to install lib32-libldap
by sunito on Monday March 26th 2018, 5:32
I had the same problem when trying to connect to Elster:
"Die ELSTER - Schnittstelle der Finanzverwaltung konnte nicht geladen werden."
This disappeared, after installing lib32-libldap as done by Florian. However, I did not
have to tweak any DLL settings.
It works fine
by Florian B on Friday February 2nd 2018, 16:37
I could install and use the WISO steuer:Sparbuch2017 but had some trouble getting the Elster Abruf to work.

Solution:
First of all i had to install it in a 32bit wineprefix and had to install lib32-libldap on my arch linux machine. After some further debugging I had to overwrite the libraries msvcp140 and vcruntime140 with winecfg. Afterwards the Elster Abruf worked like a charm.
RE: It works fine
by Matthias on Thursday March 8th 2018, 4:53
Could you provide some more details of your solution? I'm specifically interested in:

* How did you determine that lib32-libldap was needed?
* What kind of debugging did you do and how did it lead you to the conclusion that msvcp140 and vcruntime140 needed to be replaced?
* What was the source for your replacement msvcp140 and vcruntime140?
RE: It works fine
by agremB on Wednesday May 16th 2018, 10:17
Hi Matthias,

I had the same problem on ubuntu with wine3. I fixed it with the following steps:
- open winecfg
- go to libraries
- add msvcp140 and vcruntime140
- set both to 'native'
- apply

and then Elster worked for me. There was no need to install any additional libldap since it was already available with the package libldap-2.4-2:i386.

Hope I could help you a bit!
No Elster; No Videos
by Patrik Wolf on Monday January 29th 2018, 14:33
I have the same problem.
The Elster module cannot be loaded.
But experience shows that this will be fixed in future (Buhl.de)- updates.

I've never been able to play the videos.
an error message from Youtube always appears:
"Es ist ein Fehler aufgetreten. Bitte versuche es später noch einmal."

Do you know any workaround?

I use Wine 3.0 (32bit) over PlayOnLinux on Debian stretch (9.3) (amd64)
RE: No Elster; No Videos
by Markus on Saturday February 3rd 2018, 10:17
I have exactly the same issue and I opened a support ticket at Buhl. Let's have a look what happens.
By the way: I have that issue using the software with WINE and as well running the software in a virtual machine with a WIndows 7 installation.

Wine 3.0, Debian stretch, (amd64)
Elster not working: ericapi.dll can't be load
by Olaf Hoffmann on Friday January 26th 2018, 2:59
I updated to Wine 3.0 stable, still using ubuntu 16.04 - but the "Belegabruf" does not work.

- All credentials (Buhl account and Elster-Certificate) are filled in
- Nothing happens by click on Button "Belege abrufen".
- In Window "Manuellen Belegabruf einrichten" following Error Window is coming up after click on "Anmelden":
"Elster Schnittstelle nicht verfügbar - Die Elster Schnittstelle der Finanzverwaltung (ericapi.dll) konnte in dem Ordner C:\Program Files (x86)\WISO\Steuersoftware 2018 nicht geladen werden."
- "ericapi.dll" _is_ in the directory
- I tried to update WISO, but no update necessary

Anyone an idea?
RE: Elster not working: ericapi.dll can't be load
by Oliver on Friday January 26th 2018, 12:34
Firstly, i had the same issue. But after a while (i think after downloading all updates from www.buhl.de/updates.html ) the error removed.

Windows 7?

Should we compare in winecfg the dlls?
RE: Elster not working: ericapi.dll can't be load
by Olaf Hoffmann on Sunday February 11th 2018, 10:45
Oliver,
thanks for reply. I waited for the next buhl update, but it didn't change anything. All testers use newer Ubuntu-Versions, so my intention is to wait for the LTS-Upgrade (April, 26th) - maybe this will be the solution. If not, I try other ways.
installing wine 3.0-rc5 on Ubuntu 16.04.2 Desktop causes error on reboot
by Andreas Plette on Thursday January 11th 2018, 10:38
I like to install and use "WISO Sparbuch 2018" on my Ubuntu 16.04.2 virtual machine (VMware), so I installed wine 3.0-rc5 following the description on wiki.winehq.org/Ubuntu. To avoid repeating sudo commands, I used these commands:
sudo -I ( + password )
dpkg --add-architecture i386
wget -nc dl.winehq.org/wine-builds/Release.key
apt-key add Release.key
apt-add-repository dl.winehq.org/wine-builds/ubuntu/
apt-get update
apt-get install --install-recommends winehq-devel

Then I was able to successfully install and start "WISO Sparbuch 2018" but after booting the VM the next day I got an error "The system is running in low-graphics mode" which I wasn't able to fix.
I started from scratch (from another copy of my base Ubuntu 16.04.2 image) and just installed wine as described above. Same error after reboot...

Any ideas? Am I missing something?
RE: installing wine 3.0-rc5 on Ubuntu 16.04.2 Desktop causes error on reboot
by Oliver on Friday January 12th 2018, 9:52
Have you tried sudo apt-get install --install-recommends winehq-stable or staging instead of devel?
RE: installing wine 3.0-rc5 on Ubuntu 16.04.2 Desktop causes error on reboot
by Andreas Plette on Friday January 12th 2018, 12:03
I also tried the stable one but I then had issues installing "WISO Sparbuch". After having entered the login credentials for my buhl.de account I got an error reported from the installer ("Es ist ein Fehler aufgetreten. Bitte versuchen Sie es später noch einmal."). Same happens if I go back, take the option "Nein, ich nutze noch kein buhl: Konto" and then enter the "Garantie-Nummer".
Today, I also tried rebooting the VM having the stable version installed. Same issue as reported for the devel version: "The system is running in low-graphics mode".

I also tested the staging version today, again on a new copy of my base Ubuntu 16.04.2 image. Same issue...
Font smothing
by Sascha Peilicke on Monday January 1st 2018, 7:05
Fonts are readable but not smoothed / anti-aliased. Already set font-smoothing via winetricks but the toolkit used for the app might have special settings somewhere...
RE: Font smothing
by Oliver on Tuesday January 2nd 2018, 4:41
Does "winetricks settings fontsmooth=rgb" led to an improvement?
RE: Font smothing
by Sascha Peilicke on Tuesday January 2nd 2018, 4:56
Nope, but switching to Wine 3.0-rc4 improved the situation slightly.

By the way, Elster ist broken with the 2018 version. I'll report that
RE: Font smothing
by Oliver on Saturday January 20th 2018, 14:41
Awesome, it's much better with Wine 3.0

And Elster works :)
Back