WineHQ

Lego Mindstorms EV3 Home Edition

No Screenshot

Submit Screenshot

Lego Mindstorms EV3 Home Edition version 1.3.1

Installer file name: LMS-EV3_Full-setup_1.3.1_en-US_WIN32.exe

md5sum: 2220ad8edab0916170ee023f65834abb

Application Details:

Version: 1.3.1
License: Free to use
URL: http://www.lego.com/en-us/mind...
Votes: 0
Latest Rating: Garbage
Latest Wine Version Tested: 3.0

Maintainers: About Maintainership

Free Download Latest version (1.3.1 at the moment) available here.

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Installer. It installs successfully with both wine-mono and Microsoft .Net 4.0.

What does not

Program does not start with wine-mono. Requires:

winetricks dotnet40

run in a 32-bit Wineprefix.

Program starts with .Net 4.0, but immediately stops, displaying error window with Windows version set to Windows 7, or crashes with Windows version set to Windows XP.

Error windows says: "LEGO MINDSTORMS EV3 has detected a problem during application launch. Press OK to close the application and get more information about fixing the problem."

Workarounds

What was not tested

Program itself.

Hardware tested

Graphics:

  • GPU: Nvidia
  • Driver: open source

Additional Comments

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
CurrentUbuntu 16.04 "Xenial" amd64 (+ variants like Kubuntu)Mar 11 20183.0Yes No NoGarbagemarat 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

Version 1.4.2?
by rik-shaw on Friday April 5th 2019, 0:57
I haven't been able to try it yet but see there is a new version available: le-www-live-s.legocdn.com/downloads/LME-EV3/LME-EV3_Full-setup_1.4.2_en-US_WIN32.exe

Curious if you have given it a try?

by Qwerty Chouskie on Sunday March 11th 2018, 19:33
The issue here is github.com/Winetricks/winetricks/issues/911 , once this is fixed I'll update the EV3 verb to 1.3.1. A workaround may be to use ie6 instead, though this is untested.
Back