WineHQ

ZBrush

No Screenshot

Submit Screenshot

Live Boolean, Vector Displacement Mesh, Lazy Mouse 2.0, Gizmo 3D, etc ...


Look at the Extra comments for the setup in Test Result

Application Details:

Version: 4R8
License: Retail
URL: http://www.pixologic.com
Votes: 0
Latest Rating: Silver
Latest Wine Version Tested: 3.3

Maintainers: About Maintainership

No maintainers. Volunteer today!

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Most basic feature like brush, rendering, etc ... 

Sculpting work well*, save and load too.

* see comment on ALT key below

What does not

  • ALT key work rather oddly but I suppose it because in my case, ALT key is used as shortcut to move windows without clicking on the title bar. I'm using Cinnamon as desktop environment. I didn't test with an other one.
  • It takes few minute to start, less than 2 min on my computer. It takes nearly 20s on Windows.
  • the LightBox menu does not hide automatically.
  • Also, still in the LightBox menu, some preview does not work (for example: the DemoProjects folder supplied with the software is empty for me, not on windows)
  • A crash happened after loading many files but this is not an usual case.

Workarounds

What was not tested

Advanced feature (array mesh, ...)

Hardware tested

Graphics:

  • GPU: Nvidia
  • Driver: proprietary

Additional Comments

To make ZBrush 4R8 work on Wine, you need a very specific setup..

First, you need 64-bit (SysWow64) Wine. Pixologic stopped supporting a 32-bit version, of the ZBrush software, with this release. Ensure you're using a 64-bit Wineprefix ! I recommend you create a new Wineprefix for ZBrush.


You need to install:

winetricks corefonts mfc42 vcrun6 vcrun2008 vcrun2010 vcrun2013 comctl3

and set your Wineprefix to Windows 10 compatibility:

winetricks win10

Now, run winecfg, on your Wineprefix.

On the Graphics tab, enable "Emulate a virtual desktop" and set your desktop size.

On the Libraries tab, you must have these overrides set :

  • atl120 (native, builtin)
  • comctl32 (builtin, native)
  • mfc42 (native)
  • mfc42u (native)
  • msvcp120 (native, builtin)
  • msvcr100 (native, builtin)
  • msvcr120 (native, builtin)
  • msvcr90 (native, builtin)
  • vcomp120 (native, builtin)
  • api-ms-win-downlevel-normaliz-l1-1-0 (native, builtin)
  • api-ms-win-downlevel-shlwapi-l1-1-0 (native, builtin)
  • api-ms-win-downlevel-user32-l1-1-0 (native, builtin)
  • gdiplus (native, builtin)
  • msvcrt (native, builtin)
  • normaliz (native, builtin)
  • ole32 (native, builtin)
  • rpcrt4 (native, builtin)
  • shlwapi (native, builtin)
  • vcomp90(native, builtin)

Apply these, and now, ZBrush should work ;-) .


I'm pretty sure this setup can be improved, by removing unnecessary things. But it took many attempts to get ZBrush working... So I'm just posting my setup as it is. 

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
CurrentDebian GNU/Linux 9.x "Stretch" x86_64Mar 13 20183.3Yes Yes NoSilverubotella 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show open bugs

Comments

Comments Disabled

Comments for this application have been disabled because there are no maintainers.
Back