WineHQ

Mechwarrior Online

No Screenshot

Submit Screenshot

17-APR-2018




  • Solaris 7 Gamemode.
  • Solaris Heros.
  • Fafnir Mechs
  • Bolt-Ons
  • ...

See: PATCH NOTES - 1.4.159.0 - 17-APR-2018.

Application Details:

Version: 1.4.159.0
License: Free to use
URL: http://mwomercs.com/
Votes: 0
Latest Rating: Garbage
Latest Wine Version Tested: 3.6

Maintainers: About Maintainership

Test Results

Old test results
The test results for this version are very old, and as such they may not represent the current state of Wine. Please consider submitting a new test report.
Selected Test Results

What works

Once you actually get into a match everything works great.

What does not

  • Sometimes takes a few tries to start. After you login it's a coinflip whether you will get past the announcement screen but once the "continue" button loads you are good.
  • Game randomly crashes after matched.
  • When switching mechs on the mech select screen most of them will cause the game to instantly hang. You can use the party mech select as an alternative to get around this crash. 

Workarounds

What was not tested

The new Solaris 1v1, and 2v2 content.

Hardware tested

Graphics:

  • GPU: Nvidia
  • Driver: proprietary

Additional Comments

This was actually tested on 3.5, 3.6 and 3.6 wine-staging.

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
CurrentArch Linux x86_64Apr 19 20183.6Yes Yes NoGarbageKyle 
ShowArch Linux x86_64Apr 18 20183.6Yes No YesGarbageDavid Koolhoven 

Known Bugs

Bug # Description Status Resolution Other apps affected
46022 MechWarrior Online (MWO, Piranha games) crashes before login (broken Boost 1.62.0+ boost::context library corrupts TEB 'SubSystemTib') NEW View

Show all bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

games crashes before login
by Anastasius Focht on Friday October 19th 2018, 18:32
The game just works by chance on Windows and maybe Wine.
It's broken in various aspects and due to Wine's design/implementation some bugs are much easier exposed on Linux/Wine.
See bug 46022 for the crash before login.
test data and how to
by John on Thursday April 19th 2018, 13:50
Thank you for testing MWO, it would be more helpful if you could supply a little bit more information on your configuration and how what parameters you used.
For instance the version of Nvidia driver, any additional components and installation method use would be useful.
Another test indicated that there were issue with Wine32 prefix and Wine64 prefix requirements and that dotnet version - dotnet462 -was required.

I would be grateful if you could provide these details and thereby help other users
RE: test data and how to
by Kyle on Tuesday May 15th 2018, 14:54
John - they discontinued 32bit support with the release above so you won't be able to use a 32bit prefix. As for the dotnet version, while I tried to use various versions of dotnet the game ended up actually running smoother when I didn't.

For the in-game settings it simply didn't matter what you had them set too (besides lowering the gpu memory usage with shaders) the problems weren't related to the actual ingame performance. The problems are the menu's, dialogs, and loading.

The most tested Nvidia Driver I used would have been 390.48.x

Short on time, but to give a quick rundown of what I tried (from memory so it'll be a bit vague):
- Different Flash versions
- Multiple recent wine versions (anyone I could find that was claimed as decently stable with 64bit), wine-staging, and dxvk-wine patches.
- Different dotnet versions
RE: test data and how to
by Richard H on Friday September 14th 2018, 19:27
I'm testing it on Wine Staging 3.16-1. On Wine Development 3.6, the game fails to initialize. The Steam version with Proton 3.7 beta also crashes at the same spot. There has been luck getting the game to get past the Nvidia crash when the Saved Game folder in the C:\Users section is deleted prior to launching it. It also includes Shaders, user profile and preferences, and logs in that folder.

The game reports a Radeon 460 for my video card.
OpenGL renderer string: Radeon RX 560 Series (POLARIS11 / DRM 3.26.0 AMD 18.20 / 4.18.7-041807-generic, LLVM 6.0.1)

The game crashes shortly after the Nvidia splash screen and right before the logon screen. Here are a few output extracts that I see right before the crash. The messages before the crash mention Shaders, DSound, DInput, DVP Client Compression Types.

Even the latest DXVK and a few previous version back to 0.52 don't improve the chances of the game working but it does let it run better when it does work.

These are the Winetricks I install. I tried using Winetricks to install .Net 4.5.1 and also 4.6.2 but either the Portal or Game wouldn't run and the Portal and the game work best with doing .Net 40 then letting the game install 4.5.1.

Windows 7
corefonts
tahoma
dotnet40
d3dx9_43
d3dx11_43
dinput
directplay
dsound
flash
msxml3
msxml4
msxml6
quartz
vcrun2010
test data and how to
by John on Thursday April 19th 2018, 13:47
Thank you for testing MWO, it would be more helpful if you could supply a little bit more information on your configuration and how what parameters you used.
Did you install any other components bar the dotnet version mentioned for instance or other specific information
Back