WineHQ

Steuer-Spar-Erklärung

Steuererklärung für 2018 (German tax program for 2018)

Application Details:

Version: 2019
License: Retail
URL: http://www.akademische.de
Votes: 0
Latest Rating: Gold
Latest Wine Version Tested: 4.0.1

Maintainers: About Maintainership

Link Homepage Free Download Eingeschränkte Testversion (kann für ca. 25 € freigeschaltet werden) / restricted test version (may be released for about 25 €)

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Installation läuft durch, allerdings crashed SSE dann gleich beim Start.

What does not

Crash beim Startup.


rd@h370:~$ ./sse24.sh          
wine: Call from 0x7b43cb73 to unimplemented function ucrtbase.dll.__processing_throw, aborting
0039:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0033:err:ntdll:RtlpWaitForCriticalSection section 0x7fa52580 "freetype.c: freetype_cs" wait timed out in thread 0033, blocked by 0009, retrying (60 sec)
./sse24.sh: Zeile 6:  5631 Getötet                env WINEPREFIX=$WP $WINE $WP/drive_c/Program\ Files/Akademische\ Arbeitsgemeinschaft/SteuerSparErklaerung\ 2019/SSE.exe
rd@h370:~$

Ich habe sowohl mit 32-bit als auch 64-bit Prefix probiert und auch einige Pakete mit winetricks installiert, half alles nichts.

Schade, dass es die Akademische immer wieder bis zur nächsten Version schafft, inkompatibel zur Stable Wine-Version zu sein.

Workarounds

What was not tested

Ich habe die SSE nur versucht zu starten. Mit wine-3.20 habe ich Datenübernahme durchgeführt, etwas editiert und mit das (hypothetische Ergebnis angeschaut)

Hardware tested

Graphics:

  • GPU: Intel
  • Driver: open source

Additional Comments

Mit wine-3.20 ist die SSE fehlerfrei gestartet (64 bit Prefix).

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowDebian 10.x "Buster"Aug 08 20194.0.1Yes Yes YesGoldMarkus 
ShowUbuntu 18.04 "Bionic" amd64 (+variants like Kubuntu)May 15 20194.0.1Yes Yes YesGoldTony Huth 
ShowopenSUSE Tumbleweed (rolling release)May 03 20194.7Yes Yes YesSilverKai 
ShowArch Linux x86_64Nov 09 20183.19-stagingYes Yes YesGoldStephan Windmüller 
CurrentDebian 10.x "Buster"Dec 01 20183.0.3Yes No NoGarbageRainer Dorsch 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

Statt Update neueste Version drüberinstallieren
by Johannes Tielmann on Tuesday July 2nd 2019, 13:23
Danke für den Tipp! Das hat sofort funktoniert.
Den Tipp solte man in die obige Installationsdoku mit aufnehmen.
Der Installationsbefehl im Terminal ist dann z.B.:
WINEPREFIX=~/.wine-sse2019 wine ~/Downloads/Win-SteuerSparErklaerung_24.31.122.exe
Update funktioniert nicht
by Johannes Tielmann on Tuesday July 2nd 2019, 12:25
Die Erstinstallation (9.6.2019) nach der Anleitung in einer PREFIX-Umgebung hat funktioniert und war lauffähig. Steuerdaten konnten eingegeben werden.
Beim Aufruf des Programmes heute (2.7.2019) wurde vom Programm verlangt, ein Update durchzuführen. Das ist fehlgeschlagen. Danach wurde die Installation als beschädigt ausgewiesen mit der Aufforderung zur Deinstallation und Neuinstallation.
Deinstallation und Neuinstallatioon liefen durch bis zur erneuten Aufforderung das Update zu laden.
Fehlermeldung:
"Die Installation von >Update 24.31.122< konnte nicht durchgeführt werden! Prüfen Sie bitte, ob die notwendigen Installationsvoraussetzungen erfüllt sind."
Was ist zu tun?
RE: Update funktioniert nicht
by Stephan Windmüller on Tuesday July 2nd 2019, 12:30
Einfach die aktuelle Version von der Homepage herunterladen und drüber installieren.
Schwarze Options- und andere Unterfenster auf grauem Hauptfenster
by Dr. Werner Fink on Sunday April 14th 2019, 4:52
sehe ich mit wine 3.7, hatte das aber auch schon mit älteren wine und SteuerSpar-Versionen. Meist hilft es, das Fenster in der Größe zu verändern oder kurz ein anderes Fenster darüber zu legen. Mit opengl/gdi hat es nichts zu tun.
Leider kann ich hier kein png anhängen
Fragen
by Johannes Erhardt on Sunday March 17th 2019, 5:44
Liebe Steuer-Sparer,

ich bin gerade am Installieren der neuen Version (24.25.100) und hätte dazu einige Fragen

1. Auf welche Windows-Version habt ihr eingestellt? 8.1 oder 10?
2. Die diversen Programme, die früher mit installiert werden mussten, wie cabeextract , bind etc, sind die nicht mehr nötig? Oder habt ihr schon vergessen, dass die von älteren Installationen noch auf der Platte sind?
3. Ein 64-bit Prefix ist ok? Kein 32 nötig?
4. Beim ersten Installationversuch mit Wine stable 3.6 über Ubuntu 18.04 kamen beim Erstellen des Prefixes Fehlermeldungen, dass Gecko nicht herunter geladen werden könnte. Auf der Download-Seite von WineHq steht das auch. Habt ihr Gecko manuel geladen? Welche Version?
5. Nach Installieren der SteuersparErklärung wurde ein Update angeboten. Nach nicht mal einer Sekunde hiess es, alles sei auf dem neuesten Stand. Früher dauerten die Updates viel länger. Nach 3 Monaten denke ich schon, dass da neuere Versionen sein sollten. Heisst das, das Update hat nicht geklappt? Oder komemn die Aktualisierungen jetzt in kleineren Häppchen, nicht mehr gleich das ganze Programm?

Für Antworten wäre ich dankbar


Johannes
RE: Fragen
by jre on Monday March 18th 2019, 13:16
1. Ist glaub ich egal, nimm einfach den Standard (Win 7, glaub ich).
2. cabextract brauchst du vielleicht für winetricks, für die SSE selber aber nicht. Mit bind meinst du winbind? Nein, brauchst du auch nicht nicht.
3. 64-bit funktioniert, ja.
4. Das ist eine allgemeine Meldung, die immer kommt. wine-gecko brauchst du für die SSE nicht. (Wine 3.6 ist übrigens eine development Version, keine stable.)
5. Wenn du den SSE-Installer frisch runtergeladen hast (und du schreibst ja selber dass du die aktuelle 24.25.100 installierst), hast du bereits die aktuelle Version. Oder installierst du von CD und willst auf die 24.25.100 aktualisieren? Die Updates kommen glaub immer noch alle paar Wochen und haben ein paar hundert MB.

Oder mit anderen Worten, alles was du brauchst ist:

winetricks riched20 crypt32 mspatcha vcrun2017
winetricks fontsmooth=rgb ...
by Rainer Dorsch on Sunday December 2nd 2018, 7:52
... hilft auch bei wine 3.0.3 :-)
vcrun2017 hat gefehlt
by Rainer Dorsch on Sunday December 2nd 2018, 7:43
Danke für die Info, kann hiermit bestätigen, dass vcrun2017 gefehlt hat, damit läuft SSE bei mir auch unter 3.0.3

Derzeit ist mir unklar, ob die für devel beschriebenen winetricks

- Formularanzeige funktioniert nach "winetricks riched20 crypt32"
- Schriften korrekt dargestellt nach "winetricks fontsmooth=rgb"

auch bei Stable Sinn machen oder eher schaden (?).
Absturz beim Start der SteuerSparErklärung unter Wine 3.0.3 (stable)
by jre on Saturday December 1st 2018, 15:57
Wine 3.0.3 (stable) stürzt beim Start der SteuerSparErklärung ab:

~~~~~
wine: Call from 0x7b43cb73 to unimplemented function ucrtbase.dll.__processing_throw, aborting
~~~~~

Behoben ist dieses Problem seit der Entwicklerversion 3.5.

Mit Wine 3.0.3 konnte ich die SteuerSparErklärung starten, nachdem ich einmalig folgenden Befehl ausgeführt hatte:

~~~~~
winetricks vcrun2017
~~~~~

Weiter getestet habe ich aber nicht.
Back