WineHQ

Elite Dangerous

No Screenshot

Submit Screenshot

The latest version of Elite: Dangerous on Steam or the standalone launcher.

Application Details:

Version: Latest
License: Retail
URL: http://www.elitedangerous.com/
Votes: 0
Latest Rating: Garbage
Latest Wine Version Tested: 4.11-staging

Maintainers: About Maintainership

Link Steam Store Page Link Elite Dangerous Website

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Launcher after some fiddling.

What does not

The game itself.

Workarounds

Installed corefonts and dotnet45 from winetricks. Set my OS back to Win7 in winecfg as dotnet45 winetrick changes it to 2003. Launcher works great besides some graphical issues.

What was not tested

Anything ingame

Hardware tested

Graphics:

  • GPU: Nvidia
  • Driver: proprietary

Additional Comments

After some struggle getting this to work, launching the game gives some simple fixme warnings of unimplemented DX11 calls, causing a software crash. The most common one being "00b5:fixme:d3d11:d3d_blend_state_create Per-rendertarget blend not implemented." Maybe in a future wine version this will be implemented.

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
Showopensuse leap 15.1Aug 22 20194.11-stagingYes Yes YesGarbagekolAflash 
ShowUbuntu 18.04 "Bionic" amd64 (+variants like Kubuntu)May 29 20194.9Yes No NoGarbageAaron Franke 
ShowUbuntu 18.04 "Bionic" amd64 (+variants like Kubuntu)Dec 27 20184.0-rc3-stagingYes Yes YesGarbageWiborg 
ShowopenSUSE Leap 15.0Dec 24 20184.0-rc3-stagingYes Yes YesGarbagekolAflash 
CurrentArch LinuxJan 12 20183.0-rc6Yes No YesGarbageBrigham Andersen 

Known Bugs

Bug # Description Status Resolution Other apps affected
41972 "Elite: Dangerous" client crashes when starting UNCONFIRMED View

Show all bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

3.3.02 update and more links
by kolAflash on Sunday January 20th 2019, 4:48
Still Silver on openSUSE-15.0 with Elite Dangerous version 3.3.02.

Wine has been updated on my system to version: wine-staging-nine-4.0~rc6
And I also recently updated my DXVK to version 0.95, using: WINEARCH=win64 WINE=/usr/bin/wine64 winetricks --force dxvk
github.com/doitsujin/dxvk/releases
raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks

Actually I already played a lot Elite Dangerous trough Wine in the last weeks. Sometimes little things don't work. But nothing which keeps me from playing and having fun.

Some more help might be found here: lutris.net/games/elite-dangerous/
hints and workarounds
by kolAflash on Thursday September 6th 2018, 16:15
Found some hints here:
lutris.net/games/elite-dangerous/
lutris.net/games/install/9190/view

My current status of workarounds to get the game to load up to 19%.
winetricks dotnet40
winetricks win7
winetricks dsound
winetricks dxvk-0.71/setup_dxvk.verb # from: github.com/doitsujin/dxvk/releases

Launcher works and installs the game (current version as of 2019-09-06 - probably version 3.2.1). But the game crashes on the loading screen at 19% (graphics totally hand - PC still accessible via SSH).

dmesg messages (GPU: Radeon RX 550)
[16753.860126] amdgpu 0000:01:00.0: GPU fault detected: 147 0x05504802
[16753.860129] amdgpu 0000:01:00.0: VM_CONTEXT1_PROTECTION_FAULT_ADDR 0x0003EAAA
[16753.860130] amdgpu 0000:01:00.0: VM_CONTEXT1_PROTECTION_FAULT_STATUS 0x0C048002
[16753.860132] amdgpu 0000:01:00.0: VM fault (0x02, vmid 6) at page 256682, read from 'TC0' (0x54433000) (72)
Notes on DX11 support
by EoD on Wednesday November 2nd 2016, 15:31
I managed to start (not play!) EliteDangerous64.exe ( EliteDangerous/Products/elite-dangerous-64/total/EliteDangerous64.exe )

I required to work around the missing DX11 support, following the advice from: www.gearsongallium.com/?p=2875

Apart form that, I did not manage to get EDLaunch.exe to start.
RE: Notes on DX11 support
by troy on Saturday January 28th 2017, 1:10
confirm.
"winetricks vsm=3 psm=3 gsm=3 d3dcompiler_43 d3dx11_42 d3dx11_43" && "MESA_GL_VERSION_OVERRIDE=4.1COMPAT wine ./EliteDangerous64.exe"
managed to launch black screened window
Back