WineHQ

World of Warcraft

No Screenshot

Submit Screenshot

Patch 8.2 Rise of Azshara Battle for Azeroth

Application Details:

Version: 8.2.0
License: Subscription
URL: http://www.worldofwarcraft.com
Votes: 230
Latest Rating: Gold
Latest Wine Version Tested: 4.11-staging

Maintainers: About Maintainership

Test Results

Selected Test Results

What works

Directx11 with dxvk and Directx12 with vkd3d works with wine-staging 4.11.

I tried mostly vkd3d, because it gives about 15% better performance. I am running a git snapshot of vkd3d with the following patch applied against flickering: https://bugs.winehq.org/attachment.cgi?id=63174 .

Launch command: VKD3D_DEBUG=none WINEDEBUG=-all STAGING_SHARED_MEMORY=1 STAGING_WRITECOPY=1 wine64 _retail_/Wow.exe

I have a mediocre graphics card (geforce 960) and it gives me about 60-80 fps in Dazaralor and about 30fps in outdoor world boss fights with 30-40 people.

I noticed that the game hangs on area transition for about 1-2 minutes. This might be the shaders compiling. If anyone knows a workaround that would be great.

I have only tested for about 5 minutes due to lack of time, I will update the thread with any further impressions.

What does not

DX12:

As I wrote about: The game hangs in the loading screen for about 1-2 on the first area transition. Subsequent transitions are smooth.

Also you need to apply a patch to vkd3d to avoid screen flickering to black.

Workarounds

Patch applied against flickering: https://bugs.winehq.org/attachment.cgi?id=63174 .

What was not tested

Raids/Instanced content for the moment

Hardware tested

Graphics:

  • GPU: Nvidia
  • Driver: proprietary

Additional Comments

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
CurrentFedora 29 x86_64Jun 26 20194.11-stagingYes Yes YesGoldFred 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show open bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.


by Shirlee Rollins on Tuesday October 1st 2019, 3:06
I just applied some OS upgrades. It must have included a Wine update because I saw winecfg fire when I started WoW. I had problems after the latest WoW expansion similar to what others mentioned -- solid colors, etc. I found that I was able to work around it by switching monitor between "Default" and "Monitor 1" -- switching either direction worked. It seemed that subsequent Wine updates made it less frequent and eventually fixed it. I'm currently on "wine-3.20 (Staging)" and the problem is back, worse than ever.

Besides the solid blocks I have wild flashes of color constantly. Switching monitors does *not* work around it this time. I have a screenshot, and will file a bug so I can post if if that will help: gunmayhem.io/
Back