WineHQ

Selectronic SP Link

No Screenshot

Submit Screenshot

SP LINK queries an SP PRO inverter and the power system (Solar Panels, Grid and batteries)


There are 2 applications. Both work.

 SP LINK Monitor : (24.5 MB)

Intended for End Users, to view information only....

SP LINK : (24.7 MB)

Intended for System Integrators, to configure and maintain settings....


Application Details:

Version: 15.10.8388
License: Free to use
URL: http://www.selectronic.com.au/...
Votes: 0
Latest Rating: Silver
Latest Wine Version Tested: 8.0

Maintainers: About Maintainership

No maintainers. Volunteer today!

Free Download splink description page

Test Results

Old test results
The test results for this version are very old, and as such they may not represent the current state of Wine. Please consider submitting a new test report.
Selected Test Results

What works

SP LINK Monitor :

Connecting to the unit via ethernet IP address and  default port 10001

As with previous versions, the following still work...

  • Initial setup wizard
  • Main screen and all tabs
  • Changing of settings
  • Live data
  • Quick view
  • Site configuration



What does not

SP LINK Monitor ( /Selectronic SP LINK Monitor/SP LINK.exe ):

Compared to last entry...

  • USB connection not working

Unknown , not tested

  • Unable to save on local computer - will crash or "Unhandled Exemption" popup message:

Downloading the Performance data fails at the last step but selecting continue from the pop up warning allows the application to continue.

A directory is created, the progress bar continues but at the end an exception is raised and no files are saved.  It is possibly failing as it expects to start Excel which isn't installed - especially as the Unhandled Exception error message ends with "Attempted to access a missing member"

  • Saving in directories other the main drive C (Wine setup Drive C):

Unknown , not tested

SP Link - the full installer version (/Selectronic SP LINK/SP LINK.exe ):

This also works.

The comments for the minimal version above also apply here.

In addition:

The Get SP Pro's Configuration settings appear to work (under "Configuration Settings" tab). Data is fetched, colored highlights display so it appears to have communicated directly with the unit and is reporting appropriately

However ... I'm not brave enough to test whether it writes changes back to the inverter - yet!



Workarounds

None: not relevant to this installation as it was done via an ethernet connection

The comments from the previous version may still apply...

Use a USB-Rs232 converter. - Users of SP-Pro series one are already
using this by default anyway.  Then select in the connection tab
"serial" under connection type menu. Try different com port settings or
might work using "Find SP-Pro"

Unfortunately haven't found solution for issues wit saving files

What was not tested

As per previous comments.

  • Haven't checked all settings as there are lots of different ones



Hardware tested

Graphics:

  • GPU: Nvidia
  • Driver: proprietary

Additional Comments

The fact that it was a seamless install (once wine-mono was sorted) and that it runs without fault for the vital QuickView and Data View sections means I bump it to Silver level. The graphics are no more sluggish than the vmware alternative.

For the rest I'll resort to the sluggish, resource hogging, vmware installation of the full version - but only because I can't believe it works !

This is all on Debian VERSION="11 (bullseye)"

The debian apt installation of wine had issues with wine-mono not being installed, despite it being so. Rather than do battle with that, and in order to get the latest version of wine...

apt remove wine

Then get the latest direct from winehq as per this very simple youtube run through

dpkg --add-architecture i386

wget -nc https://dl.winehq.org/wine-bui...

apt-key add winehq.key

apt install software-properties-common

apt update

apt install --install-recommends winehq-stable

After that was completed succesfully...

wine --version

winecfg

wine msiexec /i Downloads/SPPRO/SP_LINK_15.10.8388.msi

then run the desired SP LINK.exe



selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
CurrentDebian GNU/Linux 11.x "Bullseye" x86_64Feb 26 20238.0N/A Yes YesSilverGlenn 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

Comments

Comments Disabled

Comments for this application have been disabled because there are no maintainers.
Back